aboutsummaryrefslogtreecommitdiffstats
path: root/devel
diff options
context:
space:
mode:
authorMichael Scheidell <scheidell@FreeBSD.org>2012-09-10 20:56:16 +0800
committerMichael Scheidell <scheidell@FreeBSD.org>2012-09-10 20:56:16 +0800
commit4eb68f089e43fc0c2df1cb992ee31886d096f73e (patch)
tree0b64861a6807d92121b7dca52623881a78c391f9 /devel
parent5e908806457ac960f490cd1511fc6971bb9703fa (diff)
downloadfreebsd-ports-gnome-4eb68f089e43fc0c2df1cb992ee31886d096f73e.tar.gz
freebsd-ports-gnome-4eb68f089e43fc0c2df1cb992ee31886d096f73e.tar.zst
freebsd-ports-gnome-4eb68f089e43fc0c2df1cb992ee31886d096f73e.zip
- Update to 2.5
- Update to OptionsNG - Remove extra Makefile #Header information PR: ports/171418 Submitted by: arrowdodger <6yearold@gmail.com> (maintainer)
Diffstat (limited to 'devel')
-rw-r--r--devel/tortoisehg2/Makefile36
-rw-r--r--devel/tortoisehg2/distinfo4
-rw-r--r--devel/tortoisehg2/files/patch-setup.py20
-rw-r--r--devel/tortoisehg2/pkg-plist12
4 files changed, 35 insertions, 37 deletions
diff --git a/devel/tortoisehg2/Makefile b/devel/tortoisehg2/Makefile
index d794091ca147..fef51a962891 100644
--- a/devel/tortoisehg2/Makefile
+++ b/devel/tortoisehg2/Makefile
@@ -1,12 +1,7 @@
-# New ports collection makefile for: tortoisehg2
-# Date created: 7 May 2011
-# Whom: arrowdodger <6yearold@gmail.com>
-#
# $FreeBSD$
-#
PORTNAME= tortoisehg
-PORTVERSION= 2.4.2
+PORTVERSION= 2.5
CATEGORIES= devel
MASTER_SITES= http://cdn.bitbucket.org/tortoisehg/targz/downloads/
@@ -25,8 +20,8 @@ RUN_DEPENDS= ${PYTHON_PKGNAMEPREFIX}qt4-core>=4.8.3:${PORTSDIR}/devel/py-qt4-cor
hg:${PORTSDIR}/devel/mercurial \
${PYTHON_SITELIBDIR}/iniparse/ini.py:${PORTSDIR}/devel/py-iniparse \
pygmentize:${PORTSDIR}/textproc/py-pygments
-
-OPTIONS= NAUTILUS "Install TortoiseHG Nautilus extension" off
+OPTIONS_DEFINE= NAUTILUS
+NAUTILUS_DESC= Install TortoiseHG Nautilus extension
INSTALLS_ICONS= yes
@@ -38,32 +33,33 @@ SUB_FILES= pkg-message
.include <bsd.port.options.mk>
-.if defined(WITHOUT_NLS)
-PLIST_SUB+= NLS="@comment "
-.else
+.if ${PORT_OPTIONS:MNLS}
PLIST_SUB+= NLS=""
USE_GETTEXT= yes
+.else
+PLIST_SUB+= NLS="@comment "
.endif
-.if defined(WITHOUT_NAUTILUS)
-PLIST_SUB+= NAUTILUS="@comment "
-.else
+.if ${PORT_OPTIONS:MNAUTILUS}
PLIST_SUB+= NAUTILUS=""
+.else
+PLIST_SUB+= NAUTILUS="@comment "
.endif
post-patch:
@${REINPLACE_CMD} -e '/_path/ s|/usr|${PREFIX}|' ${WRKSRC}/${PYSETUP}
@${REINPLACE_CMD} -e 's|%%PREFIX%%|${PREFIX}|' ${WRKSRC}/contrib/tortoisehg.desktop
@${REINPLACE_CMD} -e 's|%%LOCALBASE%%|${LOCALBASE}|' ${WRKSRC}/thg
-.if defined(WITHOUT_NLS)
- @${REINPLACE_CMD} -e 's/^%%NLS%%/# /' ${WRKSRC}/${PYSETUP}
-.else
+.if ${PORT_OPTIONS:MNLS}
@${REINPLACE_CMD} -e 's/^%%NLS%%//' ${WRKSRC}/${PYSETUP}
-.endif
-.if defined(WITHOUT_NAUTILUS)
- @${REINPLACE_CMD} -e 's/^%%NAUTILUS%%/# /' ${WRKSRC}/${PYSETUP}
.else
+ @${REINPLACE_CMD} -e 's/^%%NLS%%/# /' ${WRKSRC}/${PYSETUP}
+.endif
+.if ${PORT_OPTIONS:MNAUTILUS}
@${REINPLACE_CMD} -e 's/^%%NAUTILUS%%//' ${WRKSRC}/${PYSETUP}
+ @${REINPLACE_CMD} -e 's|%%PREFIX%%|${PREFIX}|' ${WRKSRC}/${PYSETUP}
+.else
+ @${REINPLACE_CMD} -e 's/^%%NAUTILUS%%/# /' ${WRKSRC}/${PYSETUP}
.endif
post-install:
diff --git a/devel/tortoisehg2/distinfo b/devel/tortoisehg2/distinfo
index 8ecdafd33013..ce8aaccc1d77 100644
--- a/devel/tortoisehg2/distinfo
+++ b/devel/tortoisehg2/distinfo
@@ -1,2 +1,2 @@
-SHA256 (tortoisehg-2.4.2.tar.gz) = d30963453a9d618b04dfbfebda1641cb4742133829c25ff60735236f1399108a
-SIZE (tortoisehg-2.4.2.tar.gz) = 9018020
+SHA256 (tortoisehg-2.5.tar.gz) = 8fb1fdd90517e9c24c36f62053eea862aea55e43ee28b1b898848798538b1abd
+SIZE (tortoisehg-2.5.tar.gz) = 9767802
diff --git a/devel/tortoisehg2/files/patch-setup.py b/devel/tortoisehg2/files/patch-setup.py
index 1a73fa445feb..bc55ea7c5c44 100644
--- a/devel/tortoisehg2/files/patch-setup.py
+++ b/devel/tortoisehg2/files/patch-setup.py
@@ -1,6 +1,6 @@
---- setup.py_ 2011-05-02 07:06:56.000000000 +0400
-+++ setup.py 2011-05-25 15:54:34.833312978 +0400
-@@ -283,7 +283,7 @@
+--- setup_.py 2012-09-05 19:36:36.000000000 +0400
++++ setup.py 2012-09-07 10:16:47.929179472 +0400
+@@ -280,7 +280,7 @@
class build(_build_orig):
sub_commands = [
('build_qt', None),
@@ -9,12 +9,8 @@
] + _build_orig.sub_commands
class clean(_clean_orig):
-@@ -299,10 +299,10 @@
- cmdclass = {
- 'build': build,
- 'build_qt': build_qt ,
-- 'build_mo': build_mo ,
-+%%NLS%% 'build_mo': build_mo ,
+@@ -299,7 +299,7 @@
+ 'build_mo': build_mo ,
'clean': clean,
'clean_local': clean_local,
- 'update_pot': update_pot ,
@@ -22,19 +18,19 @@
}
def setup_windows(version):
-@@ -407,11 +407,11 @@
+@@ -418,11 +418,11 @@
_data_files = [(os.path.join('share/pixmaps/tortoisehg', root),
[os.path.join(root, file_) for file_ in files])
for root, dirs, files in os.walk('icons')]
- _data_files += [(os.path.join('share', root),
- [os.path.join(root, file_) for file_ in files])
- for root, dirs, files in os.walk('locale')]
-- _data_files += [('lib/nautilus/extensions-2.0/python',
+- _data_files += [('/usr/share/nautilus-python/extensions/',
- ['contrib/nautilus-thg.py'])]
+%%NLS%% _data_files += [(os.path.join('share', root),
+%%NLS%% [os.path.join(root, file_) for file_ in files])
+%%NLS%% for root, dirs, files in os.walk('locale')]
-+%%NAUTILUS%% _data_files += [('lib/nautilus/extensions-2.0/python',
++%%NAUTILUS%% _data_files += [('%%PREFIX%%/lib/nautilus/extensions-2.0/python',
+%%NAUTILUS%% ['contrib/nautilus-thg.py'])]
# Create a config.py. Distributions will need to supply their own
diff --git a/devel/tortoisehg2/pkg-plist b/devel/tortoisehg2/pkg-plist
index a7d715a56e3f..a3bc9c65f632 100644
--- a/devel/tortoisehg2/pkg-plist
+++ b/devel/tortoisehg2/pkg-plist
@@ -51,6 +51,9 @@ bin/thg
%%PYTHON_SITELIBDIR%%/tortoisehg/hgqt/cslist.py
%%PYTHON_SITELIBDIR%%/tortoisehg/hgqt/cslist.pyc
%%PYTHON_SITELIBDIR%%/tortoisehg/hgqt/cslist.pyo
+%%PYTHON_SITELIBDIR%%/tortoisehg/hgqt/customtools.py
+%%PYTHON_SITELIBDIR%%/tortoisehg/hgqt/customtools.pyc
+%%PYTHON_SITELIBDIR%%/tortoisehg/hgqt/customtools.pyo
%%PYTHON_SITELIBDIR%%/tortoisehg/hgqt/decorators.py
%%PYTHON_SITELIBDIR%%/tortoisehg/hgqt/decorators.pyc
%%PYTHON_SITELIBDIR%%/tortoisehg/hgqt/decorators.pyo
@@ -60,6 +63,9 @@ bin/thg
%%PYTHON_SITELIBDIR%%/tortoisehg/hgqt/docklog.py
%%PYTHON_SITELIBDIR%%/tortoisehg/hgqt/docklog.pyc
%%PYTHON_SITELIBDIR%%/tortoisehg/hgqt/docklog.pyo
+%%PYTHON_SITELIBDIR%%/tortoisehg/hgqt/filectxactions.py
+%%PYTHON_SITELIBDIR%%/tortoisehg/hgqt/filectxactions.pyc
+%%PYTHON_SITELIBDIR%%/tortoisehg/hgqt/filectxactions.pyo
%%PYTHON_SITELIBDIR%%/tortoisehg/hgqt/filedata.py
%%PYTHON_SITELIBDIR%%/tortoisehg/hgqt/filedata.pyc
%%PYTHON_SITELIBDIR%%/tortoisehg/hgqt/filedata.pyo
@@ -78,6 +84,9 @@ bin/thg
%%PYTHON_SITELIBDIR%%/tortoisehg/hgqt/fileview.py
%%PYTHON_SITELIBDIR%%/tortoisehg/hgqt/fileview.pyc
%%PYTHON_SITELIBDIR%%/tortoisehg/hgqt/fileview.pyo
+%%PYTHON_SITELIBDIR%%/tortoisehg/hgqt/graft.py
+%%PYTHON_SITELIBDIR%%/tortoisehg/hgqt/graft.pyc
+%%PYTHON_SITELIBDIR%%/tortoisehg/hgqt/graft.pyo
%%PYTHON_SITELIBDIR%%/tortoisehg/hgqt/graph.py
%%PYTHON_SITELIBDIR%%/tortoisehg/hgqt/graph.pyc
%%PYTHON_SITELIBDIR%%/tortoisehg/hgqt/graph.pyo
@@ -336,9 +345,6 @@ bin/thg
%%PYTHON_SITELIBDIR%%/tortoisehg/util/paths.py
%%PYTHON_SITELIBDIR%%/tortoisehg/util/paths.pyc
%%PYTHON_SITELIBDIR%%/tortoisehg/util/paths.pyo
-%%PYTHON_SITELIBDIR%%/tortoisehg/util/prej.py
-%%PYTHON_SITELIBDIR%%/tortoisehg/util/prej.pyc
-%%PYTHON_SITELIBDIR%%/tortoisehg/util/prej.pyo
%%PYTHON_SITELIBDIR%%/tortoisehg/util/settings.py
%%PYTHON_SITELIBDIR%%/tortoisehg/util/settings.pyc
%%PYTHON_SITELIBDIR%%/tortoisehg/util/settings.pyo