aboutsummaryrefslogtreecommitdiffstats
path: root/devel
diff options
context:
space:
mode:
authorrakuco <rakuco@FreeBSD.org>2015-08-18 18:51:01 +0800
committerrakuco <rakuco@FreeBSD.org>2015-08-18 18:51:01 +0800
commit4f4c3f4858e41faac2d9b5883898c35afbe1c327 (patch)
treece0de1d0b7bda5eb762e64fe58300177d350898c /devel
parent8a49f8f056abc122912107313fddc7b1ea728c39 (diff)
downloadfreebsd-ports-gnome-4f4c3f4858e41faac2d9b5883898c35afbe1c327.tar.gz
freebsd-ports-gnome-4f4c3f4858e41faac2d9b5883898c35afbe1c327.tar.zst
freebsd-ports-gnome-4f4c3f4858e41faac2d9b5883898c35afbe1c327.zip
Uses/cmake.mk: Replace CMAKE_ENV with CONFIGURE_ENV.
Instead of defining a variable that is almost always based on CONFIGURE_ENV, just use CONFIGURE_ENV directly. This also matches the behavior of other ports that do not use autotools (so most ports can just worry about CONFIGURE_ENV). Additionally, the fact that we do not use ?= means we do not have problems if another file in Uses/ needs to set CONFIGURE_ENV (with CMAKE_ENV, the order of the arguments to USES would matter). Ports which set CMAKE_ENV have been adjusted accordingly. In most cases, CMAKE_ENV was just replaced with CONFIGURE_ENV, the exceptions being: * databases/sqliteman: CMAKE_ENV line removed; setting QMAKESPEC there has no effect on the build system. * devel/freeocl: CMAKE_ENV line removed; FREEOCL_CXX_COMPILER is already retrieved from the CMAKE_CXX_COMPILER variable in the build system. * graphics/openimageio: CMAKE_ENV line removed; setting Qt variables there has no effect on the build system. Reviewed by: makc Differential Revision: https://reviews.freebsd.org/D3403
Diffstat (limited to 'devel')
-rw-r--r--devel/freeocl/Makefile1
-rw-r--r--devel/qca-qt5/Makefile2
-rw-r--r--devel/qca/Makefile2
3 files changed, 2 insertions, 3 deletions
diff --git a/devel/freeocl/Makefile b/devel/freeocl/Makefile
index 94420852b45e..06f3b17a1450 100644
--- a/devel/freeocl/Makefile
+++ b/devel/freeocl/Makefile
@@ -25,7 +25,6 @@ USES= cmake compiler:c++11-lib
USE_LDCONFIG= yes
CXXFLAGS+= -pthread -std=gnu++0x
-CMAKE_ENV+= FREEOCL_CXX_COMPILER="${CXX}"
CFLAGS_i386= -msse
diff --git a/devel/qca-qt5/Makefile b/devel/qca-qt5/Makefile
index 4c3ae8f47ed2..8bfbec62fe14 100644
--- a/devel/qca-qt5/Makefile
+++ b/devel/qca-qt5/Makefile
@@ -19,7 +19,7 @@ CMAKE_ARGS= -DBUILD_PLUGINS=none -DBUILD_TESTS=no -DQT5_BUILD=yes \
-DQCA_FEATURE_INSTALL_DIR=${QT_MKSPECDIR}/features \
-DQCA_MAN_INSTALL_DIR=${MANPREFIX}/man \
-DQCA_SUFFIX=qt5
-CMAKE_ENV= QC_CERTSTORE_PATH=${LOCALBASE}/share/certs/ca-root-nss.crt
+CONFIGURE_ENV= QC_CERTSTORE_PATH=${LOCALBASE}/share/certs/ca-root-nss.crt
USE_LDCONFIG= yes
USE_QT5= buildtools_build core network qmake_build
diff --git a/devel/qca/Makefile b/devel/qca/Makefile
index 0b8314602239..7ecbf294d355 100644
--- a/devel/qca/Makefile
+++ b/devel/qca/Makefile
@@ -18,7 +18,7 @@ CMAKE_ARGS= -DBUILD_PLUGINS=none -DBUILD_TESTS=no -DQT4_BUILD=yes \
-DPKGCONFIG_INSTALL_PREFIX=${PREFIX}/libdata/pkgconfig \
-DQCA_FEATURE_INSTALL_DIR=${QT_MKSPECDIR}/features \
-DQCA_MAN_INSTALL_DIR=${MANPREFIX}/man
-CMAKE_ENV= QC_CERTSTORE_PATH=${LOCALBASE}/share/certs/ca-root-nss.crt
+CONFIGURE_ENV= QC_CERTSTORE_PATH=${LOCALBASE}/share/certs/ca-root-nss.crt
USE_LDCONFIG= yes
USE_QT4= corelib moc_build qmake_build rcc_build