aboutsummaryrefslogtreecommitdiffstats
path: root/devel
diff options
context:
space:
mode:
authorKirill Ponomarev <krion@FreeBSD.org>2004-03-10 23:35:51 +0800
committerKirill Ponomarev <krion@FreeBSD.org>2004-03-10 23:35:51 +0800
commit50d44db5d5cc5396e0c5d2e28b21979f74e47e9d (patch)
treed6d3118547f90658824ffabcb7cea371dad98aa0 /devel
parentf81674b8959d5c7b99c468f0abf37d4fee4497d1 (diff)
downloadfreebsd-ports-gnome-50d44db5d5cc5396e0c5d2e28b21979f74e47e9d.tar.gz
freebsd-ports-gnome-50d44db5d5cc5396e0c5d2e28b21979f74e47e9d.tar.zst
freebsd-ports-gnome-50d44db5d5cc5396e0c5d2e28b21979f74e47e9d.zip
Add gsoap 2.5.2,
The gSOAP Web services development toolkit offers an XML to C/C++ language binding to ease the development of SOAP/XML Web services in C and C/C++. Most toolkits for C++ Web services adopt a SOAP-centric view and offer APIs that require the use of class libraries for SOAP-specific data structures. This often forces a user to adapt the application logic to these libraries. In contrast, gSOAP provides a transparent SOAP API through the use of proven compiler technologies. These technologies leverage strong typing to map XML schemas to C/C++ definitions. Strong typing provides a greater assurance on content validation of both WSDL schemas and SOAP/XML messages. WWW: http://www.cs.fsu.edu/~engelen/soap.html PR: ports/64019 Submitted by: Sergey Matveychuk <sem@ciam.ru>
Diffstat (limited to 'devel')
-rw-r--r--devel/Makefile1
-rw-r--r--devel/gsoap/Makefile24
-rw-r--r--devel/gsoap/distinfo2
-rw-r--r--devel/gsoap/pkg-descr11
-rw-r--r--devel/gsoap/pkg-plist7
5 files changed, 45 insertions, 0 deletions
diff --git a/devel/Makefile b/devel/Makefile
index 2373ee5d7a0b..843c01408879 100644
--- a/devel/Makefile
+++ b/devel/Makefile
@@ -284,6 +284,7 @@
SUBDIR += gorm
SUBDIR += gperf
SUBDIR += gputils
+ SUBDIR += gsoap
SUBDIR += gtgt
SUBDIR += gtranslator
SUBDIR += gvd
diff --git a/devel/gsoap/Makefile b/devel/gsoap/Makefile
new file mode 100644
index 000000000000..9dc9c7061ecc
--- /dev/null
+++ b/devel/gsoap/Makefile
@@ -0,0 +1,24 @@
+# New ports collection makefile for: gsoap
+# Date created: 8 March 2004
+# Whom: Sergey Matveychuk <sem@ciam.ru>
+#
+# $FreeBSD$
+#
+
+PORTNAME= gsoap
+PORTVERSION= 2.5.2
+CATEGORIES= devel
+MASTER_SITES= ${MASTER_SITE_SOURCEFORGE}
+MASTER_SITE_SUBDIR= gsoap2
+DISTNAME= gsoap-2.5
+
+MAINTAINER= sem@ciam.ru
+COMMENT= Generator Tools for Coding SOAP/XML Web Services in C and C++
+
+USE_GMAKE= yes
+GNU_CONFIGURE= yes
+CONFIGURE_TARGET= --build=${MACHINE_ARCH}-portbld-freebsd${OSREL}
+
+ONLY_FOR_ARCHS= i386
+
+.include <bsd.port.mk>
diff --git a/devel/gsoap/distinfo b/devel/gsoap/distinfo
new file mode 100644
index 000000000000..88d8ce7b6a12
--- /dev/null
+++ b/devel/gsoap/distinfo
@@ -0,0 +1,2 @@
+MD5 (gsoap-2.5.tar.gz) = 4cfb29b34728aadf3c3c6d5847d6c40b
+SIZE (gsoap-2.5.tar.gz) = 2758220
diff --git a/devel/gsoap/pkg-descr b/devel/gsoap/pkg-descr
new file mode 100644
index 000000000000..884052579aea
--- /dev/null
+++ b/devel/gsoap/pkg-descr
@@ -0,0 +1,11 @@
+The gSOAP Web services development toolkit offers an XML to C/C++ language
+binding to ease the development of SOAP/XML Web services in C and C/C++.
+Most toolkits for C++ Web services adopt a SOAP-centric view and offer APIs
+that require the use of class libraries for SOAP-specific data structures.
+This often forces a user to adapt the application logic to these libraries.
+In contrast, gSOAP provides a transparent SOAP API through the use of proven
+compiler technologies. These technologies leverage strong typing to map
+XML schemas to C/C++ definitions. Strong typing provides a greater assurance
+on content validation of both WSDL schemas and SOAP/XML messages.
+
+WWW: http://www.cs.fsu.edu/~engelen/soap.html
diff --git a/devel/gsoap/pkg-plist b/devel/gsoap/pkg-plist
new file mode 100644
index 000000000000..658fe017e935
--- /dev/null
+++ b/devel/gsoap/pkg-plist
@@ -0,0 +1,7 @@
+bin/soapcpp2
+bin/wsdl2h
+include/stdsoap2.h
+lib/libgsoap++.a
+lib/libgsoap.a
+lib/libgsoapck++.a
+lib/libgsoapck.a