aboutsummaryrefslogtreecommitdiffstats
path: root/devel
diff options
context:
space:
mode:
authornovel <novel@FreeBSD.org>2016-10-29 20:06:25 +0800
committernovel <novel@FreeBSD.org>2016-10-29 20:06:25 +0800
commit5264a33e73a99f382f7a41e24345632ccac9a691 (patch)
tree1c75b677c0184bd2d395025dc0df57af63cc1d32 /devel
parent0b25ab04e2f118890d4fd3c3bda5c6826e5cec63 (diff)
downloadfreebsd-ports-gnome-5264a33e73a99f382f7a41e24345632ccac9a691.tar.gz
freebsd-ports-gnome-5264a33e73a99f382f7a41e24345632ccac9a691.tar.zst
freebsd-ports-gnome-5264a33e73a99f382f7a41e24345632ccac9a691.zip
Add py-glance-store 0.18.0, openStack Image Service Store Library.
PR: 213769 Submitted by: Alexander Nusov <alexander.nusov@nfvexpress.com>
Diffstat (limited to 'devel')
-rw-r--r--devel/Makefile1
-rw-r--r--devel/py-glance-store/Makefile34
-rw-r--r--devel/py-glance-store/distinfo3
-rw-r--r--devel/py-glance-store/pkg-descr3
4 files changed, 41 insertions, 0 deletions
diff --git a/devel/Makefile b/devel/Makefile
index ba6953507386..1199f0affa46 100644
--- a/devel/Makefile
+++ b/devel/Makefile
@@ -4182,6 +4182,7 @@
SUBDIR += py-gitless
SUBDIR += py-gitosis
SUBDIR += py-gitpython
+ SUBDIR += py-glance-store
SUBDIR += py-glob2
SUBDIR += py-gobject
SUBDIR += py-gobject3
diff --git a/devel/py-glance-store/Makefile b/devel/py-glance-store/Makefile
new file mode 100644
index 000000000000..a69c4b4b671d
--- /dev/null
+++ b/devel/py-glance-store/Makefile
@@ -0,0 +1,34 @@
+# Created by: Alexander Nusov <alexander.nusov@nfvexpress.com>
+# $FreeBSD$
+
+PORTNAME= glance-store
+PORTVERSION= 0.18.0
+CATEGORIES= devel python
+MASTER_SITES= CHEESESHOP
+PKGNAMEPREFIX= ${PYTHON_PKGNAMEPREFIX}
+DISTNAME= glance_store-${PORTVERSION}
+
+MAINTAINER= alexander.nusov@nfvexpress.com
+COMMENT= OpenStack Image Service Store Library
+
+BUILD_DEPENDS= ${PYTHON_PKGNAMEPREFIX}pbr>=1.6:devel/py-pbr
+RUN_DEPENDS= ${PYTHON_PKGNAMEPREFIX}enum34>=0:devel/py-enum34 \
+ ${PYTHON_PKGNAMEPREFIX}stevedore>=1.16.0:devel/py-stevedore \
+ ${PYTHON_PKGNAMEPREFIX}six>=1.9.0:devel/py-six \
+ ${PYTHON_PKGNAMEPREFIX}requests>=2.10.0:www/py-requests \
+ ${PYTHON_PKGNAMEPREFIX}keystoneclient>=0:net/py-keystoneclient \
+ ${PYTHON_PKGNAMEPREFIX}oslo.utils>=3.16.0:devel/py-oslo.utils \
+ ${PYTHON_PKGNAMEPREFIX}oslo.serialization>=1.10.0:devel/py-oslo.serialization \
+ ${PYTHON_PKGNAMEPREFIX}oslo.i18n>=2.1.0:devel/py-oslo.i18n \
+ ${PYTHON_PKGNAMEPREFIX}oslo.config>=3.14.0:devel/py-oslo.config \
+ ${PYTHON_PKGNAMEPREFIX}oslo.concurrency>=3.8.0:devel/py-oslo.concurrency \
+ ${PYTHON_PKGNAMEPREFIX}jsonschema>=0:devel/py-jsonschema \
+ ${PYTHON_PKGNAMEPREFIX}eventlet>=0:net/py-eventlet \
+ ${PYTHON_PKGNAMEPREFIX}debtcollector>=1.2.0:devel/py-debtcollector
+
+NO_ARCH= yes
+
+USES= python
+USE_PYTHON= autoplist distutils
+
+.include <bsd.port.mk>
diff --git a/devel/py-glance-store/distinfo b/devel/py-glance-store/distinfo
new file mode 100644
index 000000000000..783bcd38118e
--- /dev/null
+++ b/devel/py-glance-store/distinfo
@@ -0,0 +1,3 @@
+TIMESTAMP = 1476648738
+SHA256 (glance_store-0.18.0.tar.gz) = 56b8b33f5deb74c652bd82d781aa82459e14152a5ee5c74726f0f1545c2355a7
+SIZE (glance_store-0.18.0.tar.gz) = 126949
diff --git a/devel/py-glance-store/pkg-descr b/devel/py-glance-store/pkg-descr
new file mode 100644
index 000000000000..7837a19c2a5e
--- /dev/null
+++ b/devel/py-glance-store/pkg-descr
@@ -0,0 +1,3 @@
+OpenStack Image Service Store Library.
+
+WWW: https://pypi.python.org/pypi/glance_store