aboutsummaryrefslogtreecommitdiffstats
path: root/devel
diff options
context:
space:
mode:
authorjhb <jhb@FreeBSD.org>2018-08-02 01:49:33 +0800
committerjhb <jhb@FreeBSD.org>2018-08-02 01:49:33 +0800
commit52d6642dda85913ac0a0612bf5f05f645a825b3c (patch)
tree19e509051a922545312aec6ee277b655860e2829 /devel
parent7d168237506cf275f9375cca1784935202ed2ab0 (diff)
downloadfreebsd-ports-gnome-52d6642dda85913ac0a0612bf5f05f645a825b3c.tar.gz
freebsd-ports-gnome-52d6642dda85913ac0a0612bf5f05f645a825b3c.tar.zst
freebsd-ports-gnome-52d6642dda85913ac0a0612bf5f05f645a825b3c.zip
base/binutils: Cleanup packing lists.
- Use BUREMOVE to strip binutils tools not installed by the base/binutils package. - Update BUREMOVE logic in devel/binutils to cope with the base package which installs tools without a BUTARGET- prefix. - Use MANPREFIX for BUREMOVE to handle the PREFIX=/usr case used by base/binutils. - Remove binutils headers and libraries explicitly from the staging area for base/binutils. - Add missing plist entries for binutils binaries installed under a BUTARGET subdirectory. Approved by: bapt (implicit for base/*) Differential Revision: https://reviews.freebsd.org/D16464
Diffstat (limited to 'devel')
-rw-r--r--devel/binutils/Makefile6
1 files changed, 5 insertions, 1 deletions
diff --git a/devel/binutils/Makefile b/devel/binutils/Makefile
index 676c856dce16..5ea9e0025c4d 100644
--- a/devel/binutils/Makefile
+++ b/devel/binutils/Makefile
@@ -145,11 +145,15 @@ post-install:
${MV} ${STAGEDIR}/${MANDIR}1/objdump.1 ${STAGEDIR}/${MANDIR}1/${BUTARGET}-objdump.1
${GZIP_CMD} ${STAGEDIR}/${MANDIR}1/${BUTARGET}-objdump.1
${LN} -fs ${BUTARGET}-objdump.1.gz ${STAGEDIR}/${MANDIR}1/objdump.1.gz
+ @${RM} -r ${STAGEDIR}${PREFIX}/include
+ @${RM} -r ${STAGEDIR}${PREFIX}/lib
.endif
.endif
.for tool in ${BUREMOVE}
@${RM} ${STAGEDIR}${PREFIX}/bin/${BUTARGET}-${tool} \
- ${STAGEDIR}${PREFIX}/man/man1/${BUTARGET}-${tool}.1 \
+ ${STAGEDIR}${PREFIX}/bin/${tool} \
+ ${STAGEDIR}${MANPREFIX}/man/man1/${BUTARGET}-${tool}.1 \
+ ${STAGEDIR}${MANPREFIX}/man/man1/${tool}.1 \
${STAGEDIR}${PREFIX}/${BUTARGET}/bin/${tool}
.endfor
.if defined(BUREMOVE) && ${BUREMOVE:Mld}