aboutsummaryrefslogtreecommitdiffstats
path: root/devel
diff options
context:
space:
mode:
authormezz <mezz@FreeBSD.org>2008-01-08 13:08:51 +0800
committermezz <mezz@FreeBSD.org>2008-01-08 13:08:51 +0800
commit52df1bc81fa8076ec953c3516a7811fb75dee9c2 (patch)
tree358c01d7c858b34fa5233f5cf9da104405f46b47 /devel
parent5c291b69f621ec7d4dc3c1620ad5f593a12537d4 (diff)
downloadfreebsd-ports-gnome-52df1bc81fa8076ec953c3516a7811fb75dee9c2.tar.gz
freebsd-ports-gnome-52df1bc81fa8076ec953c3516a7811fb75dee9c2.tar.zst
freebsd-ports-gnome-52df1bc81fa8076ec953c3516a7811fb75dee9c2.zip
Update to 2.20.1.
Diffstat (limited to 'devel')
-rw-r--r--devel/libgtop/Makefile2
-rw-r--r--devel/libgtop/distinfo6
-rw-r--r--devel/libgtop/pkg-plist4
3 files changed, 6 insertions, 6 deletions
diff --git a/devel/libgtop/Makefile b/devel/libgtop/Makefile
index e2c6ee0eb239..f6ca4775389f 100644
--- a/devel/libgtop/Makefile
+++ b/devel/libgtop/Makefile
@@ -7,7 +7,7 @@
#
PORTNAME= libgtop
-PORTVERSION= 2.20.0
+PORTVERSION= 2.20.1
CATEGORIES= devel gnome
MASTER_SITES= ${MASTER_SITE_GNOME}
MASTER_SITE_SUBDIR= sources/${PORTNAME}/${PORTVERSION:C/^([0-9]+\.[0-9]+).*/\1/}
diff --git a/devel/libgtop/distinfo b/devel/libgtop/distinfo
index a0808660ecf5..c2752cf6af14 100644
--- a/devel/libgtop/distinfo
+++ b/devel/libgtop/distinfo
@@ -1,3 +1,3 @@
-MD5 (gnome2/libgtop-2.20.0.tar.bz2) = ddc05ffe9499294801cbd5fdac949045
-SHA256 (gnome2/libgtop-2.20.0.tar.bz2) = 5cae684d0af69193d9b6c31bbb90f74350855a23f245aef8538c17a877ba04a5
-SIZE (gnome2/libgtop-2.20.0.tar.bz2) = 766106
+MD5 (gnome2/libgtop-2.20.1.tar.bz2) = b6fa671e8325bd8dbce684527791225a
+SHA256 (gnome2/libgtop-2.20.1.tar.bz2) = 1e4d9cdedee5105c99a7bf3363e9bc375bff82923e24f55e475050937f482135
+SIZE (gnome2/libgtop-2.20.1.tar.bz2) = 770145
diff --git a/devel/libgtop/pkg-plist b/devel/libgtop/pkg-plist
index 54b982f347b5..88f66a24bd55 100644
--- a/devel/libgtop/pkg-plist
+++ b/devel/libgtop/pkg-plist
@@ -1,7 +1,6 @@
bin/libgtop_daemon2
bin/libgtop_server2
include/libgtop-2.0/glibtop.h
-include/libgtop-2.0/glibtop_private.h
include/libgtop-2.0/glibtop/close.h
include/libgtop-2.0/glibtop/command.h
include/libgtop-2.0/glibtop/cpu.h
@@ -39,6 +38,7 @@ include/libgtop-2.0/glibtop/union.h
include/libgtop-2.0/glibtop/uptime.h
include/libgtop-2.0/glibtop/version.h
include/libgtop-2.0/glibtop_machine.h
+include/libgtop-2.0/glibtop_private.h
include/libgtop-2.0/glibtop_server.h
include/libgtop-2.0/glibtop_suid.h
include/libgtop-2.0/libgtopconfig.h
@@ -169,9 +169,9 @@ share/locale/xh/LC_MESSAGES/libgtop-2.0.mo
share/locale/zh_CN/LC_MESSAGES/libgtop-2.0.mo
share/locale/zh_HK/LC_MESSAGES/libgtop-2.0.mo
share/locale/zh_TW/LC_MESSAGES/libgtop-2.0.mo
+@dirrm %%DOCSDIR%%
@dirrm include/libgtop-2.0/glibtop
@dirrm include/libgtop-2.0
-@dirrm %%DOCSDIR%%
@dirrmtry share/locale/zh_HK/LC_MESSAGES
@dirrmtry share/locale/zh_HK
@dirrmtry share/locale/xh/LC_MESSAGES
dation/dexon-consensus.svg?style=svg&circle-token=faed911ec07618dfbd6868b09181aa2046b550d8">

DEXON Consensus

Getting Started

Prerequisites

Installation

  1. Clone the repo git clone https://github.com/dexon-foundation/dexon-consensus.git cd dexon-consensus

  2. Setup GOPATH, the GOPATH could be anywhere in the system. Here we use $HOME/go: export GOPATH=$HOME/go export PATH=$GOPATH/bin:$PATH You should write these settings to your .bashrc file.

  3. Install go dependency management tool ./bin/install_tools.sh

  4. Install all dependencies dep ensure

Run Unit Tests

make pre-submit

Simulation

Simulation with Nodes connected by HTTP

  1. Setup the configuration under ./test.toml
  2. Compile and install the cmd dexon-simulation
make
  1. Run simulation:
dexcon-simulation -config test.toml -init

Simulation with test.Scheduler

  1. Setup the configuration under ./test.toml
  2. Compile and install the cmd dexon-simulation-with-scheduler
make
  1. Run simulation with scheduler:
dexcon-simulation-with-scheduler -config test.toml