aboutsummaryrefslogtreecommitdiffstats
path: root/devel
diff options
context:
space:
mode:
authorDmitry Marakasov <amdmi3@FreeBSD.org>2015-03-05 23:44:38 +0800
committerDmitry Marakasov <amdmi3@FreeBSD.org>2015-03-05 23:44:38 +0800
commit56642f54f01f289823fda231b530088a283c44fb (patch)
tree57716259ca29ede072f25aa3c8d34accd11513f4 /devel
parent50573d226a0725a226f30ba06d247a2133de0107 (diff)
downloadfreebsd-ports-gnome-56642f54f01f289823fda231b530088a283c44fb.tar.gz
freebsd-ports-gnome-56642f54f01f289823fda231b530088a283c44fb.tar.zst
freebsd-ports-gnome-56642f54f01f289823fda231b530088a283c44fb.zip
- Don't require openssl from ports
- Make SCons preserve environment for e.g. ccache to work properly PR: 198225 Submitted by: amdmi3 Approved by: FreeBSD@ShaneWare.Biz (maintainer)
Diffstat (limited to 'devel')
-rw-r--r--devel/godot/Makefile3
-rw-r--r--devel/godot/files/patch-SConstruct13
-rw-r--r--devel/godot/files/patch-platform_x11_detect.py29
3 files changed, 37 insertions, 8 deletions
diff --git a/devel/godot/Makefile b/devel/godot/Makefile
index 8bc014d3b208..f617a64e298b 100644
--- a/devel/godot/Makefile
+++ b/devel/godot/Makefile
@@ -3,6 +3,7 @@
PORTNAME= godot
PORTVERSION= 1.0
+PORTREVISION= 1
CATEGORIES= devel games
MAINTAINER= FreeBSD@Shaneware.biz
@@ -23,8 +24,6 @@ USES= scons pkgconfig compiler
USE_XORG= x11 xcursor
USE_GL= glu
USE_OPENSSL= yes
-# uses pkg-config to find ssl - pkg-config only finds port version
-WITH_OPENSSL_PORT= yes
MAKE_ARGS+= platform=x11
diff --git a/devel/godot/files/patch-SConstruct b/devel/godot/files/patch-SConstruct
index 834311c60f61..8221b4e2b834 100644
--- a/devel/godot/files/patch-SConstruct
+++ b/devel/godot/files/patch-SConstruct
@@ -1,5 +1,14 @@
---- SConstruct.orig 2014-12-16 05:19:18.000000000 +1030
-+++ SConstruct 2015-01-27 00:22:23.169373963 +1030
+--- SConstruct.orig 2014-12-15 21:49:18.000000000 +0300
++++ SConstruct 2015-03-03 08:24:01.000000000 +0300
+@@ -60,7 +60,7 @@
+ if (os.getenv("VSINSTALLDIR")==None):
+ custom_tools=['mingw']
+
+-env_base=Environment(tools=custom_tools,ENV = {'PATH' : os.environ['PATH']});
++env_base=Environment(tools=custom_tools,ENV = os.environ);
+ #env_base=Environment(tools=custom_tools);
+ env_base.global_defaults=global_defaults
+ env_base.android_source_modules=[]
@@ -110,7 +110,8 @@
opts.Add('builtin_zlib','Use built-in zlib (yes/no)','yes')
opts.Add('openssl','Use OpenSSL (yes/no/builtin)','no')
diff --git a/devel/godot/files/patch-platform_x11_detect.py b/devel/godot/files/patch-platform_x11_detect.py
index 06e97469f716..b886a17af2d4 100644
--- a/devel/godot/files/patch-platform_x11_detect.py
+++ b/devel/godot/files/patch-platform_x11_detect.py
@@ -1,6 +1,18 @@
---- platform/x11/detect.py.orig 2014-12-16 05:19:18.000000000 +1030
-+++ platform/x11/detect.py 2015-01-23 16:08:21.497280349 +1030
-@@ -72,17 +72,16 @@
+--- platform/x11/detect.py.orig 2014-12-15 21:49:18.000000000 +0300
++++ platform/x11/detect.py 2015-03-03 07:01:34.000000000 +0300
+@@ -29,11 +29,6 @@
+ print("X11 not found.. x11 disabled.")
+ return False
+
+- ssl_error=os.system("pkg-config openssl --modversion > /dev/null ")
+- if (ssl_error):
+- print("OpenSSL not found.. x11 disabled.")
+- return False
+-
+ x11_error=os.system("pkg-config xcursor --modversion > /dev/null ")
+ if (x11_error):
+ print("xcursor not found.. x11 disabled.")
+@@ -72,17 +67,16 @@
env.Append(CPPPATH=['#platform/x11'])
if (env["use_llvm"]=="yes"):
@@ -28,7 +40,16 @@
#if (env["tools"]=="no"):
-@@ -128,11 +127,6 @@
+@@ -105,7 +99,7 @@
+
+ env.ParseConfig('pkg-config x11 --cflags --libs')
+ env.ParseConfig('pkg-config xcursor --cflags --libs')
+- env.ParseConfig('pkg-config openssl --cflags --libs')
++ env.ParseConfig('echo -lssl -lcrypto')
+
+
+ env.ParseConfig('pkg-config freetype2 --cflags --libs')
+@@ -128,11 +122,6 @@
env.Append(LINKFLAGS=['-m64','-L/usr/lib/i686-linux-gnu'])