aboutsummaryrefslogtreecommitdiffstats
path: root/devel
diff options
context:
space:
mode:
authorroam <roam@FreeBSD.org>2009-04-10 17:11:43 +0800
committerroam <roam@FreeBSD.org>2009-04-10 17:11:43 +0800
commit568cb46ce92ec3677601911b6f0ff81927240871 (patch)
tree6588c839d45bff358005fca3b7c34c9a57e531cd /devel
parenta693fd5a2790b0fce8e38cf31eecfd02f7722591 (diff)
downloadfreebsd-ports-gnome-568cb46ce92ec3677601911b6f0ff81927240871.tar.gz
freebsd-ports-gnome-568cb46ce92ec3677601911b6f0ff81927240871.tar.zst
freebsd-ports-gnome-568cb46ce92ec3677601911b6f0ff81927240871.zip
Update to libelf-0.8.10:
- the w32/Makefile configure fix was integrated upstream - add the SANITY knob for stringent ELF header checks, on by default to reflect both the upstream default and pre-0.8.10 behavior While I'm here, refresh the patches with quilt --no-timestamps and add patch descriptions.
Diffstat (limited to 'devel')
-rw-r--r--devel/libelf/Makefile12
-rw-r--r--devel/libelf/distinfo6
-rw-r--r--devel/libelf/files/patch-Makefile.in6
-rw-r--r--devel/libelf/files/patch-configure34
-rw-r--r--devel/libelf/files/patch-lib::sys_elf.h.in6
5 files changed, 31 insertions, 33 deletions
diff --git a/devel/libelf/Makefile b/devel/libelf/Makefile
index d23ae7440255..017951cc3b61 100644
--- a/devel/libelf/Makefile
+++ b/devel/libelf/Makefile
@@ -6,8 +6,7 @@
#
PORTNAME= libelf
-PORTVERSION= 0.8.9
-PORTREVISION= 1
+PORTVERSION= 0.8.10
CATEGORIES= devel
MASTER_SITES= http://www.mr511.de/software/ \
${MASTER_SITE_SUNSITE}
@@ -17,7 +16,8 @@ MAINTAINER= roam@FreeBSD.org
COMMENT= A public ELF file access library similar to libelf(3) in Solaris
OPTIONS= EXTENDED "ELF format extensions" on \
- NLS "Native Language Support" on
+ NLS "Native Language Support" on \
+ SANITY "Avoid loading invalid ELF files" on
.include <bsd.port.pre.mk>
@@ -44,6 +44,12 @@ CONFIGURE_ARGS+= --enable-extended-format
CONFIGURE_ARGS+= --disable-extended-format
.endif
+.if !defined(WITHOUT_SANITY)
+CONFIGURE_ARGS+= --enable-sanity-checks
+.else
+CONFIGURE_ARGS+= --disable-sanity-checks
+.endif
+
.if ${OSVERSION} < 600102
FILES_TO_PATCH=lib/32.fsize.c lib/64.xlatetof.c lib/cook.c lib/gelf.h lib/gelftrans.c
diff --git a/devel/libelf/distinfo b/devel/libelf/distinfo
index c207e6622e8f..d30fb10528f1 100644
--- a/devel/libelf/distinfo
+++ b/devel/libelf/distinfo
@@ -1,3 +1,3 @@
-MD5 (libelf-0.8.9.tar.gz) = 11904a77b948bcfab671e80100b6098d
-SHA256 (libelf-0.8.9.tar.gz) = 9eafb75460233a354012a6e7f2af54fe7e569dadb6bb532ffaa59df22d36ba18
-SIZE (libelf-0.8.9.tar.gz) = 146250
+MD5 (libelf-0.8.10.tar.gz) = 9db4d36c283d9790d8fa7df1f4d7b4d9
+SHA256 (libelf-0.8.10.tar.gz) = 2d7995485c0f8f4beef98d8c1b7970b1efb34193c1a764d91f28624d83302a09
+SIZE (libelf-0.8.10.tar.gz) = 147824
diff --git a/devel/libelf/files/patch-Makefile.in b/devel/libelf/files/patch-Makefile.in
index 7e3c457ecaec..af1e8d161a27 100644
--- a/devel/libelf/files/patch-Makefile.in
+++ b/devel/libelf/files/patch-Makefile.in
@@ -1,5 +1,7 @@
---- Makefile.in.orig Fri Aug 19 16:51:51 2005
-+++ Makefile.in Fri Aug 19 16:52:13 2005
+Fix the pkgconfig data directory path.
+
+--- Makefile.in.orig
++++ Makefile.in
@@ -23,7 +23,7 @@
exec_prefix = @exec_prefix@
libdir = @libdir@
diff --git a/devel/libelf/files/patch-configure b/devel/libelf/files/patch-configure
index bad5f309dc6f..7ca3e6f67d4f 100644
--- a/devel/libelf/files/patch-configure
+++ b/devel/libelf/files/patch-configure
@@ -1,6 +1,12 @@
---- configure.orig Tue Sep 26 10:18:31 2006
-+++ configure Tue Sep 26 10:19:11 2006
-@@ -1144,7 +1144,7 @@
+Adapt the configure script to FreeBSD:
+- use the elf.h header;
+- shorten the library .so file name;
+- honor LDFLAGS when linking;
+- do not link against or depend on libc.
+
+--- configure.orig
++++ configure
+@@ -1146,7 +1146,7 @@
fi
@@ -9,7 +15,7 @@
do
ac_safe=`echo "$ac_hdr" | sed 'y%./+-%__p_%'`
echo $ac_n "checking for $ac_hdr""... $ac_c" 1>&6
-@@ -3256,7 +3256,7 @@
+@@ -3281,7 +3281,7 @@
fi
case "$host" in
@@ -18,7 +24,7 @@
if test "$GCC" = yes; then
-@@ -3311,13 +3311,12 @@
+@@ -3336,13 +3336,12 @@
PICFLAGS='-fPIC -DPIC'
if test "$mr_enable_gnu_names" = yes
then SHLIB_SFX='-$(VERSION).so'
@@ -34,21 +40,3 @@
else
echo "configure: warning: shared libraries not supported for $host" 1>&2
mr_enable_shared=no
-@@ -3507,7 +3506,7 @@
- ac_given_srcdir=$srcdir
- ac_given_INSTALL="$INSTALL"
-
--trap 'rm -fr `echo "Makefile lib/Makefile po/Makefile w32/Makefile libelf.pc config.h lib/sys_elf.h" | sed "s/:[^ ]*//g"` conftest*; exit 1' 1 2 15
-+trap 'rm -fr `echo "Makefile lib/Makefile po/Makefile libelf.pc config.h lib/sys_elf.h" | sed "s/:[^ ]*//g"` conftest*; exit 1' 1 2 15
- EOF
- cat >> $CONFIG_STATUS <<EOF
-
-@@ -3622,7 +3621,7 @@
-
- cat >> $CONFIG_STATUS <<EOF
-
--CONFIG_FILES=\${CONFIG_FILES-"Makefile lib/Makefile po/Makefile w32/Makefile libelf.pc"}
-+CONFIG_FILES=\${CONFIG_FILES-"Makefile lib/Makefile po/Makefile libelf.pc"}
- EOF
- cat >> $CONFIG_STATUS <<\EOF
- for ac_file in .. $CONFIG_FILES; do if test "x$ac_file" != x..; then
diff --git a/devel/libelf/files/patch-lib::sys_elf.h.in b/devel/libelf/files/patch-lib::sys_elf.h.in
index b9c8e0b181fa..5312dd2ed02b 100644
--- a/devel/libelf/files/patch-lib::sys_elf.h.in
+++ b/devel/libelf/files/patch-lib::sys_elf.h.in
@@ -1,5 +1,7 @@
-+++ lib/sys_elf.h.in.orig Mon Sep 5 22:31:49 2005
---- lib/sys_elf.h.in Mon Sep 5 22:33:06 2005
+Provide the missing definitions for the ELF magic bytes.
+
+--- lib/sys_elf.h.in.orig
++++ lib/sys_elf.h.in
@@ -77,6 +77,13 @@
*/
#ifdef __LIBELF_HEADER_ELF_H