aboutsummaryrefslogtreecommitdiffstats
path: root/devel
diff options
context:
space:
mode:
authorsteve <steve@FreeBSD.org>2001-03-11 12:57:34 +0800
committersteve <steve@FreeBSD.org>2001-03-11 12:57:34 +0800
commit57156ba907e0997b744cb722c78a0aa0f5cab004 (patch)
treec40eb2a3c45744c75db50b20add5afd0922703aa /devel
parent8d0eb9d13e8062625977f6b118b5e75abc41f75b (diff)
downloadfreebsd-ports-gnome-57156ba907e0997b744cb722c78a0aa0f5cab004.tar.gz
freebsd-ports-gnome-57156ba907e0997b744cb722c78a0aa0f5cab004.tar.zst
freebsd-ports-gnome-57156ba907e0997b744cb722c78a0aa0f5cab004.zip
Use '-O0' on the Alpha so this builds without internal compiler errors.
Diffstat (limited to 'devel')
-rw-r--r--devel/amulet/files/Makefile.vars.gcc.FreeBSD12
1 files changed, 9 insertions, 3 deletions
diff --git a/devel/amulet/files/Makefile.vars.gcc.FreeBSD b/devel/amulet/files/Makefile.vars.gcc.FreeBSD
index 31407b989ebc..bfa30a622355 100644
--- a/devel/amulet/files/Makefile.vars.gcc.FreeBSD
+++ b/devel/amulet/files/Makefile.vars.gcc.FreeBSD
@@ -22,21 +22,27 @@ AM_CFLAGS = -I$(AMULET_DIR)/include $(X11_INC) -Wall \
AM_LIBS = $(X11_LIB) -lX11 -lm
+.if $(MACHINE_ARCH) == "alpha"
+OPT_CFLAGS = -O0
+.else
+OPT_CFLAGS = -O2
+.endif
+
##
## Parameters for the Amulet library
##
# additional compiler flags for development version
-AM_DEVELOP = -O2 -DDEBUG -g -DAMULET2_CONVERSION
+AM_DEVELOP = $(OPT_CFLAGS) -DDEBUG -g -DAMULET2_CONVERSION
# additional compiler flags for release version
-AM_RELEASE = -O2 -DAMULET2_CONVERSION
+AM_RELEASE = $(OPT_CFLAGS) -DAMULET2_CONVERSION
# additional compiler flags for optimized version with inspector and debugging enabled
AM_INHOUSE = -DDEBUG -g
# additional compiler flags for optimized version with inspector but no debugging symbols
-AM_NODEBUGSYM = -O2 -DDEBUG -DAMULET2_CONVERSION
+AM_NODEBUGSYM = $(OPT_FLAGS) -DDEBUG -DAMULET2_CONVERSION
# Flags used to build the sample programs
AM_SAMPLE_FLAGS = $(AM_NODEBUGSYM)