aboutsummaryrefslogtreecommitdiffstats
path: root/devel
diff options
context:
space:
mode:
authorMartin Wilke <miwi@FreeBSD.org>2007-02-10 22:35:47 +0800
committerMartin Wilke <miwi@FreeBSD.org>2007-02-10 22:35:47 +0800
commit579fa0c27b14b3b38cd600533039671659dc39ff (patch)
tree365eaf6469b37930bb4ce47eae8cef4a0dfa92c4 /devel
parent4b9190ee1bd691b06f71fbd0b95e45e203c6e17c (diff)
downloadfreebsd-ports-gnome-579fa0c27b14b3b38cd600533039671659dc39ff.tar.gz
freebsd-ports-gnome-579fa0c27b14b3b38cd600533039671659dc39ff.tar.zst
freebsd-ports-gnome-579fa0c27b14b3b38cd600533039671659dc39ff.zip
pycount helps you with a simple analysis of Python code, categorizing it into
comments, doc strings, blank lines and real code. It creates simple lines counts for individual or multiple files, but can also be used to strip comments from a source file, say. See a sample output of pycount running on itself in verbose mode. WWW: http://python.net/~gherman/pycount.html PR: ports/108996 Submitted by: Li-Wen Hsu <lwhsu at lwhsu.org>
Diffstat (limited to 'devel')
-rw-r--r--devel/Makefile1
-rw-r--r--devel/pycount/Makefile33
-rw-r--r--devel/pycount/distinfo3
-rw-r--r--devel/pycount/pkg-descr7
4 files changed, 44 insertions, 0 deletions
diff --git a/devel/Makefile b/devel/Makefile
index b09d63f72287..7f752f063c1b 100644
--- a/devel/Makefile
+++ b/devel/Makefile
@@ -1837,6 +1837,7 @@
SUBDIR += py-zopeInterface
SUBDIR += py_otp_interface
SUBDIR += pychecker
+ SUBDIR += pycount
SUBDIR += pylint
SUBDIR += pyobfuscate
SUBDIR += pymacs
diff --git a/devel/pycount/Makefile b/devel/pycount/Makefile
new file mode 100644
index 000000000000..a61285bdea88
--- /dev/null
+++ b/devel/pycount/Makefile
@@ -0,0 +1,33 @@
+# New ports collection makefile for: pycount
+# Date created: Feb. 10, 2007
+# Whom: Li-Wen Hsu <lwhsu@lwhsu.org>
+#
+# $FreeBSD$
+#
+
+PORTNAME= pycount
+PORTVERSION= 0.0.6
+CATEGORIES= devel python
+MASTER_SITES= http://python.net/crew/gherman/playground/pycount/
+PKGNAMEPREFIX= ${PYTHON_PKGNAMEPREFIX}
+DISTNAME= ${PORTNAME}.py
+EXTRACT_SUFX= #
+DIST_SUBDIR= python
+
+MAINTAINER= lwhsu@lwhsu.org
+COMMENT= A very initial effort to Python code metrics
+
+USE_DOS2UNIX= yes
+USE_PYTHON= yes
+NO_BUILD= yes
+
+PLIST_FILES= bin/${PORTNAME}
+
+do-extract:
+ @${MKDIR} ${WRKDIR}
+ @${CP} ${DISTDIR}/${DIST_SUBDIR}/${DISTFILES} ${WRKDIR}
+
+do-install:
+ ${INSTALL_SCRIPT} ${WRKDIR}/${DISTFILES} ${TARGETDIR}/bin/${PORTNAME}
+
+.include <bsd.port.mk>
diff --git a/devel/pycount/distinfo b/devel/pycount/distinfo
new file mode 100644
index 000000000000..4b4bdc8cd929
--- /dev/null
+++ b/devel/pycount/distinfo
@@ -0,0 +1,3 @@
+MD5 (python/pycount.py) = baeb40358470945d6d943a0d8721419a
+SHA256 (python/pycount.py) = 5fdc8096ae046d2a1741ceb4c33ac02e84a7978e9b3c93032496e58c6416ad48
+SIZE (python/pycount.py) = 12920
diff --git a/devel/pycount/pkg-descr b/devel/pycount/pkg-descr
new file mode 100644
index 000000000000..9241c9bd799f
--- /dev/null
+++ b/devel/pycount/pkg-descr
@@ -0,0 +1,7 @@
+pycount helps you with a simple analysis of Python code, categorizing it into
+comments, doc strings, blank lines and real code. It creates simple lines
+counts for individual or multiple files, but can also be used to strip
+comments from a source file, say. See a sample output of pycount running on
+itself in verbose mode.
+
+WWW: http://python.net/~gherman/pycount.html