aboutsummaryrefslogtreecommitdiffstats
path: root/devel
diff options
context:
space:
mode:
authorkoobs <koobs@FreeBSD.org>2015-02-21 11:28:15 +0800
committerkoobs <koobs@FreeBSD.org>2015-02-21 11:28:15 +0800
commit5a2d09174b774d0d790f8a3b62aecf8af11aa6b3 (patch)
tree3f4fac0911597e9791875f08597e37da2ad29071 /devel
parent67b237bc601bbd9741c83a33c69af70337634a7d (diff)
downloadfreebsd-ports-gnome-5a2d09174b774d0d790f8a3b62aecf8af11aa6b3.tar.gz
freebsd-ports-gnome-5a2d09174b774d0d790f8a3b62aecf8af11aa6b3.tar.zst
freebsd-ports-gnome-5a2d09174b774d0d790f8a3b62aecf8af11aa6b3.zip
devel/py-twistedCore: Create OPTION for service_identity
service_identity is an optional dependency that hasn't yet been added to setup.py upstream as an extras_require [1] Create a VERIFY option to make the dependency optional, as it adds a decent number [~9] of subsequent dependencies that aren't needed in most cases. Set the VERIFY option to be a OPTIONS_DEFAULT *for now* since a few consumers (and their ports) bail out with an error if its not installed (deluge) [2]. For these cases, the port should instead depend on service_identity directly, as in www/calendarserver. While I'm here: - Strip shared libraries - Tweak COMMENT [1] http://twistedmatrix.com/trac/ticket/3696 [2] http://svnweb.freebsd.org/ports?view=revision&revision=375833 Approved by: python (hat)
Diffstat (limited to 'devel')
-rw-r--r--devel/py-twistedCore/Makefile16
1 files changed, 13 insertions, 3 deletions
diff --git a/devel/py-twistedCore/Makefile b/devel/py-twistedCore/Makefile
index 388b75ea9ee5..b2dc497ef2fe 100644
--- a/devel/py-twistedCore/Makefile
+++ b/devel/py-twistedCore/Makefile
@@ -3,6 +3,7 @@
PORTNAME= twistedCore
PORTVERSION= 15.0.0
+PORTREVISION= 1
CATEGORIES= devel net python
MASTER_SITES= http://twistedmatrix.com/Releases/Core/${PORTVERSION:R}/ \
LOCAL/sunpoet
@@ -10,14 +11,19 @@ PKGNAMEPREFIX= ${PYTHON_PKGNAMEPREFIX}
DISTNAME= TwistedCore-${PORTVERSION}
MAINTAINER= python@FreeBSD.org
-COMMENT= Asynchronous networking framework for Python - Core module
+COMMENT= Asynchronous networking framework for Python (Core Module)
LICENSE= MIT
LICENSE_FILE= ${WRKSRC}/LICENSE
BUILD_DEPENDS= ${PYTHON_PKGNAMEPREFIX}zope.interface>=3.6.0:${PORTSDIR}/devel/py-zope.interface
-RUN_DEPENDS:= ${BUILD_DEPENDS} \
- ${PYTHON_PKGNAMEPREFIX}service_identity>0:${PORTSDIR}/security/py-service_identity
+RUN_DEPENDS:= ${BUILD_DEPENDS}
+
+OPTIONS_DEFINE= VERIFY
+OPTIONS_DEFAULT= VERIFY
+
+VERIFY_DESC= Server (SNI) and Service Verification Support (RFC6125+)
+VERIFY_RUN_DEPENDS= ${PYTHON_PKGNAMEPREFIX}service_identity>0:${PORTSDIR}/security/py-service_identity
# - Note that Twisted ships with some graphical examples and clients that
# require PyGNOME to run. These are not central to the funcitoning of
@@ -27,4 +33,8 @@ RUN_DEPENDS:= ${BUILD_DEPENDS} \
USES= python:2 tar:bzip2
USE_PYTHON= autoplist distutils
+post-install:
+ @${STRIP_CMD} ${STAGEDIR}${PYTHON_SITELIBDIR}/twisted/python/sendmsg.so \
+ ${STAGEDIR}${PYTHON_SITELIBDIR}/twisted/test/raiser.so
+
.include <bsd.port.mk>