aboutsummaryrefslogtreecommitdiffstats
path: root/devel
diff options
context:
space:
mode:
authoredwin <edwin@FreeBSD.org>2004-03-08 09:01:31 +0800
committeredwin <edwin@FreeBSD.org>2004-03-08 09:01:31 +0800
commit5d87bf6f020ae3177a26e679d65b5e50f035bbe1 (patch)
treeca9d8a7830bc4c19ec29804b066fc99d81d7488b /devel
parent476102ca837a76b18c930b013cb486ec3f0ce79e (diff)
downloadfreebsd-ports-gnome-5d87bf6f020ae3177a26e679d65b5e50f035bbe1.tar.gz
freebsd-ports-gnome-5d87bf6f020ae3177a26e679d65b5e50f035bbe1.tar.zst
freebsd-ports-gnome-5d87bf6f020ae3177a26e679d65b5e50f035bbe1.zip
Properly use SDL everywhere:
USE_SDL=yes -> USE_SDL=sdl (good examles everywhere) WANT_SDL/HAVE_SDL instead of exists(localbase/lib/lib...) See http://www.freebsd.org/doc/en_US.ISO8859-1/books/porters-handbook/using-sdl.html for more information on how to use USE_SDL, WANT_SDL and HAVE_SDL. PR: follow-ups of ports/55494, ports/61877 Submitted by: Edwin Groothuis <edwin@mavetju.org>
Diffstat (limited to 'devel')
-rw-r--r--devel/clanlib-devel/Makefile2
-rw-r--r--devel/esdl/Makefile2
-rw-r--r--devel/libuta/Makefile6
-rw-r--r--devel/wftk/Makefile6
4 files changed, 10 insertions, 6 deletions
diff --git a/devel/clanlib-devel/Makefile b/devel/clanlib-devel/Makefile
index 6b73db22b4a6..17ba9c98d0aa 100644
--- a/devel/clanlib-devel/Makefile
+++ b/devel/clanlib-devel/Makefile
@@ -57,7 +57,7 @@ CFLAGS+= -O0
CONFIGURE_ARGS+= --disable-clanSDL
PLIST_SUB+= SDL="@comment "
.else
-USE_SDL= yes
+USE_SDL= sdl
CONFIGURE_ARGS+= --disable-sdltest
PLIST_SUB+= SDL=""
.endif
diff --git a/devel/esdl/Makefile b/devel/esdl/Makefile
index e1089cb562bc..a54a863d0723 100644
--- a/devel/esdl/Makefile
+++ b/devel/esdl/Makefile
@@ -23,7 +23,7 @@ WRKSRC= ${WRKDIR}/${PORTNAME}-${PORTVERSION}
USE_GL= yes
USE_GMAKE= yes
-USE_SDL= yes
+USE_SDL= sdl
USE_SIZE= yes
ALL_TARGET= target
PLIST_SUB= VERSION="${PORTVERSION}"
diff --git a/devel/libuta/Makefile b/devel/libuta/Makefile
index afe03413983c..696339577ef5 100644
--- a/devel/libuta/Makefile
+++ b/devel/libuta/Makefile
@@ -29,6 +29,8 @@ INSTALLS_SHLIB= yes
CONFIGURE_ENV= LIBS="-L${LOCALBASE}/lib"
+WANT_SDL= yes
+
SDL11_FILES= configure uta/color.h uta/event.h uta/keysym.h uta/mutex.h \
uta/pixelformat.h uta/rect.h uta/sge_blib.cc uta/sge_blib.h \
uta/sge_draw.cc uta/sge_draw.h uta/sound.h uta/surface_io.cc \
@@ -36,12 +38,12 @@ SDL11_FILES= configure uta/color.h uta/event.h uta/keysym.h uta/mutex.h \
.include <bsd.port.pre.mk>
-.if exists(${LOCALBASE}/lib/libSDL_mixer.so.2)
+.if ${HAVE_SDL:Mmixer}!=""
WITH_SDL_MIXER= yes
.endif
.if defined(WITH_SDL_MIXER)
-USE_SDL= mixer sdl
+USE_SDL+= mixer
.endif
post-patch:
diff --git a/devel/wftk/Makefile b/devel/wftk/Makefile
index afe03413983c..696339577ef5 100644
--- a/devel/wftk/Makefile
+++ b/devel/wftk/Makefile
@@ -29,6 +29,8 @@ INSTALLS_SHLIB= yes
CONFIGURE_ENV= LIBS="-L${LOCALBASE}/lib"
+WANT_SDL= yes
+
SDL11_FILES= configure uta/color.h uta/event.h uta/keysym.h uta/mutex.h \
uta/pixelformat.h uta/rect.h uta/sge_blib.cc uta/sge_blib.h \
uta/sge_draw.cc uta/sge_draw.h uta/sound.h uta/surface_io.cc \
@@ -36,12 +38,12 @@ SDL11_FILES= configure uta/color.h uta/event.h uta/keysym.h uta/mutex.h \
.include <bsd.port.pre.mk>
-.if exists(${LOCALBASE}/lib/libSDL_mixer.so.2)
+.if ${HAVE_SDL:Mmixer}!=""
WITH_SDL_MIXER= yes
.endif
.if defined(WITH_SDL_MIXER)
-USE_SDL= mixer sdl
+USE_SDL+= mixer
.endif
post-patch: