aboutsummaryrefslogtreecommitdiffstats
path: root/devel
diff options
context:
space:
mode:
authorkwm <kwm@FreeBSD.org>2010-10-29 20:02:22 +0800
committerkwm <kwm@FreeBSD.org>2010-10-29 20:02:22 +0800
commit62ee7179efe49050b7c73d14e52839d99712832b (patch)
tree6c45762bd2ec4ccb41dce147367ace84234f5eb7 /devel
parentcd93ad0cfaa48dea5df7db8dc3d9e4707b580dad (diff)
downloadfreebsd-ports-gnome-62ee7179efe49050b7c73d14e52839d99712832b.tar.gz
freebsd-ports-gnome-62ee7179efe49050b7c73d14e52839d99712832b.tar.zst
freebsd-ports-gnome-62ee7179efe49050b7c73d14e52839d99712832b.zip
Hide a sed line.
Fix a configure assumption. Configure tries to figure out the linker objects. The check it uses for this doesn't work with clang. So tweak the check to make it work. Approved by: maintainer timeout (21 days)
Diffstat (limited to 'devel')
-rw-r--r--devel/pcre/Makefile4
1 files changed, 3 insertions, 1 deletions
diff --git a/devel/pcre/Makefile b/devel/pcre/Makefile
index 5b1a4caae798..52d619b0effd 100644
--- a/devel/pcre/Makefile
+++ b/devel/pcre/Makefile
@@ -55,8 +55,10 @@ post-patch:
@${REINPLACE_CMD} -E -e '/^install-data-am/,/^$$/ s,install-(dist_doc|dist_html|html)DATA,,g' \
${WRKSRC}/Makefile.in
.endif
- ${REINPLACE_CMD} -e 's/\(pkgconfigdir = \).*/\1$$\(DESTDIR\)$$\(prefix\)\/libdata\/pkgconfig/' \
+ @${REINPLACE_CMD} -e 's/\(pkgconfigdir = \).*/\1$$\(DESTDIR\)$$\(prefix\)\/libdata\/pkgconfig/' \
${WRKSRC}/Makefile.in
+# work around for a autoconf assumption, to fix c++ linking with clang
+ @${REINPLACE_CMD} -e 's|GREP "\\-L"|GREP "conftest\\.$$objext"|g' ${WRKSRC}/configure
post-install:
@${STRIP_CMD} ${PREFIX}/bin/pcregrep ${PREFIX}/bin/pcretest