aboutsummaryrefslogtreecommitdiffstats
path: root/devel
diff options
context:
space:
mode:
authorjgh <jgh@FreeBSD.org>2013-10-02 04:47:39 +0800
committerjgh <jgh@FreeBSD.org>2013-10-02 04:47:39 +0800
commit6317a1f764f042deebbb0e36bb1ce385b3017660 (patch)
treee3012d19079d12fd1430850d99a15c4655d09493 /devel
parentc3e08dc27c84704743774f14dea53653c9f8398a (diff)
downloadfreebsd-ports-gnome-6317a1f764f042deebbb0e36bb1ce385b3017660.tar.gz
freebsd-ports-gnome-6317a1f764f042deebbb0e36bb1ce385b3017660.tar.zst
freebsd-ports-gnome-6317a1f764f042deebbb0e36bb1ce385b3017660.zip
- update to 1.1.3
- support staging Changes: http://libvirt.org/news.html
Diffstat (limited to 'devel')
-rw-r--r--devel/libvirt/Makefile18
-rw-r--r--devel/libvirt/distinfo4
-rw-r--r--devel/libvirt/pkg-plist24
3 files changed, 15 insertions, 31 deletions
diff --git a/devel/libvirt/Makefile b/devel/libvirt/Makefile
index fc9f071c791f..d5b951fdf5b8 100644
--- a/devel/libvirt/Makefile
+++ b/devel/libvirt/Makefile
@@ -2,7 +2,7 @@
# $FreeBSD$
PORTNAME= libvirt
-PORTVERSION= 1.1.2
+PORTVERSION= 1.1.3
CATEGORIES= devel
MASTER_SITES= http://libvirt.org/sources/ \
ftp://libvirt.org/libvirt/
@@ -61,12 +61,8 @@ PLIST_SUB= PORTVERSION="-${PORTVERSION}" \
SHLIB_VER=${SHLIB_VER}
PORTDOCS= *
-NO_STAGE= yes
.include <bsd.port.options.mk>
-MAN1= virsh.1 virt-pki-validate.1 virt-xml-validate.1 virt-host-validate.1
-MAN8= libvirtd.8 virtlockd.8
-
post-patch:
.if ${OSVERSION} < 900000
@${REINPLACE_CMD} -e 's|-Wmissing-include-dirs||' \
@@ -88,17 +84,17 @@ post-patch:
post-install:
@for configuration in libvirt libvirtd ${QEMU_CONFIG}; do \
- if [ ! -e "${ETCDIR}/$${configuration}.conf" ]; then \
- ${ECHO_MSG} " Installing local configuration file: ${ETCDIR}/$${configuration}.conf"; \
- ${CP} ${ETCDIR}/$${configuration}.conf.sample ${ETCDIR}/$${configuration}.conf; \
+ if [ ! -e "${STAGEDIR}${ETCDIR}/$${configuration}.conf" ]; then \
+ ${ECHO_MSG} " Installing local configuration file: ${STAGEDIR}${ETCDIR}/$${configuration}.conf"; \
+ ${CP} ${STAGEDIR}${ETCDIR}/$${configuration}.conf.sample ${STAGEDIR}${ETCDIR}/$${configuration}.conf; \
else \
- ${ECHO_MSG} " Preserving local configuration file: ${ETCDIR}/$${configuration}.conf"; \
+ ${ECHO_MSG} " Preserving local configuration file: ${STAGEDIR}${ETCDIR}/$${configuration}.conf"; \
fi; \
done
.if ${PORT_OPTIONS:MDOCS}
- @${MKDIR} ${DOCSDIR}
+ @${MKDIR} ${STAGEDIR}${DOCSDIR}
.for doc in AUTHORS ChangeLog INSTALL NEWS README TODO
- ${INSTALL_DATA} ${WRKSRC}/${doc} ${DOCSDIR}
+ ${INSTALL_DATA} ${WRKSRC}/${doc} ${STAGEDIR}${DOCSDIR}
.endfor
.endif
diff --git a/devel/libvirt/distinfo b/devel/libvirt/distinfo
index 36890064f899..9fe89051fb25 100644
--- a/devel/libvirt/distinfo
+++ b/devel/libvirt/distinfo
@@ -1,2 +1,2 @@
-SHA256 (libvirt-1.1.2.tar.gz) = 16648af54d3e162f5cc5445d970ec29a0bd55b1dbcb568a05533c4c2f25965e3
-SIZE (libvirt-1.1.2.tar.gz) = 26069691
+SHA256 (libvirt-1.1.3.tar.gz) = af83e65b4b26520662ddd183c1358be0d05138dba3e66745419f06441eff5a7c
+SIZE (libvirt-1.1.3.tar.gz) = 26578000
diff --git a/devel/libvirt/pkg-plist b/devel/libvirt/pkg-plist
index 1bcfec71bad7..b67e88de8e7f 100644
--- a/devel/libvirt/pkg-plist
+++ b/devel/libvirt/pkg-plist
@@ -2,6 +2,12 @@ bin/virsh
bin/virt-host-validate
bin/virt-pki-validate
bin/virt-xml-validate
+man/man1/virsh.1.gz
+man/man1/virt-pki-validate.1.gz
+man/man1/virt-xml-validate.1.gz
+man/man1/virt-host-validate.1.gz
+man/man8/libvirtd.8.gz
+man/man8/virtlockd.8.gz
@unexec if cmp -s %D/%%ETCDIR%%/libvirtd.conf.sample %D/%%ETCDIR%%/libvirtd.conf; then rm -f %D/%%ETCDIR%%/libvirtd.conf; fi
%%ETCDIR%%/libvirtd.conf.sample
@exec if [ ! -f %D/%%ETCDIR%%/libvirtd.conf ] ; then cp -p %D/%%ETCDIR%%/libvirtd.conf.sample %D/%%ETCDIR%%/libvirtd.conf; fi
@@ -13,23 +19,6 @@ bin/virt-xml-validate
%%QEMU%%%%ETCDIR%%/qemu.conf.sample
%%QEMU%%@exec if [ ! -f %D/%%ETCDIR%%/qemu.conf ] ; then cp -p %D/%%ETCDIR%%/qemu.conf.sample %D/%%ETCDIR%%/qemu.conf; fi
%%QEMU%%%%ETCDIR%%/qemu-lockd.conf
-%%ETCDIR%%/nwfilter/allow-arp.xml
-%%ETCDIR%%/nwfilter/allow-dhcp-server.xml
-%%ETCDIR%%/nwfilter/allow-dhcp.xml
-%%ETCDIR%%/nwfilter/allow-incoming-ipv4.xml
-%%ETCDIR%%/nwfilter/allow-ipv4.xml
-%%ETCDIR%%/nwfilter/clean-traffic.xml
-%%ETCDIR%%/nwfilter/no-arp-spoofing.xml
-%%ETCDIR%%/nwfilter/no-arp-ip-spoofing.xml
-%%ETCDIR%%/nwfilter/no-arp-mac-spoofing.xml
-%%ETCDIR%%/nwfilter/no-ip-multicast.xml
-%%ETCDIR%%/nwfilter/no-ip-spoofing.xml
-%%ETCDIR%%/nwfilter/no-mac-broadcast.xml
-%%ETCDIR%%/nwfilter/no-mac-spoofing.xml
-%%ETCDIR%%/nwfilter/no-other-l2-traffic.xml
-%%ETCDIR%%/nwfilter/no-other-rarp-traffic.xml
-%%ETCDIR%%/nwfilter/qemu-announce-self-rarp.xml
-%%ETCDIR%%/nwfilter/qemu-announce-self.xml
etc/logrotate.d/libvirtd
etc/logrotate.d/libvirtd.lxc
etc/logrotate.d/libvirtd.qemu
@@ -344,7 +333,6 @@ lib/libvirt/connection-driver/libvirt_driver_vbox.la
%%NLS%%@dirrmtry share/locale/bo
%%NLS%%@dirrmtry share/locale/as/LC_MESSAGES
%%NLS%%@dirrmtry share/locale/as
-@dirrm %%ETCDIR%%/nwfilter
@dirrm %%ETCDIR%%
@dirrmtry var/run/libvirt/lockd
@dirrmtry var/run/libvirt