aboutsummaryrefslogtreecommitdiffstats
path: root/devel
diff options
context:
space:
mode:
authorsunpoet <sunpoet@FreeBSD.org>2013-05-26 07:46:59 +0800
committersunpoet <sunpoet@FreeBSD.org>2013-05-26 07:46:59 +0800
commit640d3ca058d20c14f098a84e129fc4b3682e8db9 (patch)
tree6be14d738139d23d2c932dd95b01130aaa4f1613 /devel
parentce81a27473060e5e6bbf5fe4e3b63a47ec8a452e (diff)
downloadfreebsd-ports-gnome-640d3ca058d20c14f098a84e129fc4b3682e8db9.tar.gz
freebsd-ports-gnome-640d3ca058d20c14f098a84e129fc4b3682e8db9.tar.zst
freebsd-ports-gnome-640d3ca058d20c14f098a84e129fc4b3682e8db9.zip
- Add p5-Sub-Exporter-Lexical 0.092291
Sub::Exporter::Lexical provides an alternate installer for Sub::Exporter. Installers are documented in Sub::Exporter's documentation; all you need to know is that by using Sub::Exporter::Lexical's installer, you can import routines into a lexical scope that will be cleaned up when that scope ends. WWW: http://search.cpan.org/dist/Sub-Exporter-Lexical/
Diffstat (limited to 'devel')
-rw-r--r--devel/Makefile1
-rw-r--r--devel/p5-Sub-Exporter-Lexical/Makefile32
-rw-r--r--devel/p5-Sub-Exporter-Lexical/distinfo2
-rw-r--r--devel/p5-Sub-Exporter-Lexical/pkg-descr6
-rw-r--r--devel/p5-Sub-Exporter-Lexical/pkg-plist8
5 files changed, 49 insertions, 0 deletions
diff --git a/devel/Makefile b/devel/Makefile
index 585170d26461..a07dbd0900ec 100644
--- a/devel/Makefile
+++ b/devel/Makefile
@@ -2664,6 +2664,7 @@
SUBDIR += p5-Sub-Exporter
SUBDIR += p5-Sub-Exporter-ForMethods
SUBDIR += p5-Sub-Exporter-GlobExporter
+ SUBDIR += p5-Sub-Exporter-Lexical
SUBDIR += p5-Sub-Exporter-Progressive
SUBDIR += p5-Sub-Identify
SUBDIR += p5-Sub-Install
diff --git a/devel/p5-Sub-Exporter-Lexical/Makefile b/devel/p5-Sub-Exporter-Lexical/Makefile
new file mode 100644
index 000000000000..8e2e775269d9
--- /dev/null
+++ b/devel/p5-Sub-Exporter-Lexical/Makefile
@@ -0,0 +1,32 @@
+# Created by: Sunpoet Po-Chuan Hsieh <sunpoet@FreeBSD.org>
+# $FreeBSD$
+
+PORTNAME= Sub-Exporter-Lexical
+PORTVERSION= 0.092.291
+CATEGORIES= devel perl5
+MASTER_SITES= CPAN
+PKGNAMEPREFIX= p5-
+DISTNAME= ${PORTNAME}-${PORTVERSION:R}${PORTVERSION:E}
+
+MAINTAINER= sunpoet@FreeBSD.org
+COMMENT= Export lexically-available subs with Sub::Exporter
+
+LICENSE= ART10 GPLv1
+LICENSE_COMB= dual
+
+BUILD_DEPENDS= p5-B-Hooks-EndOfScope>=0:${PORTSDIR}/devel/p5-B-Hooks-EndOfScope \
+ p5-Sub-Exporter>=0.978:${PORTSDIR}/devel/p5-Sub-Exporter \
+ p5-namespace-clean>=0:${PORTSDIR}/devel/p5-namespace-clean
+RUN_DEPENDS:= ${BUILD_DEPENDS}
+
+PERL_CONFIGURE= yes
+
+MAN3= Sub::Exporter::Lexical.3
+
+.include <bsd.port.pre.mk>
+
+.if ${PERL_LEVEL} < 501400
+TEST_DEPENDS+= p5-Test-Simple>=0.96:${PORTSDIR}/devel/p5-Test-Simple
+.endif
+
+.include <bsd.port.post.mk>
diff --git a/devel/p5-Sub-Exporter-Lexical/distinfo b/devel/p5-Sub-Exporter-Lexical/distinfo
new file mode 100644
index 000000000000..b50ca1d8d111
--- /dev/null
+++ b/devel/p5-Sub-Exporter-Lexical/distinfo
@@ -0,0 +1,2 @@
+SHA256 (Sub-Exporter-Lexical-0.092291.tar.gz) = e45830d8e39ed33a0af3a513223f0158133f4aa2429306101cbb2f98cdbcfbc1
+SIZE (Sub-Exporter-Lexical-0.092291.tar.gz) = 11624
diff --git a/devel/p5-Sub-Exporter-Lexical/pkg-descr b/devel/p5-Sub-Exporter-Lexical/pkg-descr
new file mode 100644
index 000000000000..27fc9b3e029a
--- /dev/null
+++ b/devel/p5-Sub-Exporter-Lexical/pkg-descr
@@ -0,0 +1,6 @@
+Sub::Exporter::Lexical provides an alternate installer for Sub::Exporter.
+Installers are documented in Sub::Exporter's documentation; all you need to know
+is that by using Sub::Exporter::Lexical's installer, you can import routines
+into a lexical scope that will be cleaned up when that scope ends.
+
+WWW: http://search.cpan.org/dist/Sub-Exporter-Lexical/
diff --git a/devel/p5-Sub-Exporter-Lexical/pkg-plist b/devel/p5-Sub-Exporter-Lexical/pkg-plist
new file mode 100644
index 000000000000..7d81d8595158
--- /dev/null
+++ b/devel/p5-Sub-Exporter-Lexical/pkg-plist
@@ -0,0 +1,8 @@
+%%SITE_PERL%%/Sub/Exporter/Lexical.pm
+%%SITE_PERL%%/Sub/Exporter/snippet.pl
+%%SITE_PERL%%/%%PERL_ARCH%%/auto/Sub/Exporter/Lexical/.packlist
+@dirrm %%SITE_PERL%%/%%PERL_ARCH%%/auto/Sub/Exporter/Lexical
+@dirrmtry %%SITE_PERL%%/%%PERL_ARCH%%/auto/Sub/Exporter
+@dirrmtry %%SITE_PERL%%/%%PERL_ARCH%%/auto/Sub
+@dirrmtry %%SITE_PERL%%/Sub/Exporter
+@dirrmtry %%SITE_PERL%%/Sub