aboutsummaryrefslogtreecommitdiffstats
path: root/devel
diff options
context:
space:
mode:
authormarino <marino@FreeBSD.org>2014-08-11 06:21:22 +0800
committermarino <marino@FreeBSD.org>2014-08-11 06:21:22 +0800
commit64333fcf123617cbc7cd7340319379bc9e07da76 (patch)
tree8c9444fa9b83e1b5e9adbe45df09a9ee9776d1e5 /devel
parent852522bf83cf5c9ed4dec68c0d086957ca368832 (diff)
downloadfreebsd-ports-gnome-64333fcf123617cbc7cd7340319379bc9e07da76.tar.gz
freebsd-ports-gnome-64333fcf123617cbc7cd7340319379bc9e07da76.tar.zst
freebsd-ports-gnome-64333fcf123617cbc7cd7340319379bc9e07da76.zip
Add new port devel/tass64
PR: 192155 Submitted by: uffe 6502/65C02/R65C02/W65C02/65CE02/65816/DTV/65EL02 Turbo Assembler Open source, mostly portable C with minimal dependencies Familiar syntax to Omicron TASS and TASM. Supports 6502, 65C02, R65C02, W65C02, 65CE02, 65816, DTV, 65EL02 Arbitrary-precision integers and bitstrings, double precision floating point nos Character and byte strings, array arithmetic Handles UTF-8, UTF-16 and 8 bit RAW encoded source files, unicode strings Supports Unicode identifiers with case folding and compatibility normalization Built-in "linker" with section support CPU or flat address space for creating huge binaries (e.g. cartridges) Conditional compilation, macros, struct/union structures, scopes.
Diffstat (limited to 'devel')
-rw-r--r--devel/Makefile1
-rw-r--r--devel/tass64/Makefile31
-rw-r--r--devel/tass64/distinfo2
-rw-r--r--devel/tass64/pkg-descr16
4 files changed, 50 insertions, 0 deletions
diff --git a/devel/Makefile b/devel/Makefile
index eda46a67addd..283c9c2744c1 100644
--- a/devel/Makefile
+++ b/devel/Makefile
@@ -4613,6 +4613,7 @@
SUBDIR += ta-lib
SUBDIR += tailor
SUBDIR += talloc
+ SUBDIR += tass
SUBDIR += tbb
SUBDIR += tcl-memchan
SUBDIR += tcl-mmap
diff --git a/devel/tass64/Makefile b/devel/tass64/Makefile
new file mode 100644
index 000000000000..c53a708637ed
--- /dev/null
+++ b/devel/tass64/Makefile
@@ -0,0 +1,31 @@
+# Created by: Uffe Jakobsen <uffe@uffe.org>
+# $FreeBSD$
+
+PORTNAME= tass64
+PORTVERSION= 1.51.727
+CATEGORIES= devel
+MASTER_SITES= SF/${PORTNAME}/source
+DISTNAME= 64tass-${PORTVERSION}-src
+
+MAINTAINER= uffe@uffe.org
+COMMENT= 6502/65C02/R65C02/W65C02/65CE02/65816/DTV/65EL02 Turbo Assembler
+
+LICENSE= GPLv2
+
+USES= gmake zip
+MAKE_ARGS= -w CC="${CC}" CFLAGS="${CFLAGS}" LD="${CC}" LDFLAGS="${LDFLAGS}"
+
+PLIST_FILES= bin/tass64 \
+ %%DOCSDIR%%/README \
+ %%DOCSDIR%%/README.html
+
+PLIST_DIRSTRY= %%DOCSDIR%%
+
+do-install:
+ ${INSTALL_PROGRAM} ${WRKSRC}/64tass ${STAGEDIR}${PREFIX}/bin/tass64
+ @${MKDIR} ${STAGEDIR}${DOCSDIR}
+.for doc in README README.html
+ ${INSTALL_DATA} ${WRKSRC}/${doc} ${STAGEDIR}${DOCSDIR}
+.endfor
+
+.include <bsd.port.mk>
diff --git a/devel/tass64/distinfo b/devel/tass64/distinfo
new file mode 100644
index 000000000000..d708b1b27225
--- /dev/null
+++ b/devel/tass64/distinfo
@@ -0,0 +1,2 @@
+SHA256 (64tass-1.51.727-src.zip) = 971b0e4bb8cc9e3f5493505a58a6060d19ee96364d969142d4ec36fa0f3bee3a
+SIZE (64tass-1.51.727-src.zip) = 517120
diff --git a/devel/tass64/pkg-descr b/devel/tass64/pkg-descr
new file mode 100644
index 000000000000..eb7051a24cdc
--- /dev/null
+++ b/devel/tass64/pkg-descr
@@ -0,0 +1,16 @@
+6502/65C02/R65C02/W65C02/65CE02/65816/DTV/65EL02 Turbo Assembler
+
+Key features:
+
+Open source, mostly portable C with minimal dependencies
+Familiar syntax to Omicron TASS and TASM.
+Supports 6502, 65C02, R65C02, W65C02, 65CE02, 65816, DTV, 65EL02
+Arbitrary-precision integers and bitstrings, double precision floating point nos
+Character and byte strings, array arithmetic
+Handles UTF-8, UTF-16 and 8 bit RAW encoded source files, unicode strings
+Supports Unicode identifiers with case folding and compatibility normalization
+Built-in "linker" with section support
+CPU or flat address space for creating huge binaries (e.g. cartridges)
+Conditional compilation, macros, struct/union structures, scopes.
+
+WWW: http://tass64.sourceforge.net/