aboutsummaryrefslogtreecommitdiffstats
path: root/devel
diff options
context:
space:
mode:
authorwen <wen@FreeBSD.org>2010-03-07 08:53:17 +0800
committerwen <wen@FreeBSD.org>2010-03-07 08:53:17 +0800
commit654da8aa07945d4f980646c3aa0e76ea78015621 (patch)
tree24611964c05b9deeb1706c7756ded4a1c896fdeb /devel
parent54b72013aef0fca460fc8f429879c32fcf4349eb (diff)
downloadfreebsd-ports-gnome-654da8aa07945d4f980646c3aa0e76ea78015621.tar.gz
freebsd-ports-gnome-654da8aa07945d4f980646c3aa0e76ea78015621.tar.zst
freebsd-ports-gnome-654da8aa07945d4f980646c3aa0e76ea78015621.zip
- Update to 2.0.0
PR: ports/144462 Submitted by: Ganael Laplanche <ganael.laplanche@martymac.com> (maintainer) Feature safe: yes
Diffstat (limited to 'devel')
-rw-r--r--devel/simgear/Makefile6
-rw-r--r--devel/simgear/distinfo6
-rw-r--r--devel/simgear/files/patch-simgear-compiler.h17
-rw-r--r--devel/simgear/pkg-plist367
4 files changed, 227 insertions, 169 deletions
diff --git a/devel/simgear/Makefile b/devel/simgear/Makefile
index 29088b3f006a..e793f2ae420a 100644
--- a/devel/simgear/Makefile
+++ b/devel/simgear/Makefile
@@ -6,11 +6,11 @@
#
PORTNAME= SimGear
-PORTVERSION= 1.9.1
-PORTREVISION= 5
+PORTVERSION= 2.0.0
CATEGORIES= devel games
MASTER_SITES= ftp://ftp.de.simgear.org/pub/simgear/Source/ \
- ftp://ftp.simgear.org/pub/simgear/Source/
+ ftp://mirrors.ibiblio.org/pub/mirrors/simgear/ftp/Source/ \
+ ftp://goflyflightgear.com/simgear/Source/
MAINTAINER= ganael.laplanche@martymac.com
COMMENT= A toolkit for 3D games and simulations
diff --git a/devel/simgear/distinfo b/devel/simgear/distinfo
index b60105ccb101..97f7d4e62ae7 100644
--- a/devel/simgear/distinfo
+++ b/devel/simgear/distinfo
@@ -1,3 +1,3 @@
-MD5 (SimGear-1.9.1.tar.gz) = edfdaa60518a06699a409d0eb9f1b157
-SHA256 (SimGear-1.9.1.tar.gz) = ba9014ad08594730db388cfe9ba9f59c82cd81b4e8bc91e2c254f5b47afcfa6a
-SIZE (SimGear-1.9.1.tar.gz) = 851327
+MD5 (SimGear-2.0.0.tar.gz) = 414bea545ea1e8ce17e4aa0809159cec
+SHA256 (SimGear-2.0.0.tar.gz) = a55847b8aefdeabb511b761a2a39290b36b841b22e813d62217cd32c7351d121
+SIZE (SimGear-2.0.0.tar.gz) = 1058343
diff --git a/devel/simgear/files/patch-simgear-compiler.h b/devel/simgear/files/patch-simgear-compiler.h
new file mode 100644
index 000000000000..8258a40e47ca
--- /dev/null
+++ b/devel/simgear/files/patch-simgear-compiler.h
@@ -0,0 +1,17 @@
+--- simgear/compiler.h.orig 2010-02-25 09:07:12.998305929 +0000
++++ simgear/compiler.h 2010-02-25 09:07:20.148299853 +0000
+@@ -149,14 +149,6 @@
+ # endif
+ #endif
+
+-#if defined (__FreeBSD__)
+-# if __FreeBSD_version < 500000
+- extern "C" {
+- inline int isnan(double r) { return !(r <= 0 || r >= 0); }
+- }
+-# endif
+-#endif
+-
+ #if defined (__CYGWIN__)
+ # include <ieeefp.h> // isnan
+ #endif
diff --git a/devel/simgear/pkg-plist b/devel/simgear/pkg-plist
index d3ec39231b82..10c6ae297c7f 100644
--- a/devel/simgear/pkg-plist
+++ b/devel/simgear/pkg-plist
@@ -1,181 +1,220 @@
-include/simgear/xml/easyxml.hxx
-include/simgear/debug/debug_types.h
-include/simgear/debug/logstream.hxx
-include/simgear/misc/sg_path.hxx
-include/simgear/misc/sgstream.hxx
-include/simgear/misc/stopwatch.hxx
-include/simgear/misc/strutils.hxx
-include/simgear/misc/tabbed_values.hxx
-include/simgear/misc/texcoord.hxx
-include/simgear/misc/zfstream.hxx
-include/simgear/misc/interpolator.hxx
-include/simgear/misc/stdint.hxx
-include/simgear/misc/PathOptions.hxx
-include/simgear/structure/callback.hxx
-include/simgear/structure/commands.hxx
-include/simgear/structure/exception.hxx
-include/simgear/structure/event_mgr.hxx
-include/simgear/structure/subsystem_mgr.hxx
-include/simgear/structure/OSGUtils.hxx
+include/simgear/compiler.h
+include/simgear/timing/timestamp.hxx
+include/simgear/timing/timezone.h
+include/simgear/timing/geocoord.h
+include/simgear/timing/sg_time.hxx
+include/simgear/timing/lowleveltime.h
+include/simgear/magvar/coremag.hxx
+include/simgear/magvar/magvar.hxx
+include/simgear/route/waypoint.hxx
+include/simgear/route/route.hxx
+include/simgear/version.h
+include/simgear/structure/SGSmplstat.hxx
include/simgear/structure/OSGVersion.hxx
+include/simgear/structure/exception.hxx
+include/simgear/structure/SGWeakPtr.hxx
+include/simgear/structure/StringTable.hxx
+include/simgear/structure/SGWeakReferenced.hxx
+include/simgear/structure/SGSharedPtr.hxx
include/simgear/structure/SGAtomic.hxx
-include/simgear/structure/SGBinding.hxx
+include/simgear/structure/commands.hxx
+include/simgear/structure/intern.hxx
+include/simgear/structure/OSGUtils.hxx
include/simgear/structure/SGExpression.hxx
+include/simgear/structure/Singleton.hxx
+include/simgear/structure/subsystem_mgr.hxx
+include/simgear/structure/event_mgr.hxx
+include/simgear/structure/SGBinding.hxx
include/simgear/structure/SGReferenced.hxx
-include/simgear/structure/SGSharedPtr.hxx
include/simgear/structure/SGSmplhist.hxx
-include/simgear/structure/SGSmplstat.hxx
-include/simgear/structure/Singleton.hxx
-include/simgear/bucket/newbucket.hxx
-include/simgear/ephemeris/celestialBody.hxx
-include/simgear/ephemeris/ephemeris.hxx
-include/simgear/ephemeris/jupiter.hxx
-include/simgear/ephemeris/mars.hxx
-include/simgear/ephemeris/mercury.hxx
-include/simgear/ephemeris/moonpos.hxx
-include/simgear/ephemeris/neptune.hxx
-include/simgear/ephemeris/saturn.hxx
-include/simgear/ephemeris/star.hxx
-include/simgear/ephemeris/stardata.hxx
-include/simgear/ephemeris/uranus.hxx
-include/simgear/ephemeris/venus.hxx
-include/simgear/io/iochannel.hxx
-include/simgear/io/lowlevel.hxx
-include/simgear/io/sg_binobj.hxx
-include/simgear/io/sg_file.hxx
-include/simgear/io/sg_serial.hxx
-include/simgear/io/sg_socket.hxx
-include/simgear/io/sg_socket_udp.hxx
-include/simgear/magvar/magvar.hxx
-include/simgear/math/interpolater.hxx
-include/simgear/math/leastsqs.hxx
-include/simgear/math/point3d.hxx
+include/simgear/structure/callback.hxx
+include/simgear/constants.h
+include/simgear/xml/easyxml.hxx
+include/simgear/sound/sample_group.hxx
+include/simgear/sound/sample_openal.hxx
+include/simgear/sound/xmlsound.hxx
+include/simgear/sound/soundmgr_openal.hxx
+include/simgear/math/vector.hxx
include/simgear/math/polar3d.hxx
-include/simgear/math/sg_geodesy.hxx
include/simgear/math/sg_random.h
-include/simgear/math/sg_types.hxx
-include/simgear/math/vector.hxx
include/simgear/math/Math.hxx
-include/simgear/math/SGBox.hxx
-include/simgear/math/SGCMath.hxx
-include/simgear/math/SGGeoc.hxx
+include/simgear/math/interpolater.hxx
+include/simgear/math/SGQuat.hxx
include/simgear/math/SGGeod.hxx
-include/simgear/math/SGGeodesy.hxx
-include/simgear/math/SGGeometry.hxx
-include/simgear/math/SGGeometryFwd.hxx
-include/simgear/math/SGIntersect.hxx
-include/simgear/math/SGLimits.hxx
+include/simgear/math/sg_types.hxx
+include/simgear/math/SGGeoc.hxx
+include/simgear/math/SGPlane.hxx
include/simgear/math/SGLineSegment.hxx
-include/simgear/math/SGMatrix.hxx
+include/simgear/math/SGGeometryFwd.hxx
+include/simgear/math/leastsqs.hxx
include/simgear/math/SGMath.hxx
-include/simgear/math/SGMathFwd.hxx
-include/simgear/math/SGMisc.hxx
-include/simgear/math/SGPlane.hxx
-include/simgear/math/SGQuat.hxx
-include/simgear/math/SGRay.hxx
+include/simgear/math/beziercurve.hxx
include/simgear/math/SGSphere.hxx
include/simgear/math/SGTriangle.hxx
include/simgear/math/SGVec2.hxx
-include/simgear/math/SGVec3.hxx
+include/simgear/math/SGMatrix.hxx
+include/simgear/math/SGIntersect.hxx
+include/simgear/math/point3d.hxx
+include/simgear/math/SGCMath.hxx
+include/simgear/math/SGGeodesy.hxx
+include/simgear/math/SGGeometry.hxx
+include/simgear/math/sg_geodesy.hxx
+include/simgear/math/SGMathFwd.hxx
+include/simgear/math/SGBox.hxx
include/simgear/math/SGVec4.hxx
+include/simgear/math/SGVec3.hxx
+include/simgear/math/SGMisc.hxx
+include/simgear/math/SGLimits.hxx
+include/simgear/math/SGRay.hxx
+include/simgear/serial/serial.hxx
+include/simgear/ephemeris/star.hxx
+include/simgear/ephemeris/celestialBody.hxx
+include/simgear/ephemeris/jupiter.hxx
+include/simgear/ephemeris/ephemeris.hxx
+include/simgear/ephemeris/stardata.hxx
+include/simgear/ephemeris/mercury.hxx
+include/simgear/ephemeris/uranus.hxx
+include/simgear/ephemeris/venus.hxx
+include/simgear/ephemeris/saturn.hxx
+include/simgear/ephemeris/neptune.hxx
+include/simgear/ephemeris/mars.hxx
+include/simgear/ephemeris/moonpos.hxx
+include/simgear/threads/SGGuard.hxx
+include/simgear/threads/SGQueue.hxx
+include/simgear/threads/SGThread.hxx
+include/simgear/misc/strutils.hxx
+include/simgear/misc/stopwatch.hxx
+include/simgear/misc/sgstream.hxx
+include/simgear/misc/PathOptions.hxx
+include/simgear/misc/interpolator.hxx
+include/simgear/misc/zfstream.hxx
+include/simgear/misc/tabbed_values.hxx
+include/simgear/misc/stdint.hxx
+include/simgear/misc/sg_path.hxx
+include/simgear/misc/texcoord.hxx
include/simgear/environment/metar.hxx
-include/simgear/environment/visual_enviro.hxx
include/simgear/environment/precipitation.hxx
-include/simgear/nasal/nasal.h
-include/simgear/nasal/naref.h
-include/simgear/props/condition.hxx
-include/simgear/props/props.hxx
-include/simgear/props/props_io.hxx
-include/simgear/route/route.hxx
-include/simgear/route/waypoint.hxx
-include/simgear/scene/material/mat.hxx
-include/simgear/scene/material/matlib.hxx
+include/simgear/environment/visual_enviro.hxx
+include/simgear/io/iochannel.hxx
+include/simgear/io/lowlevel.hxx
+include/simgear/io/sg_socket_udp.hxx
+include/simgear/io/sg_binobj.hxx
+include/simgear/io/sg_file.hxx
+include/simgear/io/sg_socket.hxx
+include/simgear/io/sg_serial.hxx
+include/simgear/screen/tr.h
+include/simgear/screen/jpgfactory.hxx
+include/simgear/screen/shader.h
+include/simgear/screen/RenderTexture.h
+include/simgear/screen/extensions.hxx
+include/simgear/screen/colors.hxx
+include/simgear/screen/screen-dump.hxx
+include/simgear/bucket/newbucket.hxx
+include/simgear/scene/material/EffectBuilder.hxx
+include/simgear/scene/material/Pass.hxx
+include/simgear/scene/material/EffectCullVisitor.hxx
+include/simgear/scene/material/GLPredicate.hxx
+include/simgear/scene/material/TextureBuilder.hxx
+include/simgear/scene/material/Effect.hxx
include/simgear/scene/material/matmodel.hxx
-include/simgear/scene/model/animation.hxx
-include/simgear/scene/model/particles.hxx
-include/simgear/scene/model/location.hxx
-include/simgear/scene/model/model.hxx
-include/simgear/scene/model/modellib.hxx
-include/simgear/scene/model/ModelRegistry.hxx
-include/simgear/scene/model/persparam.hxx
-include/simgear/scene/model/placement.hxx
-include/simgear/scene/model/placementtrans.hxx
-include/simgear/scene/model/CheckSceneryVisitor.hxx
-include/simgear/scene/model/SGClipGroup.hxx
-include/simgear/scene/model/SGMaterialAnimation.hxx
-include/simgear/scene/model/SGOffsetTransform.hxx
-include/simgear/scene/model/SGPagedLOD.hxx
-include/simgear/scene/model/SGReaderWriterXML.hxx
-include/simgear/scene/model/SGReaderWriterXMLOptions.hxx
-include/simgear/scene/model/SGRotateTransform.hxx
-include/simgear/scene/model/SGScaleTransform.hxx
-include/simgear/scene/model/SGTranslateTransform.hxx
-include/simgear/scene/sky/cloud.hxx
-include/simgear/scene/sky/dome.hxx
-include/simgear/scene/sky/moon.hxx
-include/simgear/scene/sky/oursun.hxx
-include/simgear/scene/sky/sky.hxx
-include/simgear/scene/sky/sphere.hxx
-include/simgear/scene/sky/stars.hxx
-include/simgear/scene/sky/bbcache.hxx
-include/simgear/scene/sky/cloudfield.hxx
-include/simgear/scene/sky/newcloud.hxx
-include/simgear/scene/sky/CloudShaderGeometry.hxx
-include/simgear/scene/tgdb/apt_signs.hxx
-include/simgear/scene/tgdb/obj.hxx
-include/simgear/scene/tgdb/pt_lights.hxx
-include/simgear/scene/tgdb/userdata.hxx
-include/simgear/scene/tgdb/ReaderWriterSTG.hxx
-include/simgear/scene/tgdb/SGOceanTile.hxx
+include/simgear/scene/material/matlib.hxx
+include/simgear/scene/material/EffectGeode.hxx
+include/simgear/scene/material/Technique.hxx
+include/simgear/scene/material/mat.hxx
include/simgear/scene/tgdb/SGVasiDrawable.hxx
+include/simgear/scene/tgdb/ReaderWriterSTG.hxx
+include/simgear/scene/tgdb/pt_lights.hxx
include/simgear/scene/tgdb/SGDirectionalLightBin.hxx
-include/simgear/scene/tgdb/SGLightBin.hxx
-include/simgear/scene/tgdb/SGReaderWriterBTGOptions.hxx
include/simgear/scene/tgdb/SGTexturedTriangleBin.hxx
-include/simgear/scene/tgdb/SGTriangleBin.hxx
-include/simgear/scene/tgdb/SGVertexArrayBin.hxx
+include/simgear/scene/tgdb/obj.hxx
+include/simgear/scene/tgdb/userdata.hxx
include/simgear/scene/tgdb/GroundLightManager.hxx
+include/simgear/scene/tgdb/SGLightBin.hxx
+include/simgear/scene/tgdb/SGReaderWriterBTG.hxx
+include/simgear/scene/tgdb/apt_signs.hxx
+include/simgear/scene/tgdb/SGVertexArrayBin.hxx
+include/simgear/scene/tgdb/SGReaderWriterBTGOptions.hxx
include/simgear/scene/tgdb/ShaderGeometry.hxx
-include/simgear/scene/tgdb/TileCache.hxx
include/simgear/scene/tgdb/TileEntry.hxx
-include/simgear/scene/util/SGDebugDrawCallback.hxx
-include/simgear/scene/util/SGEnlargeBoundingBox.hxx
+include/simgear/scene/tgdb/SGTriangleBin.hxx
+include/simgear/scene/tgdb/SGOceanTile.hxx
+include/simgear/scene/tgdb/TileCache.hxx
+include/simgear/scene/bvh/BVHStaticData.hxx
+include/simgear/scene/bvh/BVHStaticGeometry.hxx
+include/simgear/scene/bvh/BVHStaticLeaf.hxx
+include/simgear/scene/bvh/BVHStaticNode.hxx
+include/simgear/scene/bvh/BVHVisitor.hxx
+include/simgear/scene/bvh/BVHLineSegmentVisitor.hxx
+include/simgear/scene/bvh/BVHNode.hxx
+include/simgear/scene/bvh/BVHTransform.hxx
+include/simgear/scene/bvh/BVHGroup.hxx
+include/simgear/scene/bvh/BVHBoundingBoxVisitor.hxx
+include/simgear/scene/bvh/BVHStaticTriangle.hxx
+include/simgear/scene/bvh/BVHSubTreeCollector.hxx
+include/simgear/scene/bvh/BVHStaticBinary.hxx
+include/simgear/scene/bvh/BVHLineGeometry.hxx
+include/simgear/scene/bvh/BVHDebugCollectVisitor.hxx
+include/simgear/scene/bvh/BVHStaticGeometryBuilder.hxx
+include/simgear/scene/bvh/BVHMotionTransform.hxx
+include/simgear/scene/bvh/BVHNearestPointVisitor.hxx
+include/simgear/scene/util/UpdateOnceCallback.hxx
+include/simgear/scene/util/SplicingVisitor.hxx
include/simgear/scene/util/SGNodeMasks.hxx
-include/simgear/scene/util/SGPickCallback.hxx
+include/simgear/scene/util/CopyOp.hxx
+include/simgear/scene/util/VectorArrayAdapter.hxx
+include/simgear/scene/util/SGEnlargeBoundingBox.hxx
+include/simgear/scene/util/SGTextureStateAttributeVisitor.hxx
include/simgear/scene/util/SGSceneFeatures.hxx
-include/simgear/scene/util/SGSceneUserData.hxx
+include/simgear/scene/util/StateAttributeFactory.hxx
+include/simgear/scene/util/QuadTreeBuilder.hxx
+include/simgear/scene/util/PrimitiveUtils.hxx
+include/simgear/scene/util/SGPickCallback.hxx
+include/simgear/scene/util/NodeAndDrawableVisitor.hxx
+include/simgear/scene/util/SGDebugDrawCallback.hxx
include/simgear/scene/util/SGStateAttributeVisitor.hxx
-include/simgear/scene/util/SGTextureStateAttributeVisitor.hxx
include/simgear/scene/util/SGUpdateVisitor.hxx
-include/simgear/scene/util/NodeAndDrawableVisitor.hxx
-include/simgear/scene/util/QuadTreeBuilder.hxx
+include/simgear/scene/util/SGSceneUserData.hxx
include/simgear/scene/util/RenderConstants.hxx
-include/simgear/scene/util/StateAttributeFactory.hxx
-include/simgear/scene/util/VectorArrayAdapter.hxx
-include/simgear/screen/colors.hxx
-include/simgear/screen/texture.hxx
-include/simgear/screen/jpgfactory.hxx
-include/simgear/screen/screen-dump.hxx
-include/simgear/screen/extensions.hxx
-include/simgear/screen/RenderTexture.h
-include/simgear/screen/shader.h
-include/simgear/screen/tr.h
-include/simgear/serial/serial.hxx
-include/simgear/sound/sample_openal.hxx
-include/simgear/sound/soundmgr_openal.hxx
-include/simgear/sound/xmlsound.hxx
-include/simgear/threads/SGGuard.hxx
-include/simgear/threads/SGQueue.hxx
-include/simgear/threads/SGThread.hxx
-include/simgear/timing/geocoord.h
-include/simgear/timing/lowleveltime.h
-include/simgear/timing/sg_time.hxx
-include/simgear/timing/timestamp.hxx
-include/simgear/timing/timezone.h
-include/simgear/compiler.h
-include/simgear/constants.h
+include/simgear/scene/sky/sky.hxx
+include/simgear/scene/sky/cloud.hxx
+include/simgear/scene/sky/CloudShaderGeometry.hxx
+include/simgear/scene/sky/oursun.hxx
+include/simgear/scene/sky/moon.hxx
+include/simgear/scene/sky/bbcache.hxx
+include/simgear/scene/sky/dome.hxx
+include/simgear/scene/sky/stars.hxx
+include/simgear/scene/sky/newcloud.hxx
+include/simgear/scene/sky/sphere.hxx
+include/simgear/scene/sky/cloudfield.hxx
+include/simgear/scene/model/persparam.hxx
+include/simgear/scene/model/modellib.hxx
+include/simgear/scene/model/SGOffsetTransform.hxx
+include/simgear/scene/model/SGText.hxx
+include/simgear/scene/model/SGClipGroup.hxx
+include/simgear/scene/model/SGRotateTransform.hxx
+include/simgear/scene/model/SGScaleTransform.hxx
+include/simgear/scene/model/placement.hxx
+include/simgear/scene/model/SGTranslateTransform.hxx
+include/simgear/scene/model/ModelRegistry.hxx
+include/simgear/scene/model/CheckSceneryVisitor.hxx
+include/simgear/scene/model/particles.hxx
+include/simgear/scene/model/SGInteractionAnimation.hxx
+include/simgear/scene/model/SGReaderWriterXML.hxx
+include/simgear/scene/model/SGMaterialAnimation.hxx
+include/simgear/scene/model/model.hxx
+include/simgear/scene/model/SGReaderWriterXMLOptions.hxx
+include/simgear/scene/model/animation.hxx
+include/simgear/scene/model/SGPagedLOD.hxx
+include/simgear/props/condition.hxx
+include/simgear/props/props.hxx
+include/simgear/props/ExtendedPropertyAdapter.hxx
+include/simgear/props/props_io.hxx
+include/simgear/props/AtomicChangeListener.hxx
+include/simgear/debug/debug_types.h
+include/simgear/debug/logstream.hxx
+include/simgear/nasal/naref.h
+include/simgear/nasal/nasal.h
include/simgear/sg_inlines.h
-include/simgear/version.h
@dirrm include/simgear/xml
@dirrm include/simgear/timing
@dirrm include/simgear/threads
@@ -188,6 +227,7 @@ include/simgear/version.h
@dirrm include/simgear/scene/sky
@dirrm include/simgear/scene/model
@dirrm include/simgear/scene/material
+@dirrm include/simgear/scene/bvh
@dirrm include/simgear/scene
@dirrm include/simgear/route
@dirrm include/simgear/props
@@ -201,26 +241,27 @@ include/simgear/version.h
@dirrm include/simgear/debug
@dirrm include/simgear/bucket
@dirrm include/simgear
-lib/libsgxml.a
-lib/libsgdebug.a
lib/libsgmisc.a
-lib/libsgstructure.a
-lib/libsgbucket.a
-lib/libsgephem.a
-lib/libsgio.a
-lib/libsgmagvar.a
-lib/libsgmath.a
-lib/libsgenvironment.a
-lib/libsgnasal.a
+lib/libsgscreen.a
lib/libsgprops.a
lib/libsgroute.a
-lib/libsgmaterial.a
lib/libsgmodel.a
-lib/libsgsky.a
+lib/libsgmath.a
+lib/libsgmaterial.a
lib/libsgtgdb.a
-lib/libsgutil.a
-lib/libsgscreen.a
+lib/libsgmagvar.a
+lib/libsgstructure.a
+lib/libsgdebug.a
+lib/libsgnasal.a
+lib/libsgsky.a
lib/libsgserial.a
+lib/libsgutil.a
+lib/libsgtiming.a
+lib/libsgxml.a
+lib/libsgbvh.a
lib/libsgsound.a
+lib/libsgio.a
+lib/libsgenvironment.a
+lib/libsgbucket.a
+lib/libsgephem.a
lib/libsgthreads.a
-lib/libsgtiming.a