aboutsummaryrefslogtreecommitdiffstats
path: root/devel
diff options
context:
space:
mode:
authorpi <pi@FreeBSD.org>2019-09-22 18:42:03 +0800
committerpi <pi@FreeBSD.org>2019-09-22 18:42:03 +0800
commit6618325b6dfa8c9fb458cd9f0694cf879b879413 (patch)
treeaf12b598cc9b388190a0e5ec43b1f555a848ded8 /devel
parentebd4f5517f42a0ad785939fec3c21b5ca6e2c685 (diff)
downloadfreebsd-ports-gnome-6618325b6dfa8c9fb458cd9f0694cf879b879413.tar.gz
freebsd-ports-gnome-6618325b6dfa8c9fb458cd9f0694cf879b879413.tar.zst
freebsd-ports-gnome-6618325b6dfa8c9fb458cd9f0694cf879b879413.zip
New port: devel/ros-catkin_pkg
This is a Python library for working with the Catkin package system for ROS. Catkin is the main build system for the Robot Operating System. WWW: http://github.com/ros/catkin PR: 235843 Submitted by: Trenton Schulz <trueos@norwegianrockcat.com>
Diffstat (limited to 'devel')
-rw-r--r--devel/Makefile1
-rw-r--r--devel/ros-catkin_pkg/Makefile27
-rw-r--r--devel/ros-catkin_pkg/distinfo3
-rw-r--r--devel/ros-catkin_pkg/pkg-descr5
4 files changed, 36 insertions, 0 deletions
diff --git a/devel/Makefile b/devel/Makefile
index 6c312b20ea0d..5e5bd1bf12c6 100644
--- a/devel/Makefile
+++ b/devel/Makefile
@@ -5393,6 +5393,7 @@
SUBDIR += roboctl
SUBDIR += robodoc
SUBDIR += root-doc
+ SUBDIR += ros-catkin_pkg
SUBDIR += ros-rosinstall_generator
SUBDIR += ros-vcstools
SUBDIR += ros-wstool
diff --git a/devel/ros-catkin_pkg/Makefile b/devel/ros-catkin_pkg/Makefile
new file mode 100644
index 000000000000..fb4e26d3339e
--- /dev/null
+++ b/devel/ros-catkin_pkg/Makefile
@@ -0,0 +1,27 @@
+# $FreeBSD$
+
+PORTNAME= ros-catkin_pkg
+DISTVERSION= 0.4.13
+CATEGORIES= devel
+PKGNAMEPREFIX= ${PYTHON_PKGNAMEPREFIX}
+
+MAINTAINER= trueos@norwegianrockcat.com
+COMMENT= Standard Python library for the catkin build system
+
+LICENSE= BSD3CLAUSE
+LICENSE_FILE= ${WRKSRC}/LICENSE
+
+RUN_DEPENDS= ${PYTHON_PKGNAMEPREFIX}argparse>=1:devel/py-argparse@${PY_FLAVOR} \
+ ${PYTHON_PKGNAMEPREFIX}dateutil>=2:devel/py-dateutil@${PY_FLAVOR} \
+ ${PYTHON_PKGNAMEPREFIX}pyparsing>=2:devel/py-pyparsing@${PY_FLAVOR} \
+ ${PYTHON_PKGNAMEPREFIX}docutils>=0:textproc/py-docutils@${PY_FLAVOR}
+
+USES= python
+
+USE_PYTHON= distutils autoplist
+
+USE_GITHUB= yes
+GH_ACCOUNT= ros-infrastructure
+GH_PROJECT= catkin_pkg
+
+.include <bsd.port.mk>
diff --git a/devel/ros-catkin_pkg/distinfo b/devel/ros-catkin_pkg/distinfo
new file mode 100644
index 000000000000..c1cf0fb20c36
--- /dev/null
+++ b/devel/ros-catkin_pkg/distinfo
@@ -0,0 +1,3 @@
+TIMESTAMP = 1568623995
+SHA256 (ros-infrastructure-catkin_pkg-0.4.13_GH0.tar.gz) = 843a8ad05e498e1eb3c9f75496d7410058af3a9d8e52b4339a8d1a6b3ff3aced
+SIZE (ros-infrastructure-catkin_pkg-0.4.13_GH0.tar.gz) = 61790
diff --git a/devel/ros-catkin_pkg/pkg-descr b/devel/ros-catkin_pkg/pkg-descr
new file mode 100644
index 000000000000..e654aa618c8a
--- /dev/null
+++ b/devel/ros-catkin_pkg/pkg-descr
@@ -0,0 +1,5 @@
+This is a Python library for working with the Catkin package system for ROS.
+
+Catkin is the main build system for the Robot Operating System.
+
+WWW: http://github.com/ros/catkin