aboutsummaryrefslogtreecommitdiffstats
path: root/devel
diff options
context:
space:
mode:
authorolgeni <olgeni@FreeBSD.org>2010-01-20 20:40:13 +0800
committerolgeni <olgeni@FreeBSD.org>2010-01-20 20:40:13 +0800
commit67470e3e62a80c8c5bfdb82dd0dc1f83227a4466 (patch)
tree7390db757292594b0ac05dc13ba7933b2952dbee /devel
parent1248f9e714648228a7a75582c43573a23552a73a (diff)
downloadfreebsd-ports-gnome-67470e3e62a80c8c5bfdb82dd0dc1f83227a4466.tar.gz
freebsd-ports-gnome-67470e3e62a80c8c5bfdb82dd0dc1f83227a4466.tar.zst
freebsd-ports-gnome-67470e3e62a80c8c5bfdb82dd0dc1f83227a4466.zip
When building ASDF modules with the previous cl-asdf port version,
sometimes the build would fail because of "missing" packages that weren't actually missing (this only happened in ports that aren't committed yet). Rewrite the FASL placement code using the asdf-binary-locations extension, which is already included in the cl-asdf port but needs to be installed from ports when building for SBCL (which has its own ASDF code). The binary-locations code generates paths unsuitable for PLISTs, therefore it has been overridden with lisp-specific-fasl-subdir. Because of the new code, PLIST generation for cl-*-sbcl and cl-*-clisp ports is now entirely automated. All dependent cl-* ports are upgraded (obsolete code removed, PORTREVISION bumped).
Diffstat (limited to 'devel')
-rw-r--r--devel/cl-alexandria-clisp/Makefile1
-rw-r--r--devel/cl-alexandria-clisp/pkg-plist18
-rw-r--r--devel/cl-alexandria-sbcl/Makefile1
-rw-r--r--devel/cl-alexandria-sbcl/pkg-plist18
-rw-r--r--devel/cl-asdf-clisp/Makefile2
-rw-r--r--devel/cl-asdf-clisp/pkg-plist2
-rw-r--r--devel/cl-asdf/Makefile2
-rw-r--r--devel/cl-asdf/bsd.cl-asdf.mk28
-rw-r--r--devel/cl-asdf/files/asdf-init.lisp66
-rw-r--r--devel/cl-infix-sbcl/Makefile2
-rw-r--r--devel/cl-infix-sbcl/pkg-plist2
-rw-r--r--devel/cl-port-clisp/Makefile2
-rw-r--r--devel/cl-port-clisp/pkg-plist8
-rw-r--r--devel/cl-port-sbcl/Makefile2
-rw-r--r--devel/cl-port-sbcl/pkg-plist8
-rw-r--r--devel/cl-split-sequence-clisp/Makefile2
-rw-r--r--devel/cl-split-sequence-clisp/pkg-plist2
-rw-r--r--devel/cl-split-sequence-sbcl/Makefile2
-rw-r--r--devel/cl-split-sequence-sbcl/pkg-plist2
-rw-r--r--devel/cl-trivial-features-clisp/Makefile5
-rw-r--r--devel/cl-trivial-features-clisp/pkg-plist2
-rw-r--r--devel/cl-trivial-features-sbcl/Makefile5
-rw-r--r--devel/cl-trivial-features-sbcl/pkg-plist2
-rw-r--r--devel/cl-trivial-gray-streams-clisp/Makefile1
-rw-r--r--devel/cl-trivial-gray-streams-clisp/pkg-plist3
-rw-r--r--devel/cl-trivial-gray-streams-sbcl/Makefile1
-rw-r--r--devel/cl-trivial-gray-streams-sbcl/pkg-plist3
-rw-r--r--devel/cl-uffi-sbcl/Makefile6
-rw-r--r--devel/cl-uffi-sbcl/pkg-plist9
29 files changed, 67 insertions, 140 deletions
diff --git a/devel/cl-alexandria-clisp/Makefile b/devel/cl-alexandria-clisp/Makefile
index 3faf3573b6e4..f73e8428b767 100644
--- a/devel/cl-alexandria-clisp/Makefile
+++ b/devel/cl-alexandria-clisp/Makefile
@@ -6,6 +6,7 @@
PORTNAME= alexandria
PORTVERSION= 2010.01.16
+PORTREVISION= 1
CATEGORIES= devel lisp
PKGNAMEPREFIX= cl-
DISTFILES= # none
diff --git a/devel/cl-alexandria-clisp/pkg-plist b/devel/cl-alexandria-clisp/pkg-plist
deleted file mode 100644
index f368199a3dc7..000000000000
--- a/devel/cl-alexandria-clisp/pkg-plist
+++ /dev/null
@@ -1,18 +0,0 @@
-%%LIB32DIR%%/common-lisp/alexandria/clispfasl/arrays.fasl
-%%LIB32DIR%%/common-lisp/alexandria/clispfasl/binding.fasl
-%%LIB32DIR%%/common-lisp/alexandria/clispfasl/conditions.fasl
-%%LIB32DIR%%/common-lisp/alexandria/clispfasl/control-flow.fasl
-%%LIB32DIR%%/common-lisp/alexandria/clispfasl/definitions.fasl
-%%LIB32DIR%%/common-lisp/alexandria/clispfasl/features.fasl
-%%LIB32DIR%%/common-lisp/alexandria/clispfasl/functions.fasl
-%%LIB32DIR%%/common-lisp/alexandria/clispfasl/hash-tables.fasl
-%%LIB32DIR%%/common-lisp/alexandria/clispfasl/io.fasl
-%%LIB32DIR%%/common-lisp/alexandria/clispfasl/lists.fasl
-%%LIB32DIR%%/common-lisp/alexandria/clispfasl/macros.fasl
-%%LIB32DIR%%/common-lisp/alexandria/clispfasl/numbers.fasl
-%%LIB32DIR%%/common-lisp/alexandria/clispfasl/package.fasl
-%%LIB32DIR%%/common-lisp/alexandria/clispfasl/sequences.fasl
-%%LIB32DIR%%/common-lisp/alexandria/clispfasl/strings.fasl
-%%LIB32DIR%%/common-lisp/alexandria/clispfasl/symbols.fasl
-%%LIB32DIR%%/common-lisp/alexandria/clispfasl/types.fasl
-@dirrm %%LIB32DIR%%/common-lisp/alexandria/clispfasl
diff --git a/devel/cl-alexandria-sbcl/Makefile b/devel/cl-alexandria-sbcl/Makefile
index fae2c5df649e..733c0d003a36 100644
--- a/devel/cl-alexandria-sbcl/Makefile
+++ b/devel/cl-alexandria-sbcl/Makefile
@@ -6,6 +6,7 @@
PORTNAME= alexandria
PORTVERSION= 2010.01.16
+PORTREVISION= 1
CATEGORIES= devel lisp
PKGNAMEPREFIX= cl-
DISTFILES= # none
diff --git a/devel/cl-alexandria-sbcl/pkg-plist b/devel/cl-alexandria-sbcl/pkg-plist
deleted file mode 100644
index bc7fb0db0a1f..000000000000
--- a/devel/cl-alexandria-sbcl/pkg-plist
+++ /dev/null
@@ -1,18 +0,0 @@
-%%LIB32DIR%%/common-lisp/alexandria/sbclfasl/arrays.fasl
-%%LIB32DIR%%/common-lisp/alexandria/sbclfasl/binding.fasl
-%%LIB32DIR%%/common-lisp/alexandria/sbclfasl/conditions.fasl
-%%LIB32DIR%%/common-lisp/alexandria/sbclfasl/control-flow.fasl
-%%LIB32DIR%%/common-lisp/alexandria/sbclfasl/definitions.fasl
-%%LIB32DIR%%/common-lisp/alexandria/sbclfasl/features.fasl
-%%LIB32DIR%%/common-lisp/alexandria/sbclfasl/functions.fasl
-%%LIB32DIR%%/common-lisp/alexandria/sbclfasl/hash-tables.fasl
-%%LIB32DIR%%/common-lisp/alexandria/sbclfasl/io.fasl
-%%LIB32DIR%%/common-lisp/alexandria/sbclfasl/lists.fasl
-%%LIB32DIR%%/common-lisp/alexandria/sbclfasl/macros.fasl
-%%LIB32DIR%%/common-lisp/alexandria/sbclfasl/numbers.fasl
-%%LIB32DIR%%/common-lisp/alexandria/sbclfasl/package.fasl
-%%LIB32DIR%%/common-lisp/alexandria/sbclfasl/sequences.fasl
-%%LIB32DIR%%/common-lisp/alexandria/sbclfasl/strings.fasl
-%%LIB32DIR%%/common-lisp/alexandria/sbclfasl/symbols.fasl
-%%LIB32DIR%%/common-lisp/alexandria/sbclfasl/types.fasl
-@dirrm %%LIB32DIR%%/common-lisp/alexandria/sbclfasl
diff --git a/devel/cl-asdf-clisp/Makefile b/devel/cl-asdf-clisp/Makefile
index 579495702792..0df9309eb551 100644
--- a/devel/cl-asdf-clisp/Makefile
+++ b/devel/cl-asdf-clisp/Makefile
@@ -6,7 +6,7 @@
PORTNAME= asdf
PORTVERSION= 1.374
-PORTREVISION= 1
+PORTREVISION= 2
PORTEPOCH= 1
CATEGORIES= devel lisp
PKGNAMEPREFIX= cl-
diff --git a/devel/cl-asdf-clisp/pkg-plist b/devel/cl-asdf-clisp/pkg-plist
deleted file mode 100644
index 9ab70a3fc4e5..000000000000
--- a/devel/cl-asdf-clisp/pkg-plist
+++ /dev/null
@@ -1,2 +0,0 @@
-lib/common-lisp/asdf/clispfasl/asdf.fasl
-@dirrm lib/common-lisp/asdf/clispfasl
diff --git a/devel/cl-asdf/Makefile b/devel/cl-asdf/Makefile
index 26f27631bd3a..49e7184836c7 100644
--- a/devel/cl-asdf/Makefile
+++ b/devel/cl-asdf/Makefile
@@ -9,7 +9,7 @@
PORTNAME= asdf
PORTVERSION= 1.374
-PORTREVISION= 1
+PORTREVISION= 2
PORTEPOCH= 1
CATEGORIES= devel lisp
PKGNAMEPREFIX= cl-
diff --git a/devel/cl-asdf/bsd.cl-asdf.mk b/devel/cl-asdf/bsd.cl-asdf.mk
index 82270e653494..e288b06484c4 100644
--- a/devel/cl-asdf/bsd.cl-asdf.mk
+++ b/devel/cl-asdf/bsd.cl-asdf.mk
@@ -15,7 +15,7 @@
# USE_CLISP - If set, depend on lang/clisp
# USE_ASDF - If set, depend on devel/cl-asdf
# USE_ASDF_FASL - If set, set dependency on compiled ASDF files (only if
-# required by the chosed FASL_TARGET)
+# required by the chosen FASL_TARGET)
# FASL_BUILD - If set, compile FASL files using the ASDF framework
# ASDF_MODULES - If FASL_BUILD is set: list of ASDF modules to compile
@@ -55,8 +55,12 @@ RUN_DEPENDS+= clisp:${PORTSDIR}/lang/clisp
.if defined(USE_ASDF)
# Even if the Common Lisp compiler already has a bundled ASDF framework,
# we still need the asdf-init file.
-BUILD_DEPENDS+= ${LOCALBASE}/${CL_LIBDIR_REL}/asdf/asdf.lisp:${PORTSDIR}/devel/cl-asdf
-RUN_DEPENDS+= ${LOCALBASE}/${CL_LIBDIR_REL}/asdf/asdf.lisp:${PORTSDIR}/devel/cl-asdf
+
+BUILD_DEPENDS+= ${LOCALBASE}/${CL_LIBDIR_REL}/asdf/asdf.asd:${PORTSDIR}/devel/cl-asdf \
+ ${LOCALBASE}/${CL_LIBDIR_REL}/asdf-binary-locations/asdf-binary-locations.asd:${PORTSDIR}/devel/cl-asdf-binary-locations
+RUN_DEPENDS+= ${LOCALBASE}/${CL_LIBDIR_REL}/asdf/asdf.asd:${PORTSDIR}/devel/cl-asdf \
+ ${LOCALBASE}/${CL_LIBDIR_REL}/asdf-binary-locations/asdf-binary-locations.asd:${PORTSDIR}/devel/cl-asdf-binary-locations
+
.endif # defined(USE_ASDF)
.if defined(USE_ASDF_FASL)
@@ -81,7 +85,7 @@ do-build:
.for MODULE in ${ASDF_MODULES}
.if defined(USE_SBCL)
- @FBSD_ASDF_COMPILE_PORT=t WRKSRC=${WRKSRC}/ \
+ @FBSD_ASDF_COMPILE_PORT=t PORTNAME=${PORTNAME} WRKSRC=${WRKSRC}/ \
${SBCL} --noinform --userinit /dev/null --disable-debugger \
--eval '#.(load "${LOCALBASE}/etc/asdf-init")' \
--eval "(asdf:oos 'asdf:compile-op :${MODULE})" \
@@ -89,10 +93,11 @@ do-build:
.endif # USE_SBCL
.if defined(USE_CLISP)
- @FBSD_ASDF_COMPILE_PORT=t WRKSRC=${WRKSRC}/ \
+ @FBSD_ASDF_COMPILE_PORT=t PORTNAME=${PORTNAME} WRKSRC=${WRKSRC}/ \
${CLISP} -q -ansi -norc \
-i ${LOCALBASE}/etc/asdf-init \
-x "(asdf:oos 'asdf:compile-op :${MODULE})"
+ @${FIND} ${WRKSRC} -name "*.lib" | ${XARGS} ${RM}
.endif # USE_CLISP
.endfor
@@ -103,8 +108,19 @@ do-build:
do-install:
@${MKDIR} ${FASL_PATHNAME}
- @${INSTALL_DATA} ${WRKSRC}/*.fasl ${FASL_PATHNAME}
+ @cd ${WRKSRC} && ${COPYTREE_SHARE} . ${FASL_PATHNAME}
.endif # !target(do-install)
+post-install:
+ @cd ${WRKSRC} && ${FIND} * -type f \
+ | ${SORT} \
+ | ${AWK} '{ print "${CL_LIBDIR_REL}/${PORTNAME}/${FASL_DIR_REL}/" $$1 }' \
+ > ${TMPPLIST}
+ @cd ${WRKSRC} && ${FIND} * -type d \
+ | ${SORT} -r \
+ | ${AWK} '{ print "@dirrm ${CL_LIBDIR_REL}/${PORTNAME}/${FASL_DIR_REL}/" $$1 }' \
+ >> ${TMPPLIST}
+ @${ECHO_CMD} "@dirrm ${CL_LIBDIR_REL}/${PORTNAME}/${FASL_DIR_REL}" >> ${TMPPLIST}
+
.endif # FASL_BUILD
diff --git a/devel/cl-asdf/files/asdf-init.lisp b/devel/cl-asdf/files/asdf-init.lisp
index 93408f0bb249..9913c1fc1800 100644
--- a/devel/cl-asdf/files/asdf-init.lisp
+++ b/devel/cl-asdf/files/asdf-init.lisp
@@ -155,7 +155,6 @@ should modify that in order to add other directories.")
(lisp-implementation-type)
(lisp-implementation-version)))))
-
(defun lisp-specific-fasl-subdir ()
"Return the subdirectory in which fasl files for this Lisp
implementations should be stored, as a string without any slashes.
@@ -209,41 +208,38 @@ LISP-SPECIFIC-FASL-SUBDIR as well."
(pushnew *system-registry* asdf:*central-registry*)
-;;;; Messing with asdf:output-files
+;; The bundled ASDF in SBCL needs asdf-binary-locations
+#+sbcl (asdf:operate 'asdf:load-op :asdf-binary-locations)
+
+(defun asdf:implementation-specific-directory-name ()
+ "Return a name that can be used as a directory name that is unique to
+a Lisp implementation, Lisp implementation version, operating system,
+and hardware architecture. This implementation is designed for the
+FreeBSD ports system and returns a simplified directory name (sbclfasl,
+clispfasl, ...) by calling lisp-specific-fasl-subdir."
+ (lisp-specific-fasl-subdir))
+
+(setf asdf:*source-to-target-mappings*
+ '(#+openmcl ("%%PREFIX%%/lib/ccl/" nil)
+ #+sbcl ("%%PREFIX%%/lib/sbcl/" nil)))
+
+(defmethod asdf:output-files :around ((op asdf:compile-op)
+ (file asdf:cl-source-file))
+ (let ((default-output-file (car (call-next-method))))
+ (list
+ (make-pathname
+ :directory (pathname-directory (namestring default-output-file))
+ :type "fasl"
+ :defaults default-output-file))))
(if (and (getenv "FBSD_ASDF_COMPILE_PORT")
- (getenv "WRKSRC"))
-
- ;; We are compiling a port - fasls should go to ${WRKSRC}
- (defmethod asdf:output-files :around ((op asdf:compile-op)
- (file asdf:cl-source-file))
- (let ((wrksrc (getenv "WRKSRC"))
- (relative-name (asdf:component-relative-pathname file))
- (default-output-name (car (call-next-method))))
- (list
- (make-pathname
- :host (pathname-host wrksrc)
- :device (pathname-device wrksrc)
- :directory `(:absolute ,@(cdr (pathname-directory wrksrc))
- ,@(cdr (pathname-directory relative-name)))
- :name (pathname-name default-output-name)
- :type "fasl"))))
-
- ;; Normal operation: load from lisp-specific-fasl-subdir
- (defmethod asdf:output-files :around ((op asdf:compile-op)
- (file asdf:cl-source-file))
- (let ((default-output-file (car (call-next-method))))
- (let ((output-file-string (namestring default-output-file)))
- (list
- (if
- (or
- (search "%%PREFIX%%/lib/ccl" output-file-string)
- (search "%%PREFIX%%/lib/sbcl" output-file-string))
- (make-pathname :defaults default-output-file)
- (make-pathname
- :directory `(:absolute ,@(cdr (pathname-directory default-output-file))
- ,(lisp-specific-fasl-subdir))
- :type "fasl"
- :defaults default-output-file)))))))
+ (getenv "PORTNAME")
+ (getenv "WRKSRC"))
+ (let ((wrksrc (getenv "WRKSRC"))
+ (portname (getenv "PORTNAME")))
+ ;; If we are building a FreeBSD port, all the compiled fasl files
+ ;; should be redirected to WRKSRC.
+ (let ((package (format nil "%%PREFIX%%/lib/common-lisp/~A/" portname)))
+ (pushnew (list package wrksrc) asdf:*source-to-target-mappings*))))
;;;; asdf-init.lisp ends here
diff --git a/devel/cl-infix-sbcl/Makefile b/devel/cl-infix-sbcl/Makefile
index a35741a7b78f..ad50d457471d 100644
--- a/devel/cl-infix-sbcl/Makefile
+++ b/devel/cl-infix-sbcl/Makefile
@@ -6,7 +6,7 @@
PORTNAME= infix
PORTVERSION= 19960628
-PORTREVISION= 1
+PORTREVISION= 2
CATEGORIES= devel lisp
PKGNAMEPREFIX= cl-
DISTFILES= # none
diff --git a/devel/cl-infix-sbcl/pkg-plist b/devel/cl-infix-sbcl/pkg-plist
deleted file mode 100644
index 151a6aba7903..000000000000
--- a/devel/cl-infix-sbcl/pkg-plist
+++ /dev/null
@@ -1,2 +0,0 @@
-lib/common-lisp/infix/sbclfasl/infix.fasl
-@dirrm lib/common-lisp/infix/sbclfasl
diff --git a/devel/cl-port-clisp/Makefile b/devel/cl-port-clisp/Makefile
index 4e8600aa1029..4702b09fcd8e 100644
--- a/devel/cl-port-clisp/Makefile
+++ b/devel/cl-port-clisp/Makefile
@@ -6,7 +6,7 @@
PORTNAME= port
PORTVERSION= 2002.10.02.1
-PORTREVISION= 3
+PORTREVISION= 4
CATEGORIES= devel lisp
PKGNAMEPREFIX= cl-
DISTFILES= # none
diff --git a/devel/cl-port-clisp/pkg-plist b/devel/cl-port-clisp/pkg-plist
deleted file mode 100644
index 8d2eaee66dd2..000000000000
--- a/devel/cl-port-clisp/pkg-plist
+++ /dev/null
@@ -1,8 +0,0 @@
-lib/common-lisp/port/clispfasl/ext.fasl
-lib/common-lisp/port/clispfasl/gray.fasl
-lib/common-lisp/port/clispfasl/net.fasl
-lib/common-lisp/port/clispfasl/path.fasl
-lib/common-lisp/port/clispfasl/proc.fasl
-lib/common-lisp/port/clispfasl/shell.fasl
-lib/common-lisp/port/clispfasl/sys.fasl
-@dirrm lib/common-lisp/port/clispfasl
diff --git a/devel/cl-port-sbcl/Makefile b/devel/cl-port-sbcl/Makefile
index fca6c1768ecd..c229478086a8 100644
--- a/devel/cl-port-sbcl/Makefile
+++ b/devel/cl-port-sbcl/Makefile
@@ -6,7 +6,7 @@
PORTNAME= port
PORTVERSION= 2002.10.02.1
-PORTREVISION= 1
+PORTREVISION= 2
CATEGORIES= devel lisp
PKGNAMEPREFIX= cl-
DISTFILES= # none
diff --git a/devel/cl-port-sbcl/pkg-plist b/devel/cl-port-sbcl/pkg-plist
deleted file mode 100644
index c48543cae173..000000000000
--- a/devel/cl-port-sbcl/pkg-plist
+++ /dev/null
@@ -1,8 +0,0 @@
-lib/common-lisp/port/sbclfasl/ext.fasl
-lib/common-lisp/port/sbclfasl/gray.fasl
-lib/common-lisp/port/sbclfasl/net.fasl
-lib/common-lisp/port/sbclfasl/path.fasl
-lib/common-lisp/port/sbclfasl/proc.fasl
-lib/common-lisp/port/sbclfasl/shell.fasl
-lib/common-lisp/port/sbclfasl/sys.fasl
-@dirrm lib/common-lisp/port/sbclfasl
diff --git a/devel/cl-split-sequence-clisp/Makefile b/devel/cl-split-sequence-clisp/Makefile
index 6ed2e431e982..c93ed9a762fe 100644
--- a/devel/cl-split-sequence-clisp/Makefile
+++ b/devel/cl-split-sequence-clisp/Makefile
@@ -6,7 +6,7 @@
PORTNAME= split-sequence
PORTVERSION= 20011114.1
-PORTREVISION= 3
+PORTREVISION= 4
CATEGORIES= devel lisp
PKGNAMEPREFIX= cl-
DISTFILES= # none
diff --git a/devel/cl-split-sequence-clisp/pkg-plist b/devel/cl-split-sequence-clisp/pkg-plist
deleted file mode 100644
index cc28c153cfb5..000000000000
--- a/devel/cl-split-sequence-clisp/pkg-plist
+++ /dev/null
@@ -1,2 +0,0 @@
-lib/common-lisp/split-sequence/clispfasl/split-sequence.fasl
-@dirrm lib/common-lisp/split-sequence/clispfasl
diff --git a/devel/cl-split-sequence-sbcl/Makefile b/devel/cl-split-sequence-sbcl/Makefile
index 78fb662b377f..776ea794e56d 100644
--- a/devel/cl-split-sequence-sbcl/Makefile
+++ b/devel/cl-split-sequence-sbcl/Makefile
@@ -6,7 +6,7 @@
PORTNAME= split-sequence
PORTVERSION= 20011114.1
-PORTREVISION= 1
+PORTREVISION= 2
CATEGORIES= devel lisp
PKGNAMEPREFIX= cl-
DISTFILES= # none
diff --git a/devel/cl-split-sequence-sbcl/pkg-plist b/devel/cl-split-sequence-sbcl/pkg-plist
deleted file mode 100644
index a37df7314122..000000000000
--- a/devel/cl-split-sequence-sbcl/pkg-plist
+++ /dev/null
@@ -1,2 +0,0 @@
-lib/common-lisp/split-sequence/sbclfasl/split-sequence.fasl
-@dirrm lib/common-lisp/split-sequence/sbclfasl
diff --git a/devel/cl-trivial-features-clisp/Makefile b/devel/cl-trivial-features-clisp/Makefile
index ac8a7dae1a55..eb568bcd9673 100644
--- a/devel/cl-trivial-features-clisp/Makefile
+++ b/devel/cl-trivial-features-clisp/Makefile
@@ -6,6 +6,7 @@
PORTNAME= trivial-features
PORTVERSION= 2010.01.16
+PORTREVISION= 1
CATEGORIES= devel lisp
PKGNAMEPREFIX= cl-
DISTFILES= # none
@@ -20,9 +21,5 @@ USE_ASDF_FASL= yes
FASL_TARGET= clisp
FASL_BUILD= yes
-do-install:
- @${MKDIR} ${ASDF_PATHNAME}/src/${FASL_DIR_REL}
- @${INSTALL_DATA} ${WRKSRC}/*.fasl ${ASDF_PATHNAME}/src/${FASL_DIR_REL}
-
.include "${.CURDIR}/../../devel/cl-asdf/bsd.cl-asdf.mk"
.include <bsd.port.mk>
diff --git a/devel/cl-trivial-features-clisp/pkg-plist b/devel/cl-trivial-features-clisp/pkg-plist
deleted file mode 100644
index 4f5030cc164f..000000000000
--- a/devel/cl-trivial-features-clisp/pkg-plist
+++ /dev/null
@@ -1,2 +0,0 @@
-%%LIB32DIR%%/common-lisp/trivial-features/src/clispfasl/tf-clisp.fasl
-@dirrm %%LIB32DIR%%/common-lisp/trivial-features/src/clispfasl
diff --git a/devel/cl-trivial-features-sbcl/Makefile b/devel/cl-trivial-features-sbcl/Makefile
index 0563dc783a37..b718ec32c0cc 100644
--- a/devel/cl-trivial-features-sbcl/Makefile
+++ b/devel/cl-trivial-features-sbcl/Makefile
@@ -6,6 +6,7 @@
PORTNAME= trivial-features
PORTVERSION= 2010.01.16
+PORTREVISION= 1
CATEGORIES= devel lisp
PKGNAMEPREFIX= cl-
DISTFILES= # none
@@ -20,9 +21,5 @@ USE_ASDF_FASL= yes
FASL_TARGET= sbcl
FASL_BUILD= yes
-do-install:
- @${MKDIR} ${ASDF_PATHNAME}/src/${FASL_DIR_REL}
- @${INSTALL_DATA} ${WRKSRC}/*.fasl ${ASDF_PATHNAME}/src/${FASL_DIR_REL}
-
.include "${.CURDIR}/../../devel/cl-asdf/bsd.cl-asdf.mk"
.include <bsd.port.mk>
diff --git a/devel/cl-trivial-features-sbcl/pkg-plist b/devel/cl-trivial-features-sbcl/pkg-plist
deleted file mode 100644
index c4acd855a8b5..000000000000
--- a/devel/cl-trivial-features-sbcl/pkg-plist
+++ /dev/null
@@ -1,2 +0,0 @@
-%%LIB32DIR%%/common-lisp/trivial-features/src/sbclfasl/tf-sbcl.fasl
-@dirrm %%LIB32DIR%%/common-lisp/trivial-features/src/sbclfasl
diff --git a/devel/cl-trivial-gray-streams-clisp/Makefile b/devel/cl-trivial-gray-streams-clisp/Makefile
index 257f3c44fae6..ddb4b31fad0d 100644
--- a/devel/cl-trivial-gray-streams-clisp/Makefile
+++ b/devel/cl-trivial-gray-streams-clisp/Makefile
@@ -6,6 +6,7 @@
PORTNAME= trivial-gray-streams
PORTVERSION= 2008.11.02
+PORTREVISION= 1
CATEGORIES= devel lisp
PKGNAMEPREFIX= cl-
DISTFILES= # none
diff --git a/devel/cl-trivial-gray-streams-clisp/pkg-plist b/devel/cl-trivial-gray-streams-clisp/pkg-plist
deleted file mode 100644
index 22f5fda9966f..000000000000
--- a/devel/cl-trivial-gray-streams-clisp/pkg-plist
+++ /dev/null
@@ -1,3 +0,0 @@
-%%LIB32DIR%%/common-lisp/trivial-gray-streams/clispfasl/mixin.fasl
-%%LIB32DIR%%/common-lisp/trivial-gray-streams/clispfasl/package.fasl
-@dirrm %%LIB32DIR%%/common-lisp/trivial-gray-streams/clispfasl
diff --git a/devel/cl-trivial-gray-streams-sbcl/Makefile b/devel/cl-trivial-gray-streams-sbcl/Makefile
index b2589f8ad259..0489dd4ac2d0 100644
--- a/devel/cl-trivial-gray-streams-sbcl/Makefile
+++ b/devel/cl-trivial-gray-streams-sbcl/Makefile
@@ -6,6 +6,7 @@
PORTNAME= trivial-gray-streams
PORTVERSION= 2008.11.02
+PORTREVISION= 1
CATEGORIES= devel lisp
PKGNAMEPREFIX= cl-
DISTFILES= # none
diff --git a/devel/cl-trivial-gray-streams-sbcl/pkg-plist b/devel/cl-trivial-gray-streams-sbcl/pkg-plist
deleted file mode 100644
index 254ebe6353e9..000000000000
--- a/devel/cl-trivial-gray-streams-sbcl/pkg-plist
+++ /dev/null
@@ -1,3 +0,0 @@
-%%LIB32DIR%%/common-lisp/trivial-gray-streams/sbclfasl/mixin.fasl
-%%LIB32DIR%%/common-lisp/trivial-gray-streams/sbclfasl/package.fasl
-@dirrm %%LIB32DIR%%/common-lisp/trivial-gray-streams/sbclfasl
diff --git a/devel/cl-uffi-sbcl/Makefile b/devel/cl-uffi-sbcl/Makefile
index a0f6e5e311b7..732a3c4f32af 100644
--- a/devel/cl-uffi-sbcl/Makefile
+++ b/devel/cl-uffi-sbcl/Makefile
@@ -6,7 +6,7 @@
PORTNAME= uffi
PORTVERSION= 1.6.2
-PORTREVISION= 1
+PORTREVISION= 2
CATEGORIES= devel lisp
PKGNAMEPREFIX= cl-
DISTFILES= # none
@@ -21,9 +21,5 @@ USE_ASDF_FASL= yes
FASL_TARGET= sbcl
FASL_BUILD= yes
-do-install:
- @${MKDIR} ${ASDF_PATHNAME}/src/${FASL_DIR_REL}
- @${INSTALL_DATA} ${WRKSRC}/*.fasl ${ASDF_PATHNAME}/src/${FASL_DIR_REL}
-
.include "${.CURDIR}/../../devel/cl-asdf/bsd.cl-asdf.mk"
.include <bsd.port.mk>
diff --git a/devel/cl-uffi-sbcl/pkg-plist b/devel/cl-uffi-sbcl/pkg-plist
deleted file mode 100644
index 796525d14e41..000000000000
--- a/devel/cl-uffi-sbcl/pkg-plist
+++ /dev/null
@@ -1,9 +0,0 @@
-%%LIB32DIR%%/common-lisp/uffi/src/sbclfasl/aggregates.fasl
-%%LIB32DIR%%/common-lisp/uffi/src/sbclfasl/functions.fasl
-%%LIB32DIR%%/common-lisp/uffi/src/sbclfasl/libraries.fasl
-%%LIB32DIR%%/common-lisp/uffi/src/sbclfasl/objects.fasl
-%%LIB32DIR%%/common-lisp/uffi/src/sbclfasl/os.fasl
-%%LIB32DIR%%/common-lisp/uffi/src/sbclfasl/package.fasl
-%%LIB32DIR%%/common-lisp/uffi/src/sbclfasl/primitives.fasl
-%%LIB32DIR%%/common-lisp/uffi/src/sbclfasl/strings.fasl
-@dirrm %%LIB32DIR%%/common-lisp/uffi/src/sbclfasl