aboutsummaryrefslogtreecommitdiffstats
path: root/devel
diff options
context:
space:
mode:
authorsada <sada@FreeBSD.org>2002-11-17 13:03:54 +0800
committersada <sada@FreeBSD.org>2002-11-17 13:03:54 +0800
commit678796d68f78e59552202a6dc781c058e84ccab5 (patch)
treec41d2d272c020fad9decc7fd52ba2c4d6b181908 /devel
parent3df22975f641e9f39851b20ebf2ac710cf17257a (diff)
downloadfreebsd-ports-gnome-678796d68f78e59552202a6dc781c058e84ccab5.tar.gz
freebsd-ports-gnome-678796d68f78e59552202a6dc781c058e84ccab5.tar.zst
freebsd-ports-gnome-678796d68f78e59552202a6dc781c058e84ccab5.zip
Resurrection of port devel/pear
PR: ports/44473 Submitted by: Thierry Thomas <thierry@pompo.net>
Diffstat (limited to 'devel')
-rw-r--r--devel/Makefile4
-rw-r--r--devel/pear-Console_Getopt/Makefile38
-rw-r--r--devel/pear-Console_Getopt/distinfo1
-rw-r--r--devel/pear-Console_Getopt/pkg-comment1
-rw-r--r--devel/pear-Console_Getopt/pkg-descr4
-rw-r--r--devel/pear-Console_Getopt/pkg-plist3
-rw-r--r--devel/pear-PEAR/Makefile45
-rw-r--r--devel/pear-PEAR/distinfo1
-rw-r--r--devel/pear-PEAR/pkg-comment1
-rw-r--r--devel/pear-PEAR/pkg-descr4
-rw-r--r--devel/pear-PEAR/pkg-plist34
-rw-r--r--devel/pear-install/Makefile39
-rw-r--r--devel/pear-install/pkg-comment1
-rw-r--r--devel/pear-install/pkg-descr6
-rw-r--r--devel/pear-install/pkg-plist4
-rw-r--r--devel/pear/Makefile42
-rw-r--r--devel/pear/pkg-comment1
-rw-r--r--devel/pear/pkg-descr20
-rw-r--r--devel/pear/pkg-plist1
19 files changed, 250 insertions, 0 deletions
diff --git a/devel/Makefile b/devel/Makefile
index 6dfc83f54e80..7e4e86c03a2d 100644
--- a/devel/Makefile
+++ b/devel/Makefile
@@ -623,6 +623,10 @@
SUBDIR += pcre
SUBDIR += pcre++
SUBDIR += pcsc-lite
+ SUBDIR += pear
+ SUBDIR += pear-Console_Getopt
+ SUBDIR += pear-PEAR
+ SUBDIR += pear-install
SUBDIR += pedisassem
SUBDIR += perforce
SUBDIR += perltidy
diff --git a/devel/pear-Console_Getopt/Makefile b/devel/pear-Console_Getopt/Makefile
new file mode 100644
index 000000000000..59ae58dd8d56
--- /dev/null
+++ b/devel/pear-Console_Getopt/Makefile
@@ -0,0 +1,38 @@
+# Ports collection makefile for: pear-Console_Getopt
+# Date created: 23 October 2002
+# Whom: Thierry Thomas (<thierry@pompo.net>)
+#
+# $FreeBSD$
+#
+
+PORTNAME= Console_Getopt
+PORTVERSION= 1.0
+CATEGORIES= devel www
+MASTER_SITES= http://pear.php.net/get/
+PKGNAMEPREFIX= pear-
+EXTRACT_SUFX= .tgz
+DIST_SUBDIR= PEAR
+
+MAINTAINER= ports@FreeBSD.org
+
+BUILD_DEPENDS= ${PEARDIR}.DIST_PHP:${PORTSDIR}/devel/pear-install
+RUN_DEPENDS= ${PEARDIR}.DIST_PHP:${PORTSDIR}/devel/pear-install \
+ ${LOCALBASE}/bin/php:${PORTSDIR}/lang/php4
+
+NO_BUILD= yes
+
+.include <bsd.port.pre.mk>
+
+.if exists(${LOCALBASE}/bin/php-config)
+PHP_BASE!= ${LOCALBASE}/bin/php-config --prefix
+.endif
+LPHP_LIB= lib/php
+PEARDIR= ${PHP_BASE}/${LPHP_LIB}
+PLIST_SUB= PEARDIR=${LPHP_LIB}
+
+do-install:
+ @${MV} ${PEARDIR}/Console/Getopt.php ${PEARDIR}/Console/Getopt.php.dist
+ @${CP} -Rp ${WRKSRC}/Console/Getopt.php ${PEARDIR}/Console
+ @${CHOWN} -R root:wheel ${PEARDIR}/Console/Getopt.php
+
+.include <bsd.port.post.mk>
diff --git a/devel/pear-Console_Getopt/distinfo b/devel/pear-Console_Getopt/distinfo
new file mode 100644
index 000000000000..d07b6da5dd75
--- /dev/null
+++ b/devel/pear-Console_Getopt/distinfo
@@ -0,0 +1 @@
+MD5 (PEAR/Console_Getopt-1.0.tgz) = 0a80d98559c9c0d20f6128b5edcb9aac
diff --git a/devel/pear-Console_Getopt/pkg-comment b/devel/pear-Console_Getopt/pkg-comment
new file mode 100644
index 000000000000..9f6b1b2ff609
--- /dev/null
+++ b/devel/pear-Console_Getopt/pkg-comment
@@ -0,0 +1 @@
+PEAR command-line option parser
diff --git a/devel/pear-Console_Getopt/pkg-descr b/devel/pear-Console_Getopt/pkg-descr
new file mode 100644
index 000000000000..bdfd95f64fe2
--- /dev/null
+++ b/devel/pear-Console_Getopt/pkg-descr
@@ -0,0 +1,4 @@
+This is a PHP implementation of "getopt" supporting both short and long
+options.
+
+WWW: http://pear.php.net/manual/en/core.console.getopt.php
diff --git a/devel/pear-Console_Getopt/pkg-plist b/devel/pear-Console_Getopt/pkg-plist
new file mode 100644
index 000000000000..3887db705822
--- /dev/null
+++ b/devel/pear-Console_Getopt/pkg-plist
@@ -0,0 +1,3 @@
+@exec mv %D/lib/php/Console/Getopt.php %D/lib/php/Console/Getopt.php.dist
+%%PEARDIR%%/Console/Getopt.php
+@unexec mv %D/lib/php/Console/Getopt.php.dist %D/lib/php/Console/Getopt.php || true
diff --git a/devel/pear-PEAR/Makefile b/devel/pear-PEAR/Makefile
new file mode 100644
index 000000000000..b1bb6bede494
--- /dev/null
+++ b/devel/pear-PEAR/Makefile
@@ -0,0 +1,45 @@
+# Ports collection makefile for: pear-PEAR
+# Date created: 22 October 2002
+# Whom: Thierry Thomas (<thierry@pompo.net>)
+#
+# $FreeBSD$
+#
+
+PORTNAME= PEAR
+PORTVERSION= 1.0.1
+CATEGORIES= devel www
+MASTER_SITES= http://pear.php.net/get/
+PKGNAMEPREFIX= pear-
+DISTNAME= ${PORTNAME}-${PORTVERSION:S/.1/b1/}
+EXTRACT_SUFX= .tgz
+DIST_SUBDIR= PEAR
+
+MAINTAINER= ports@FreeBSD.org
+
+BUILD_DEPENDS= ${PEARDIR}.DIST_PHP:${PORTSDIR}/devel/pear-install
+RUN_DEPENDS= ${PEARDIR}.DIST_PHP:${PORTSDIR}/devel/pear-install
+
+NO_BUILD= yes
+
+.include <bsd.port.pre.mk>
+
+.if exists(${LOCALBASE}/bin/php-config)
+PHP_BASE!= ${LOCALBASE}/bin/php-config --prefix
+.endif
+LPHP_LIB= lib/php
+PEARDIR= ${PHP_BASE}/${LPHP_LIB}
+PLIST_SUB= PEARDIR=${LPHP_LIB}
+
+do-install:
+ @${MV} ${PEARDIR}/PEAR ${PEARDIR}/PEAR.dist
+ @${MV} ${PEARDIR}/PEAR.php ${PEARDIR}/PEAR.php.dist
+ @${MV} ${PEARDIR}/System.php ${PEARDIR}/System.php.dist
+ @${CP} -Rp ${WRKSRC}/* ${PEARDIR}
+ @${CHOWN} -R root:wheel ${PEARDIR}/OS
+ @${CHOWN} -R root:wheel ${PEARDIR}/PEAR*
+ @${CHOWN} -R root:wheel ${PEARDIR}/System.php
+ @${CHOWN} -R root:wheel ${PEARDIR}/package.dtd
+ @${CHOWN} -R root:wheel ${PEARDIR}/scripts
+ @${CHOWN} -R root:wheel ${PEARDIR}/template.spec
+
+.include <bsd.port.post.mk>
diff --git a/devel/pear-PEAR/distinfo b/devel/pear-PEAR/distinfo
new file mode 100644
index 000000000000..fe522402bd58
--- /dev/null
+++ b/devel/pear-PEAR/distinfo
@@ -0,0 +1 @@
+MD5 (PEAR/PEAR-1.0b1.tgz) = 6109077247d825df343f766713e899de
diff --git a/devel/pear-PEAR/pkg-comment b/devel/pear-PEAR/pkg-comment
new file mode 100644
index 000000000000..bee5cc06093c
--- /dev/null
+++ b/devel/pear-PEAR/pkg-comment
@@ -0,0 +1 @@
+PEAR Base System
diff --git a/devel/pear-PEAR/pkg-descr b/devel/pear-PEAR/pkg-descr
new file mode 100644
index 000000000000..a74f3c8c6a11
--- /dev/null
+++ b/devel/pear-PEAR/pkg-descr
@@ -0,0 +1,4 @@
+PEAR Base System, with the PEAR base class and the PEAR_Error error handling
+mechanism.
+
+WWW: http://pear.php.net/manual/en/reference.php
diff --git a/devel/pear-PEAR/pkg-plist b/devel/pear-PEAR/pkg-plist
new file mode 100644
index 000000000000..9f99761be75d
--- /dev/null
+++ b/devel/pear-PEAR/pkg-plist
@@ -0,0 +1,34 @@
+%%PEARDIR%%/package.dtd
+%%PEARDIR%%/template.spec
+%%PEARDIR%%/PEAR.php
+%%PEARDIR%%/System.php
+%%PEARDIR%%/OS/Guess.php
+%%PEARDIR%%/PEAR/Autoloader.php
+%%PEARDIR%%/PEAR/Command.php
+%%PEARDIR%%/PEAR/Command/Auth.php
+%%PEARDIR%%/PEAR/Command/Build.php
+%%PEARDIR%%/PEAR/Command/Common.php
+%%PEARDIR%%/PEAR/Command/Config.php
+%%PEARDIR%%/PEAR/Command/Install.php
+%%PEARDIR%%/PEAR/Command/Package.php
+%%PEARDIR%%/PEAR/Command/Registry.php
+%%PEARDIR%%/PEAR/Command/Remote.php
+%%PEARDIR%%/PEAR/Common.php
+%%PEARDIR%%/PEAR/Config.php
+%%PEARDIR%%/PEAR/Dependency.php
+%%PEARDIR%%/PEAR/Frontend/CLI.php
+%%PEARDIR%%/PEAR/Builder.php
+%%PEARDIR%%/PEAR/Installer.php
+%%PEARDIR%%/PEAR/Packager.php
+%%PEARDIR%%/PEAR/Registry.php
+%%PEARDIR%%/PEAR/Remote.php
+%%PEARDIR%%/scripts/pear.in
+%%PEARDIR%%/scripts/pear.bat
+@dirrm %%PEARDIR%%/OS
+@dirrm %%PEARDIR%%/PEAR/Command
+@dirrm %%PEARDIR%%/PEAR/Frontend
+@dirrm %%PEARDIR%%/PEAR
+@dirrm %%PEARDIR%%/scripts
+@unexec mv %D/lib/php/PEAR.dist %D/lib/php/PEAR || true
+@unexec mv %D/lib/php/PEAR.php.dist %D/lib/php/PEAR.php || true
+@unexec mv %D/lib/php/System.php.dist %D/lib/php/System.php || true
diff --git a/devel/pear-install/Makefile b/devel/pear-install/Makefile
new file mode 100644
index 000000000000..c651a1bd0ccf
--- /dev/null
+++ b/devel/pear-install/Makefile
@@ -0,0 +1,39 @@
+# Ports collection makefile for: pear-install
+# Date created: 21 October 2002
+# Whom: Thierry Thomas (<thierry@pompo.net>)
+#
+# $FreeBSD$
+#
+
+PORTNAME= pear-install
+PORTVERSION= ${PHP_VERSION}
+CATEGORIES= devel www
+MASTER_SITES= # empty
+DISTFILES= # none
+EXTRACT_ONLY= # empty
+
+MAINTAINER= thierry@pompo.net
+
+BUILD_DEPENDS= ${LOCALBASE}/bin/php-config:${PORTSDIR}/www/mod_php4
+RUN_DEPENDS= ${LOCALBASE}/libexec/apache/libphp4.so:${PORTSDIR}/www/mod_php4
+
+NO_BUILD= yes
+
+.include <bsd.port.pre.mk>
+
+.if exists(${LOCALBASE}/bin/php-config)
+PHP_VERSION!= ${LOCALBASE}/bin/php-config --version
+PHP_BASE!= ${LOCALBASE}/bin/php-config --prefix
+.else
+PHP_VERSION= 4.2.3
+.endif
+LPHP_LIB= lib/php
+
+PEARDIR= ${PHP_BASE}/${LPHP_LIB}
+
+do-install:
+ @${ECHO_MSG} "===> Backuping the original PEAR from mod_php4 into ${PEARDIR}.DIST_PHP ..."
+ @${MKDIR} ${PEARDIR}.DIST_PHP
+ @${CP} -Rp ${PEARDIR}/* ${PEARDIR}.DIST_PHP
+
+.include <bsd.port.post.mk>
diff --git a/devel/pear-install/pkg-comment b/devel/pear-install/pkg-comment
new file mode 100644
index 000000000000..b69ccf50f469
--- /dev/null
+++ b/devel/pear-install/pkg-comment
@@ -0,0 +1 @@
+Prepare the installation of the PEAR framework
diff --git a/devel/pear-install/pkg-descr b/devel/pear-install/pkg-descr
new file mode 100644
index 000000000000..c56e666d755d
--- /dev/null
+++ b/devel/pear-install/pkg-descr
@@ -0,0 +1,6 @@
+This port does not install anything, but it prepares the installation of
+new PEAR packages.
+
+It is required by every pear- package in the FreeBSD ports tree.
+
+WWW: http://pear.php.net/
diff --git a/devel/pear-install/pkg-plist b/devel/pear-install/pkg-plist
new file mode 100644
index 000000000000..ba8e0f102edb
--- /dev/null
+++ b/devel/pear-install/pkg-plist
@@ -0,0 +1,4 @@
+@exec rm -r %D/lib/php.DIST_PHP 2>/dev/null || true
+@exec cp -Rp %D/lib/php %D/lib/php.DIST_PHP
+@unexec rm -r %D/lib/php || true
+@unexec mv %D/lib/php.DIST_PHP %D/lib/php || true
diff --git a/devel/pear/Makefile b/devel/pear/Makefile
new file mode 100644
index 000000000000..aa371d67c6ff
--- /dev/null
+++ b/devel/pear/Makefile
@@ -0,0 +1,42 @@
+# Ports collection makefile for: pear
+# Date created: Sat Nov 10, 2001
+# Whom: Thierry Thomas (<thierry@pompo.net>)
+#
+# $FreeBSD$
+#
+
+PORTNAME= pear
+PORTVERSION= ${PHP_VERSION}
+CATEGORIES= devel www
+MASTER_SITES= # empty
+DISTFILES= # none
+EXTRACT_ONLY= # empty
+
+MAINTAINER= thierry@pompo.net
+
+BUILD_DEPENDS= ${LOCALBASE}/bin/php-config:${PORTSDIR}/www/mod_php4
+RUN_DEPENDS= ${PEARDIR}/PEAR.php.dist:${PORTSDIR}/devel/pear-PEAR \
+ ${PEARDIR}/Console/Getopt.php.dist:${PORTSDIR}/devel/pear-Console_Getopt \
+ ${PEARDIR}/File.php:${PORTSDIR}/sysutils/pear-File \
+ ${PEARDIR}/Log.php:${PORTSDIR}/sysutils/pear-Log \
+ ${PEARDIR}/Mail/mime.php:${PORTSDIR}/mail/pear-Mail_Mime \
+ ${PEARDIR}/Net/Sieve.php:${PORTSDIR}/net/pear-Net_Sieve
+
+NO_BUILD= yes
+
+.include <bsd.port.pre.mk>
+
+.if exists(${LOCALBASE}/bin/php-config)
+PHP_VERSION!= ${LOCALBASE}/bin/php-config --version
+PHP_BASE!= ${LOCALBASE}/bin/php-config --prefix
+.else
+PHP_VERSION= 4.2.3
+PHP_BASE= ${LOCALBASE}
+.endif
+LPHP_LIB= lib/php
+PEARDIR= ${PHP_BASE}/${LPHP_LIB}
+
+do-install: # empty
+ ${DO_NADA}
+
+.include <bsd.port.post.mk>
diff --git a/devel/pear/pkg-comment b/devel/pear/pkg-comment
new file mode 100644
index 000000000000..bccf091e076a
--- /dev/null
+++ b/devel/pear/pkg-comment
@@ -0,0 +1 @@
+A framework and distribution system for reusable PHP components
diff --git a/devel/pear/pkg-descr b/devel/pear/pkg-descr
new file mode 100644
index 000000000000..5e107e566a81
--- /dev/null
+++ b/devel/pear/pkg-descr
@@ -0,0 +1,20 @@
+PEAR is a code repository for PHP extensions and PHP library code
+inspired by TeX's CTAN and Perl's CPAN.
+
+The purpose of PEAR is:
+
+ * to provide a consistent means for library code authors to
+ share their code with other developers;
+
+ * to give the PHP community an infrastructure for sharing code;
+
+ * to define standards that help developers write portable and
+ reusable code;
+
+ * to provide tools for code maintenance and distribution.
+
+PEAR comes bundled with PHP4. However, since it is a rapidly evolving
+target, not everyone who has a workable version of PHP4 has a recent
+enough PEAR installation.
+
+WWW: http://pear.php.net/
diff --git a/devel/pear/pkg-plist b/devel/pear/pkg-plist
new file mode 100644
index 000000000000..549a621fec0c
--- /dev/null
+++ b/devel/pear/pkg-plist
@@ -0,0 +1 @@
+@comment this plist intentionally left empty