aboutsummaryrefslogtreecommitdiffstats
path: root/devel
diff options
context:
space:
mode:
authoreadler <eadler@FreeBSD.org>2013-07-07 01:27:41 +0800
committereadler <eadler@FreeBSD.org>2013-07-07 01:27:41 +0800
commit67e5d292ef066c898650750db1b5b2b1abfa9e10 (patch)
treed2047a81a3f38403bf0492097a8a80d4d1b384eb /devel
parent33f83ace3690c88d9d0a404fecef289f1c7d4523 (diff)
downloadfreebsd-ports-gnome-67e5d292ef066c898650750db1b5b2b1abfa9e10.tar.gz
freebsd-ports-gnome-67e5d292ef066c898650750db1b5b2b1abfa9e10.tar.zst
freebsd-ports-gnome-67e5d292ef066c898650750db1b5b2b1abfa9e10.zip
Convert some of my ports from USE_GMAKE to USES=gmake.
The remainder have other pending patches which I must finish before conversion.
Diffstat (limited to 'devel')
-rw-r--r--devel/adime/Makefile2
-rw-r--r--devel/creduce/Makefile3
-rw-r--r--devel/csmith/Makefile3
-rw-r--r--devel/delta/Makefile2
-rw-r--r--devel/smake/Makefile2
5 files changed, 7 insertions, 5 deletions
diff --git a/devel/adime/Makefile b/devel/adime/Makefile
index 824bb69929c9..19922c26b1cc 100644
--- a/devel/adime/Makefile
+++ b/devel/adime/Makefile
@@ -12,7 +12,7 @@ COMMENT= Generate Allegro dialogs in a very simple way
LIB_DEPENDS= alleg:${PORTSDIR}/devel/allegro
-USE_GMAKE= yes
+USES= gmake
.include "Makefile.man"
diff --git a/devel/creduce/Makefile b/devel/creduce/Makefile
index 2bb740613863..70937249ab94 100644
--- a/devel/creduce/Makefile
+++ b/devel/creduce/Makefile
@@ -26,9 +26,10 @@ GH_TAGNAME= a2422d5
GH_COMMIT= a2422d5
GNU_CONFIGURE= yes
-USE_GMAKE= yes
USE_PERL5= yes
+USES= gmake
+
MAKE_JOBS_SAFE= yes
.include <bsd.port.mk>
diff --git a/devel/csmith/Makefile b/devel/csmith/Makefile
index c798b42dc1fb..4a82407c3046 100644
--- a/devel/csmith/Makefile
+++ b/devel/csmith/Makefile
@@ -11,13 +11,14 @@ COMMENT= Generates random C programs that conform to the C99 standard
LICENSE= BSD
GNU_CONFIGURE= yes
-USE_GMAKE= yes
USE_AUTOTOOLS= autoconf
USE_LDCONFIG= yes
CONFIGURE_ARGS= --docdir=${DOCSDIR}
CPPFLAGS+= -I${LOCALBASE}/include
LDFLAGS+= -L${LOCALBASE}/lib
+USES= gmake
+
MAKE_JOBS_SAFE= yes
ONLY_FOR_ARCHS= i386 amd64
diff --git a/devel/delta/Makefile b/devel/delta/Makefile
index a24cd1e5aad5..a5b88526fc7c 100644
--- a/devel/delta/Makefile
+++ b/devel/delta/Makefile
@@ -12,7 +12,7 @@ LICENSE= BSD
PLIST_FILES= bin/delta bin/multidelta bin/topformflat
-USE_GMAKE= yes
+USES= gmake
MAKE_JOBS_SAFE= yes
do-install:
diff --git a/devel/smake/Makefile b/devel/smake/Makefile
index 29e9cf00879f..288d61c9477e 100644
--- a/devel/smake/Makefile
+++ b/devel/smake/Makefile
@@ -17,7 +17,7 @@ LICENSE_FILE_CDDL= ${WRKSRC}/CDDL.Schily.txt
WRKSRC= ${WRKDIR}/${PORTNAME}-${PORTVERSION:C/.a.*//g}
USE_BZIP2= yes
-USE_GMAKE= yes
+USES= gmake
MAKE_ARGS= INS_BASE=${PREFIX} DEFMANBASE=.
MAKE_JOBS_SAFE= yes