aboutsummaryrefslogtreecommitdiffstats
path: root/devel
diff options
context:
space:
mode:
authorache <ache@FreeBSD.org>2012-02-21 20:26:02 +0800
committerache <ache@FreeBSD.org>2012-02-21 20:26:02 +0800
commit68902d7b7a7cdbfc4c2a2b5d5ee5eaa9f34971d6 (patch)
treefc7c1a2d286a823d4fb90a5cfdff29257286d3c5 /devel
parent7715671b90a38e12d2a6508f9ec42ea25dee5aa6 (diff)
downloadfreebsd-ports-gnome-68902d7b7a7cdbfc4c2a2b5d5ee5eaa9f34971d6.tar.gz
freebsd-ports-gnome-68902d7b7a7cdbfc4c2a2b5d5ee5eaa9f34971d6.tar.zst
freebsd-ports-gnome-68902d7b7a7cdbfc4c2a2b5d5ee5eaa9f34971d6.zip
A subclass to emulate boundless DEC VT102 terminal
Diffstat (limited to 'devel')
-rw-r--r--devel/Makefile1
-rw-r--r--devel/p5-Term-VT102-Boundless/Makefile24
-rw-r--r--devel/p5-Term-VT102-Boundless/distinfo2
-rw-r--r--devel/p5-Term-VT102-Boundless/pkg-descr8
-rw-r--r--devel/p5-Term-VT102-Boundless/pkg-plist7
5 files changed, 42 insertions, 0 deletions
diff --git a/devel/Makefile b/devel/Makefile
index 4a7bdc438cf7..d05cb33a398f 100644
--- a/devel/Makefile
+++ b/devel/Makefile
@@ -2473,6 +2473,7 @@
SUBDIR += p5-Term-Title
SUBDIR += p5-Term-UI
SUBDIR += p5-Term-VT102
+ SUBDIR += p5-Term-VT102-Boundless
SUBDIR += p5-Term-Visual
SUBDIR += p5-Test-Aggregate
SUBDIR += p5-Test-Assertions
diff --git a/devel/p5-Term-VT102-Boundless/Makefile b/devel/p5-Term-VT102-Boundless/Makefile
new file mode 100644
index 000000000000..e8f3f05df93f
--- /dev/null
+++ b/devel/p5-Term-VT102-Boundless/Makefile
@@ -0,0 +1,24 @@
+# New ports collection makefile for: p5-Term-VT102-Boundless
+# Date created: 2012-02-21
+# Whom: Andrey Chernov <ache@FreeBSD.org>
+#
+# $FreeBSD$
+#
+
+PORTNAME= Term-VT102-Boundless
+PORTVERSION= 0.04
+CATEGORIES= devel perl5
+MASTER_SITES= CPAN
+MASTER_SITE_SUBDIR= Term
+PKGNAMEPREFIX= p5-
+
+MAINTAINER= perl@FreeBSD.org
+COMMENT= A subclass to emulate boundless DEC VT102 terminal
+
+RUN_DEPENDS= ${SITE_PERL}/Term/VT102.pm:${PORTSDIR}/devel/p5-Term-VT102
+
+PERL_CONFIGURE= yes
+
+MAN3= Term::VT102::Boundless.3
+
+.include <bsd.port.mk>
diff --git a/devel/p5-Term-VT102-Boundless/distinfo b/devel/p5-Term-VT102-Boundless/distinfo
new file mode 100644
index 000000000000..f1f86c06a37c
--- /dev/null
+++ b/devel/p5-Term-VT102-Boundless/distinfo
@@ -0,0 +1,2 @@
+SHA256 (Term-VT102-Boundless-0.04.tar.gz) = 5bb88b5aecb44ebf56d3ac7240be80cd26def9dcf1ebeb4e77d9983dfc7a8f19
+SIZE (Term-VT102-Boundless-0.04.tar.gz) = 2857
diff --git a/devel/p5-Term-VT102-Boundless/pkg-descr b/devel/p5-Term-VT102-Boundless/pkg-descr
new file mode 100644
index 000000000000..44fdd78bd970
--- /dev/null
+++ b/devel/p5-Term-VT102-Boundless/pkg-descr
@@ -0,0 +1,8 @@
+This is a subclass of Term::VT102 that will grow the virtual screen to
+accomodate arbitrary width and height of text.
+
+The behavior is more similar to the buffer of a scrolling terminal
+emulator than to a real terminal, making it useful for output displays
+in scrolling media.
+
+WWW: http://search.cpan.org/dist/Term-VT102-Boundless/
diff --git a/devel/p5-Term-VT102-Boundless/pkg-plist b/devel/p5-Term-VT102-Boundless/pkg-plist
new file mode 100644
index 000000000000..b6da70562f87
--- /dev/null
+++ b/devel/p5-Term-VT102-Boundless/pkg-plist
@@ -0,0 +1,7 @@
+%%SITE_PERL%%/%%PERL_ARCH%%/auto/Term/VT102/Boundless/.packlist
+%%SITE_PERL%%/Term/VT102/Boundless.pm
+@dirrmtry %%SITE_PERL%%/Term/VT102
+@dirrmtry %%SITE_PERL%%/Term
+@dirrmtry %%SITE_PERL%%/%%PERL_ARCH%%/auto/Term/VT102/Boundless
+@dirrmtry %%SITE_PERL%%/%%PERL_ARCH%%/auto/Term/VT102
+@dirrmtry %%SITE_PERL%%/%%PERL_ARCH%%/auto/Term