aboutsummaryrefslogtreecommitdiffstats
path: root/devel
diff options
context:
space:
mode:
authorwg <wg@FreeBSD.org>2014-06-25 04:09:34 +0800
committerwg <wg@FreeBSD.org>2014-06-25 04:09:34 +0800
commit69801087f737f5b49302459ef6fbebb43467a06d (patch)
treeaa5703a3df6e905f69c61b84464e9a1b23d6e71c /devel
parent336dee06c9f346d1d5bb34a0d6fec0aae69191fd (diff)
downloadfreebsd-ports-gnome-69801087f737f5b49302459ef6fbebb43467a06d.tar.gz
freebsd-ports-gnome-69801087f737f5b49302459ef6fbebb43467a06d.tar.zst
freebsd-ports-gnome-69801087f737f5b49302459ef6fbebb43467a06d.zip
devel/roboctl: update to 0.3.8
- Support stage - Add LICENSE (GPLv3) PR: 191341 Submitted by: maintainer
Diffstat (limited to 'devel')
-rw-r--r--devel/roboctl/Makefile28
-rw-r--r--devel/roboctl/distinfo4
-rw-r--r--devel/roboctl/pkg-plist4
3 files changed, 19 insertions, 17 deletions
diff --git a/devel/roboctl/Makefile b/devel/roboctl/Makefile
index a3a77740d12b..e67517f0a4c0 100644
--- a/devel/roboctl/Makefile
+++ b/devel/roboctl/Makefile
@@ -2,39 +2,37 @@
# $FreeBSD$
PORTNAME= roboctl
-PORTVERSION= 0.3.7
+PORTVERSION= 0.3.8
CATEGORIES= devel
-MASTER_SITES= http://personalpages.tds.net/~jwbacon/Ports/distfiles/ \
- http://jbacon.dyndns.org/~bacon/Ports/distfiles/
+MASTER_SITES= http://acadix.biz/Ports/distfiles/ \
+ http://personalpages.tds.net/~jwbacon/Ports/distfiles/
MAINTAINER= jwbacon@tds.net
COMMENT= API and tools for communicating with Lego and Vex robots
+LICENSE= GPLv3
+
BUILD_DEPENDS= ${LOCALBASE}/lib/libgamepad.a:${PORTSDIR}/devel/libgamepad
MAKE_ENV= EXTRALIBS=-lbluetooth
+MAKE_FLAGS+= PREFIX=${STAGEDIR}${PREFIX} \
+ MANPREFIX=${STAGEDIR}${PREFIX}
MAKE_JOBS_UNSAFE= yes
+USES= tar:xz
+
OPTIONS_DEFINE= CUTECOM
CUTECOM_DESC= Install cutecom for Vex debugging
-MAN1= legoctl.1 vexctl.1 nxtremote.1
-MAN3= roboctl.3
-
-NO_STAGE= yes
-.include <bsd.port.options.mk>
-
-.if ${PORT_OPTIONS:MCUTECOM}
-RUN_DEPENDS+= cutecom:${PORTSDIR}/comms/cutecom
-.endif
+CUTECOM_RUN_DEPENDS= cutecom:${PORTSDIR}/comms/cutecom
pre-build:
(cd ${WRKSRC} && ${SETENV} ${MAKE_ENV} ${MAKE} depend)
post-install:
(cd ${WRKSRC}/Commands/NXTRemote; ${MAKE})
- ${INSTALL_PROGRAM} ${WRKSRC}/Commands/NXTRemote/nxtremote ${PREFIX}/bin
- ${INSTALL_SCRIPT} ${WRKSRC}/Scripts/lego_bluetooth_config ${PREFIX}/bin
- ${INSTALL_MAN} ${WRKSRC}/Commands/NXTRemote/nxtremote.1 ${MANPREFIX}/man/man1
+ ${INSTALL_PROGRAM} ${WRKSRC}/Commands/NXTRemote/nxtremote ${STAGEDIR}${PREFIX}/bin
+ ${INSTALL_SCRIPT} ${WRKSRC}/Scripts/lego_bluetooth_config ${STAGEDIR}${PREFIX}/bin
+ ${INSTALL_MAN} ${WRKSRC}/Commands/NXTRemote/nxtremote.1 ${STAGEDIR}${MANPREFIX}/man/man1
.include <bsd.port.mk>
diff --git a/devel/roboctl/distinfo b/devel/roboctl/distinfo
index 339707b3f67d..d88058a43a7c 100644
--- a/devel/roboctl/distinfo
+++ b/devel/roboctl/distinfo
@@ -1,2 +1,2 @@
-SHA256 (roboctl-0.3.7.tar.gz) = 7d9630b9afae523e5916559618a41108b0d34b8e7a1cc3a329f52b80bc16ebf4
-SIZE (roboctl-0.3.7.tar.gz) = 411610
+SHA256 (roboctl-0.3.8.tar.xz) = ca2a1c700f289691eb7dd40d61ccd78cd176afc154a500eabed7919dac47c383
+SIZE (roboctl-0.3.8.tar.xz) = 270384
diff --git a/devel/roboctl/pkg-plist b/devel/roboctl/pkg-plist
index c3b30aad71a3..fd5ccb7bc590 100644
--- a/devel/roboctl/pkg-plist
+++ b/devel/roboctl/pkg-plist
@@ -10,4 +10,8 @@ include/roboctl/rct_protos.h
include/roboctl/rct_rcx.h
include/roboctl/roboctl.h
lib/libroboctl.a
+man/man1/legoctl.1.gz
+man/man1/nxtremote.1.gz
+man/man1/vexctl.1.gz
+man/man3/roboctl.3.gz
@dirrm include/roboctl