aboutsummaryrefslogtreecommitdiffstats
path: root/devel
diff options
context:
space:
mode:
authorDmitry Marakasov <amdmi3@FreeBSD.org>2009-08-19 06:33:19 +0800
committerDmitry Marakasov <amdmi3@FreeBSD.org>2009-08-19 06:33:19 +0800
commit6d79c3b37f5a1ae73319dda5733d6cd0a85ded38 (patch)
treeb6b1aab4c37ca89da94207c2b216e6a7bf7c0c24 /devel
parentfb826b92327c58539578035fd8043bff065f9ef8 (diff)
downloadfreebsd-ports-gnome-6d79c3b37f5a1ae73319dda5733d6cd0a85ded38.tar.gz
freebsd-ports-gnome-6d79c3b37f5a1ae73319dda5733d6cd0a85ded38.tar.zst
freebsd-ports-gnome-6d79c3b37f5a1ae73319dda5733d6cd0a85ded38.zip
- Update to 0.2.0
PR: 137861 Submitted by: CeDeROM <tomek.cedro@gmail.com> (maintainer)
Diffstat (limited to 'devel')
-rw-r--r--devel/openocd/Makefile174
-rw-r--r--devel/openocd/distinfo6
-rw-r--r--devel/openocd/files/patch-openocd.c16
-rw-r--r--devel/openocd/pkg-message2
-rw-r--r--devel/openocd/pkg-plist299
5 files changed, 294 insertions, 203 deletions
diff --git a/devel/openocd/Makefile b/devel/openocd/Makefile
index d789be674a1e..e98fb8ffc57c 100644
--- a/devel/openocd/Makefile
+++ b/devel/openocd/Makefile
@@ -1,12 +1,12 @@
# New ports collection makefile for: openocd
-# Date created: 31 May 2009
+# Date created: 16 August 2009
# Whom: Tomek CeDeROM Cedro (http://www.tomek.cedro.info)
#
# $FreeBSD$
#
PORTNAME= openocd
-PORTVERSION= 0.1.0
+PORTVERSION= 0.2.0
CATEGORIES= devel
MASTER_SITES= BERLIOS
@@ -14,47 +14,93 @@ MAINTAINER= tomek.cedro@gmail.com
COMMENT= Open On-Chip Debugger
WRKSRC= ${WRKDIR}/${PORTNAME}-${PORTVERSION}/
-MAN1= openocd.1
+MAN1= ${PORTNAME}.1
INFO= ${PORTNAME}
USE_GMAKE= yes
CFLAGS+= -I${LOCALBASE}/include -L${LOCALBASE}/lib
GNU_CONFIGURE= yes
-CONFIGURE_ARGS= --enable-release
-OPTIONS= DUMMY "Dummy driver support" on \
+CONFIGURE_ARGS+= --disable-werror
+OPTIONS= VERBOSE "Enable verbose JTAG I/O messages" off \
+ JTAG_IO "Enable verbose JTAG I/O messages" off \
+ USB_IO "Enable verbose USB I/O messages" off \
+ USB_COMMS "Enable verbose USB communication messages" off \
+ DUMMY "Dummy driver support" on \
FT2232 "FT2232 based USB devices (using libftdi)" on \
- RLINK "Raisonance RLink JTAG Programmer" on \
+ EP93XX "EP93xx based SBCs" on \
+ AT91RM9200 "AT91RM9200 based SBCs" on \
+ PRESTO "ASIX Presto Programmer (using libftdi)" on \
+ USBPROG "Usbprog JTAG Programmer" on \
JLINK "Segger J-Link JTAG Programmer" on \
VSLLINK "Versaloon-Link JTAG Programmer" on \
- USBPROG "usbprog JTAG Programmer" on \
- PRESTO "ASIX Presto Programmer (using libftdi)" on \
- AT91RM9200 "AT91RM9200 based SBCs" on \
- EP93XX "EP93xx based SBCs" on
+ RLINK "Raisonance RLink JTAG Programmer" on \
+ ARMJTAGEW "Olimex ARM-JTAG-EW Programmer" on \
+ MINIDRIVER "Dummy minidriver (will exclude others!)" off
#Below are the interfaces that need source rewitre to work with FreeBSD
# They are hidden because they break a build. Patches are welcome :-)
# Type: make WITH_{OPTION}=1 to try the broken build (ie: make WITH_PARPORT=1)
-# PARPORT "Enable building the pc parallel port driver" off\
+# PARPORT "PC parallel port driver" off\
# Parport: parport.c:68:20: error: sys/io.h: No such file or directory
# AMTJTAGACCEL "Amontec JTAG-Accelerator driver" off \
+# MALLOC "Include free space in logging messages" off \
+# Malloc: log.c:41:2: error: #error "malloc.h is required to use --enable-malloc-logging"
# Amtjtagaccel: amt_jtagaccel.c:45:20: error: sys/io.h: No such file or directory
-# ECOSBOARD "eCosBoard based JTAG debugger" off\
+# ECOSBOARD "eCos based JTAG debugger" off \
# Ecosboard: replacements.h:36:28: error: pkgconf/system.h: No such file or directory
-# OOCDTRACE "OpenOCD+trace ETM capture device" off\
-# Oocdtrace: ocd_trace.c:127: error: 'B2500000' undeclared (first use in this function)
-# GW16012 "Gateworks GW16012 JTAG Programmer" off\
-# Gw16012: gw16012.c:67:20: error: sys/io.h: No such file or directory
# HTTPD "Enable builtin httpd server" off\
+# Zy1000: Requires working microhttpd
+# ZY1000 "ZY1000 minidriver (will exclude others!)" off \
# microhttpd does not link properly, used by some Zyli cable
+# GW16012 "Gateworks GW16012 JTAG Programmer" off \
+# Gw16012: gw16012.c:67:20: error: sys/io.h: No such file or directory
# IOUTIL "Enable ioutil functions" off
+# OOCDTRACE "OpenOCD+trace ETM capture device" off\
+# Oocdtrace: ocd_trace.c:127: error: 'B2500000' undeclared (first use in this function)
.include <bsd.port.options.mk>
+.if defined(WITH_VERBOSE)
+CONFIGURE_ARGS+= --enable-verbose
+.else
+CONFIGURE_ARGS+= --disable-verbose
+.endif
+
+.if defined(WITH_JTAG_IO)
+CONFIGURE_ARGS+= --enable-verbose-jtag-io
+.else
+CONFIGURE_ARGS+= --disable-verbose-jtag-io
+.endif
+
+.if defined(WITH_USB_IO)
+CONFIGURE_ARGS+= --enable-verbose-usb-io
+.else
+CONFIGURE_ARGS+= --disable-verbose-usb-io
+.endif
+
+.if defined(WITH_USB_COMMS)
+CONFIGURE_ARGS+= --enable-verbose-usb-comms
+.else
+CONFIGURE_ARGS+= --disable-verbose-usb-comms
+.endif
+
+.if defined(WITH_MALLOC)
+CONFIGURE_ARGS+= --enable-malloc-logging
+.else
+CONFIGURE_ARGS+= --disable-malloc-logging
+.endif
+
.if defined(WITH_DUMMY)
CONFIGURE_ARGS+= --enable-dummy
.else
CONFIGURE_ARGS+= --disable-dummy
.endif
+.if defined(WITH_PARPORT)
+CONFIGURE_ARGS+= --enable-parport
+.else
+CONFIGURE_ARGS+= --disable-parport
+.endif
+
.if defined(WITH_FT2232)
CONFIGURE_ARGS+= --enable-ft2232_libftdi
USE_LIBFTDI= yes
@@ -62,59 +108,54 @@ USE_LIBFTDI= yes
CONFIGURE_ARGS+= --disable-ft2232_libftdi
.endif
-.if defined(WITH_PARPORT)
-CONFIGURE_ARGS+= --enable-parport
-.else
-CONFIGURE_ARGS+= --disable-parport
-.endif
-
.if defined(WITH_AMTJTAGACCEL)
CONFIGURE_ARGS+= --enable-amtjtagaccel
-USE_LIBUSB= yes
.else
CONFIGURE_ARGS+= --disable-amtjtagaccel
.endif
.if defined(WITH_ECOSBOARD)
CONFIGURE_ARGS+= --enable-ecosboard
-USE_LIBUSB= yes
.else
CONFIGURE_ARGS+= --disable-ecosboard
.endif
-.if defined(WITH_RLINK)
-CONFIGURE_ARGS+= --enable-rlink
-USE_LIBUSB= yes
+.if defined(WITH_ZY1000)
+CONFIGURE_ARGS+= --enable-zy1000
.else
-CONFIGURE_ARGS+= --disable-rlink
+CONFIGURE_ARGS+= --disable-zy1000
.endif
-.if defined(WITH_JLINK)
-CONFIGURE_ARGS+= --enable-jlink
-USE_LIBUSB= yes
+.if defined(WITH_IOUTIL)
+CONFIGURE_ARGS+= --enable-ioutil
.else
-CONFIGURE_ARGS+= --disable-jlink
+CONFIGURE_ARGS+= --disable-ioutil
.endif
-.if defined(WITH_VSLLINK)
-CONFIGURE_ARGS+= --enable-vsllink
-USE_LIBUSB= yes
+.if defined(WITH_HTTPD)
+CONFIGURE_ARGS+= --enable-httpd
+BUILD_DEPENDS+= libmicrohttpd:${PORTSDIR}/www/libmicrohttpd
+LIB_DEPENDS+= microhttpd:${PORTSDIR}/www/libmicrohttpd
.else
-CONFIGURE_ARGS+= --disable-vsllink
+CONFIGURE_ARGS+= --disable-httpd
.endif
-.if defined(WITH_OOCDTRACE)
-CONFIGURE_ARGS+= --enable-oocd_trace
-USE_LIBUSB= yes
+.if defined(WITH_EP93XX)
+CONFIGURE_ARGS+= --enable-ep93xx
.else
-CONFIGURE_ARGS+= --disable-oocd_trace
+CONFIGURE_ARGS+= --disable-ep93xx
.endif
-.if defined(WITH_USBPROG)
-CONFIGURE_ARGS+= --enable-usbprog
-USE_LIBUSB= yes
+.if defined(WITH_AT91RM9200)
+CONFIGURE_ARGS+= --enable-at91rm9200
.else
-CONFIGURE_ARGS+= --disable-usbprog
+CONFIGURE_ARGS+= --disable-at91rm9200
+.endif
+
+.if defined(WITH_GW16012)
+CONFIGURE_ARGS+= --enable-gw16012
+.else
+CONFIGURE_ARGS+= --disable-gw16012
.endif
.if defined(WITH_PRESTO)
@@ -124,38 +165,51 @@ USE_LIBFTDI= yes
CONFIGURE_ARGS+= --disable-presto_libftdi
.endif
-.if defined(WITH_GW16012)
-CONFIGURE_ARGS+= --enable-gw16012
+.if defined(WITH_USBPROG)
+CONFIGURE_ARGS+= --enable-usbprog
USE_LIBUSB= yes
.else
-CONFIGURE_ARGS+= --disable-gw16012
+CONFIGURE_ARGS+= --disable-usbprog
.endif
-.if defined(WITH_AT91RM9200)
-CONFIGURE_ARGS+= --enable-at91rm9200
+.if defined(WITH_OOCDTRACE)
+CONFIGURE_ARGS+= --enable-oocd_trace
+.else
+CONFIGURE_ARGS+= --disable-oocd_trace
+.endif
+
+.if defined(WITH_JLINK)
+CONFIGURE_ARGS+= --enable-jlink
USE_LIBUSB= yes
.else
-CONFIGURE_ARGS+= --disable-at91rm9200
+CONFIGURE_ARGS+= --disable-jlink
.endif
-.if defined(WITH_EP93XX)
-CONFIGURE_ARGS+= --enable-ep93xx
+.if defined(WITH_VSLLINK)
+CONFIGURE_ARGS+= --enable-vsllink
USE_LIBUSB= yes
.else
-CONFIGURE_ARGS+= --disable-ep93xx
+CONFIGURE_ARGS+= --disable-vsllink
.endif
-.if defined(WITH_HTTPD)
-CONFIGURE_ARGS+= --enable-httpd
-LIB_DEPENDS+= microhttpd:${PORTSDIR}/www/libmicrohttpd
+.if defined(WITH_RLINK)
+CONFIGURE_ARGS+= --enable-rlink
+USE_LIBUSB= yes
.else
-CONFIGURE_ARGS+= --disable-httpd
+CONFIGURE_ARGS+= --disable-rlink
.endif
-.if defined(WITH_IOUTIL)
-CONFIGURE_ARGS+= --enable-ioutil
+.if defined(WITH_ARMJTAGEW)
+CONFIGURE_ARGS+= --enable-arm-jtag-ew
+USE_LIBUSB= yes
.else
-CONFIGURE_ARGS+= --disable-ioutil
+CONFIGURE_ARGS+= --disable-arm-jtag-ew
+.endif
+
+.if defined(WITH_MINIDRIVER)
+CONFIGURE_ARGS+= --enable-minidriver-dummy
+.else
+CONFIGURE_ARGS+= --disable-minidriver-dummy
.endif
.include <bsd.port.pre.mk>
diff --git a/devel/openocd/distinfo b/devel/openocd/distinfo
index f238fd72fe9c..680ade57e081 100644
--- a/devel/openocd/distinfo
+++ b/devel/openocd/distinfo
@@ -1,3 +1,3 @@
-MD5 (openocd-0.1.0.tar.gz) = 994b603d280ab85b5f255342c1d6b66c
-SHA256 (openocd-0.1.0.tar.gz) = e468c907355727f7aede5623afd77721eb75abe7686af7f2f388f41a7c0f2911
-SIZE (openocd-0.1.0.tar.gz) = 985328
+MD5 (openocd-0.2.0.tar.gz) = acc558613acaaf5633730072bc64e029
+SHA256 (openocd-0.2.0.tar.gz) = 48e311cd6441f5c6e1a788ee863080e22b9d1c3ba5df4af99b577028f147837d
+SIZE (openocd-0.2.0.tar.gz) = 1557187
diff --git a/devel/openocd/files/patch-openocd.c b/devel/openocd/files/patch-openocd.c
deleted file mode 100644
index 80ed9ee9a91b..000000000000
--- a/devel/openocd/files/patch-openocd.c
+++ /dev/null
@@ -1,16 +0,0 @@
---- src/openocd.c 2009-01-20 05:04:36.000000000 +0100
-+++ src/openocd.c 2009-05-19 23:12:06.000000000 +0200
-@@ -56,12 +56,6 @@
- #include <unistd.h>
- #include <errno.h>
-
--#ifdef _WIN32
--#include <malloc.h>
--#else
--#include <alloca.h>
--#endif
--
- #include "replacements.h"
-
- void print_version(void)
-
diff --git a/devel/openocd/pkg-message b/devel/openocd/pkg-message
index 3275bed796d8..9c00a0d77b08 100644
--- a/devel/openocd/pkg-message
+++ b/devel/openocd/pkg-message
@@ -2,7 +2,7 @@
Now You can use OpenOCD. Handbook is at: http://openocd.berlios.de/doc/html/
-To allow an ordinary user acces to the hotplug USB interface add him
+To allow an ordinary user to acces the hotplug USB interface add him
to the operator group and add these lines to the following files:
/etc/devfs.rules:
diff --git a/devel/openocd/pkg-plist b/devel/openocd/pkg-plist
index 18a17a8d0132..a2f2fb7dc7d2 100644
--- a/devel/openocd/pkg-plist
+++ b/devel/openocd/pkg-plist
@@ -1,129 +1,182 @@
bin/openocd
-lib/openocd/board/arm_evaluator7t.cfg
-lib/openocd/board/at91rm9200-dk.cfg
-lib/openocd/board/eir.cfg
-lib/openocd/board/hammer.cfg
-lib/openocd/board/iar_str912_sk.cfg
-lib/openocd/board/imx27ads.cfg
-lib/openocd/board/imx31pdk.cfg
-lib/openocd/board/logicpd_imx27.cfg
-lib/openocd/board/olimex_sam7_ex256.cfg
-lib/openocd/board/pic-p32mx.cfg
-lib/openocd/board/stm3210e_eval.cfg
-lib/openocd/board/stm32f10x_128k_eval.cfg
-lib/openocd/board/x300t.cfg
+@exec install-info %D/info/openocd.info %D/info/dir
+@unexec install-info --delete %D/info/openocd.info %D/info/dir
+lib/libopenocd.a
+lib/libopenocd.la
lib/openocd/ecos/at91eb40a.elf
-lib/openocd/interface/arm-usb-ocd.cfg
-lib/openocd/interface/at91rm9200.cfg
-lib/openocd/interface/calao-usb-a9260-c01.cfg
-lib/openocd/interface/calao-usb-a9260-c02.cfg
-lib/openocd/interface/calao-usb-a9260.cfg
-lib/openocd/interface/chameleon.cfg
-lib/openocd/interface/dummy.cfg
-lib/openocd/interface/flyswatter.cfg
-lib/openocd/interface/jlink.cfg
-lib/openocd/interface/jtagkey-tiny.cfg
-lib/openocd/interface/jtagkey.cfg
-lib/openocd/interface/luminary-libftdi.cfg
-lib/openocd/interface/luminary-lm3s811.cfg
-lib/openocd/interface/luminary.cfg
-lib/openocd/interface/olimex-arm-usb-ocd.cfg
-lib/openocd/interface/olimex-jtag-tiny-a.cfg
-lib/openocd/interface/openocd-usb.cfg
-lib/openocd/interface/parport.cfg
-lib/openocd/interface/parport_dlc5.cfg
-lib/openocd/interface/rlink.cfg
-lib/openocd/interface/signalyzer.cfg
-lib/openocd/interface/stm32-stick.cfg
-lib/openocd/interface/str9-comstick.cfg
-lib/openocd/interface/turtelizer2.cfg
-lib/openocd/target/aduc702x.cfg
-lib/openocd/target/at91eb40a.cfg
-lib/openocd/target/at91r40008.cfg
-lib/openocd/target/at91rm9200.cfg
-lib/openocd/target/at91sam9260.cfg
-lib/openocd/target/at91sam9260minimal.cfg
-lib/openocd/target/epc9301.cfg
-lib/openocd/target/imote2.cfg
-lib/openocd/target/imx27.cfg
-lib/openocd/target/imx31.cfg
-lib/openocd/target/ipx42x.cfg
-lib/openocd/target/is5114.cfg
-lib/openocd/target/lm3s3748.cfg
-lib/openocd/target/lm3s6965.cfg
-lib/openocd/target/lm3s811.cfg
-lib/openocd/target/lpc2129.cfg
-lib/openocd/target/lpc2148.cfg
-lib/openocd/target/lpc2148_2mhz.cfg
-lib/openocd/target/lpc2148_rclk.cfg
-lib/openocd/target/lpc2294.cfg
-lib/openocd/target/netx500.cfg
-lib/openocd/target/nslu2.cfg
-lib/openocd/target/omap5912.cfg
-lib/openocd/target/pic32mx.cfg
-lib/openocd/target/pxa255.cfg
-lib/openocd/target/pxa255_sst.cfg
-lib/openocd/target/pxa270.cfg
-lib/openocd/target/sam7se512.cfg
-lib/openocd/target/sam7x256.cfg
-lib/openocd/target/samsung_s3c2410.cfg
-lib/openocd/target/samsung_s3c2440.cfg
-lib/openocd/target/samsung_s3c4510.cfg
-lib/openocd/target/samsung_s3c6410.cfg
-lib/openocd/target/sharp_lh79532.cfg
-lib/openocd/target/smdk6410.cfg
-lib/openocd/target/smp8634.cfg
-lib/openocd/target/stm32.cfg
-lib/openocd/target/stm32stick.cfg
-lib/openocd/target/str710.cfg
-lib/openocd/target/str730.cfg
-lib/openocd/target/str750.cfg
-lib/openocd/target/str910-eval.cfg
-lib/openocd/target/str912.cfg
-lib/openocd/target/str9comstick.cfg
-lib/openocd/target/test_reset_syntax_error.cfg
-lib/openocd/target/test_syntax_error.cfg
-lib/openocd/target/wi-9c.cfg
-lib/openocd/target/xba_revA3.cfg
-lib/openocd/target/zy1000.cfg
-lib/openocd/tcl/bitsbytes.tcl
-lib/openocd/tcl/chip/atmel/at91/aic.tcl
-lib/openocd/tcl/chip/atmel/at91/at91sam7x128.tcl
-lib/openocd/tcl/chip/atmel/at91/at91sam7x256.tcl
-lib/openocd/tcl/chip/atmel/at91/pmc.tcl
-lib/openocd/tcl/chip/atmel/at91/rtt.tcl
-lib/openocd/tcl/chip/atmel/at91/usarts.tcl
-lib/openocd/tcl/chip/st/stm32/stm32.tcl
-lib/openocd/tcl/chip/st/stm32/stm32_rcc.tcl
-lib/openocd/tcl/chip/st/stm32/stm32_regs.tcl
-lib/openocd/tcl/cpu/arm/arm7tdmi.tcl
-lib/openocd/tcl/cpu/arm/arm920.tcl
-lib/openocd/tcl/cpu/arm/arm946.tcl
-lib/openocd/tcl/cpu/arm/arm966.tcl
-lib/openocd/tcl/cpu/arm/cortex_m3.tcl
-lib/openocd/tcl/memory.tcl
-lib/openocd/tcl/mmr_helpers.tcl
-lib/openocd/tcl/readable.tcl
lib/openocd/xscale/debug_handler.bin
-share/openocd/contrib/libdcc/README
-share/openocd/contrib/libdcc/dcc_stdio.c
-share/openocd/contrib/libdcc/dcc_stdio.h
-share/openocd/contrib/libdcc/example.c
-share/openocd/contrib/openocd.udev
-@dirrm share/openocd/contrib/libdcc
-@dirrm share/openocd/contrib
-@dirrm share/openocd
+%%DATADIR%%/contrib/libdcc/README
+%%DATADIR%%/contrib/libdcc/dcc_stdio.c
+%%DATADIR%%/contrib/libdcc/dcc_stdio.h
+%%DATADIR%%/contrib/libdcc/example.c
+%%DATADIR%%/contrib/openocd.udev
+%%DATADIR%%/scripts/bitsbytes.tcl
+%%DATADIR%%/scripts/board/arm_evaluator7t.cfg
+%%DATADIR%%/scripts/board/at91rm9200-dk.cfg
+%%DATADIR%%/scripts/board/atmel_sam3u_ek.cfg
+%%DATADIR%%/scripts/board/crossbow_tech_imote2.cfg
+%%DATADIR%%/scripts/board/csb337.cfg
+%%DATADIR%%/scripts/board/digi_connectcore_wi-9c.cfg
+%%DATADIR%%/scripts/board/dm355evm.cfg
+%%DATADIR%%/scripts/board/eir.cfg
+%%DATADIR%%/scripts/board/ek-lm3s3748.cfg
+%%DATADIR%%/scripts/board/ek-lm3s9b9x.cfg
+%%DATADIR%%/scripts/board/hammer.cfg
+%%DATADIR%%/scripts/board/hitex_stm32-performancestick.cfg
+%%DATADIR%%/scripts/board/hitex_str9-comstick.cfg
+%%DATADIR%%/scripts/board/iar_str912_sk.cfg
+%%DATADIR%%/scripts/board/imx27ads.cfg
+%%DATADIR%%/scripts/board/imx27lnst.cfg
+%%DATADIR%%/scripts/board/imx31pdk.cfg
+%%DATADIR%%/scripts/board/keil_mcb2140.cfg
+%%DATADIR%%/scripts/board/linksys_nslu2.cfg
+%%DATADIR%%/scripts/board/logicpd_imx27.cfg
+%%DATADIR%%/scripts/board/olimex_LPC2378STK.cfg
+%%DATADIR%%/scripts/board/olimex_lpc_h2148.cfg
+%%DATADIR%%/scripts/board/olimex_sam7_ex256.cfg
+%%DATADIR%%/scripts/board/olimex_sam9_l9260.cfg
+%%DATADIR%%/scripts/board/olimex_stm32_h103.cfg
+%%DATADIR%%/scripts/board/omap2420_h4.cfg
+%%DATADIR%%/scripts/board/osk5912.cfg
+%%DATADIR%%/scripts/board/pic-p32mx.cfg
+%%DATADIR%%/scripts/board/pxa255_sst.cfg
+%%DATADIR%%/scripts/board/sheevaplug.cfg
+%%DATADIR%%/scripts/board/stm3210e_eval.cfg
+%%DATADIR%%/scripts/board/stm32f10x_128k_eval.cfg
+%%DATADIR%%/scripts/board/str910-eval.cfg
+%%DATADIR%%/scripts/board/ti_beagleboard.cfg
+%%DATADIR%%/scripts/board/unknown-board-atmel-at91sam9260.cfg
+%%DATADIR%%/scripts/board/x300t.cfg
+%%DATADIR%%/scripts/board/zy1000.cfg
+%%DATADIR%%/scripts/chip/atmel/at91/aic.tcl
+%%DATADIR%%/scripts/chip/atmel/at91/at91sam7x128.tcl
+%%DATADIR%%/scripts/chip/atmel/at91/at91sam7x256.tcl
+%%DATADIR%%/scripts/chip/atmel/at91/pmc.tcl
+%%DATADIR%%/scripts/chip/atmel/at91/rtt.tcl
+%%DATADIR%%/scripts/chip/atmel/at91/usarts.tcl
+%%DATADIR%%/scripts/chip/st/stm32/stm32.tcl
+%%DATADIR%%/scripts/chip/st/stm32/stm32_rcc.tcl
+%%DATADIR%%/scripts/chip/st/stm32/stm32_regs.tcl
+%%DATADIR%%/scripts/cpu/arm/arm7tdmi.tcl
+%%DATADIR%%/scripts/cpu/arm/arm920.tcl
+%%DATADIR%%/scripts/cpu/arm/arm946.tcl
+%%DATADIR%%/scripts/cpu/arm/arm966.tcl
+%%DATADIR%%/scripts/cpu/arm/cortex_m3.tcl
+%%DATADIR%%/scripts/interface/arm-jtag-ew.cfg
+%%DATADIR%%/scripts/interface/arm-usb-ocd.cfg
+%%DATADIR%%/scripts/interface/at91rm9200.cfg
+%%DATADIR%%/scripts/interface/axm0432.cfg
+%%DATADIR%%/scripts/interface/calao-usb-a9260-c01.cfg
+%%DATADIR%%/scripts/interface/calao-usb-a9260-c02.cfg
+%%DATADIR%%/scripts/interface/calao-usb-a9260.cfg
+%%DATADIR%%/scripts/interface/chameleon.cfg
+%%DATADIR%%/scripts/interface/cortino.cfg
+%%DATADIR%%/scripts/interface/dummy.cfg
+%%DATADIR%%/scripts/interface/flyswatter.cfg
+%%DATADIR%%/scripts/interface/hitex_str9-comstick.cfg
+%%DATADIR%%/scripts/interface/icebear.cfg
+%%DATADIR%%/scripts/interface/jlink.cfg
+%%DATADIR%%/scripts/interface/jtagkey-tiny.cfg
+%%DATADIR%%/scripts/interface/jtagkey.cfg
+%%DATADIR%%/scripts/interface/luminary-icdi.cfg
+%%DATADIR%%/scripts/interface/luminary-lm3s811.cfg
+%%DATADIR%%/scripts/interface/luminary.cfg
+%%DATADIR%%/scripts/interface/olimex-arm-usb-ocd.cfg
+%%DATADIR%%/scripts/interface/olimex-jtag-tiny.cfg
+%%DATADIR%%/scripts/interface/oocdlink.cfg
+%%DATADIR%%/scripts/interface/openocd-usb.cfg
+%%DATADIR%%/scripts/interface/parport.cfg
+%%DATADIR%%/scripts/interface/parport_dlc5.cfg
+%%DATADIR%%/scripts/interface/rlink.cfg
+%%DATADIR%%/scripts/interface/sheevaplug.cfg
+%%DATADIR%%/scripts/interface/signalyzer.cfg
+%%DATADIR%%/scripts/interface/stm32-stick.cfg
+%%DATADIR%%/scripts/interface/turtelizer2.cfg
+%%DATADIR%%/scripts/interface/usbprog.cfg
+%%DATADIR%%/scripts/interface/vsllink.cfg
+%%DATADIR%%/scripts/memory.tcl
+%%DATADIR%%/scripts/mmr_helpers.tcl
+%%DATADIR%%/scripts/readable.tcl
+%%DATADIR%%/scripts/target/aduc702x.cfg
+%%DATADIR%%/scripts/target/at91eb40a.cfg
+%%DATADIR%%/scripts/target/at91r40008.cfg
+%%DATADIR%%/scripts/target/at91rm9200.cfg
+%%DATADIR%%/scripts/target/at91sam3u1c.cfg
+%%DATADIR%%/scripts/target/at91sam3u1e.cfg
+%%DATADIR%%/scripts/target/at91sam3u2c.cfg
+%%DATADIR%%/scripts/target/at91sam3u2e.cfg
+%%DATADIR%%/scripts/target/at91sam3u4c.cfg
+%%DATADIR%%/scripts/target/at91sam3u4e.cfg
+%%DATADIR%%/scripts/target/at91sam3uXX.cfg
+%%DATADIR%%/scripts/target/at91sam9260.cfg
+%%DATADIR%%/scripts/target/at91sam9260_ext_RAM_ext_flash.cfg
+%%DATADIR%%/scripts/target/cs351x.cfg
+%%DATADIR%%/scripts/target/davinci.cfg
+%%DATADIR%%/scripts/target/epc9301.cfg
+%%DATADIR%%/scripts/target/feroceon.cfg
+%%DATADIR%%/scripts/target/icepick.cfg
+%%DATADIR%%/scripts/target/imx21.cfg
+%%DATADIR%%/scripts/target/imx27.cfg
+%%DATADIR%%/scripts/target/imx31.cfg
+%%DATADIR%%/scripts/target/imx35.cfg
+%%DATADIR%%/scripts/target/is5114.cfg
+%%DATADIR%%/scripts/target/ixp42x.cfg
+%%DATADIR%%/scripts/target/lm3s3748.cfg
+%%DATADIR%%/scripts/target/lm3s6965.cfg
+%%DATADIR%%/scripts/target/lm3s811.cfg
+%%DATADIR%%/scripts/target/lm3s9b9x.cfg
+%%DATADIR%%/scripts/target/lpc2103.cfg
+%%DATADIR%%/scripts/target/lpc2124.cfg
+%%DATADIR%%/scripts/target/lpc2129.cfg
+%%DATADIR%%/scripts/target/lpc2148.cfg
+%%DATADIR%%/scripts/target/lpc2294.cfg
+%%DATADIR%%/scripts/target/lpc2378.cfg
+%%DATADIR%%/scripts/target/lpc2478.cfg
+%%DATADIR%%/scripts/target/mega128.cfg
+%%DATADIR%%/scripts/target/netx500.cfg
+%%DATADIR%%/scripts/target/omap2420.cfg
+%%DATADIR%%/scripts/target/omap3530.cfg
+%%DATADIR%%/scripts/target/omap5912.cfg
+%%DATADIR%%/scripts/target/pic32mx.cfg
+%%DATADIR%%/scripts/target/pxa255.cfg
+%%DATADIR%%/scripts/target/pxa270.cfg
+%%DATADIR%%/scripts/target/sam7se512.cfg
+%%DATADIR%%/scripts/target/sam7x256.cfg
+%%DATADIR%%/scripts/target/samsung_s3c2410.cfg
+%%DATADIR%%/scripts/target/samsung_s3c2440.cfg
+%%DATADIR%%/scripts/target/samsung_s3c4510.cfg
+%%DATADIR%%/scripts/target/samsung_s3c6410.cfg
+%%DATADIR%%/scripts/target/sharp_lh79532.cfg
+%%DATADIR%%/scripts/target/smdk6410.cfg
+%%DATADIR%%/scripts/target/smp8634.cfg
+%%DATADIR%%/scripts/target/stm32.cfg
+%%DATADIR%%/scripts/target/str710.cfg
+%%DATADIR%%/scripts/target/str730.cfg
+%%DATADIR%%/scripts/target/str750.cfg
+%%DATADIR%%/scripts/target/str912.cfg
+%%DATADIR%%/scripts/target/test_reset_syntax_error.cfg
+%%DATADIR%%/scripts/target/test_syntax_error.cfg
+%%DATADIR%%/scripts/target/ti_dm355.cfg
+%%DATADIR%%/scripts/target/ti_dm365.cfg
+%%DATADIR%%/scripts/target/ti_dm6446.cfg
+%%DATADIR%%/scripts/target/xba_revA3.cfg
+%%DATADIR%%/scripts/test/selftest.cfg
+%%DATADIR%%/scripts/test/syntax1.cfg
+@dirrm %%DATADIR%%/scripts/test
+@dirrm %%DATADIR%%/scripts/target
+@dirrm %%DATADIR%%/scripts/interface
+@dirrm %%DATADIR%%/scripts/cpu/arm
+@dirrm %%DATADIR%%/scripts/cpu
+@dirrm %%DATADIR%%/scripts/chip/st/stm32
+@dirrm %%DATADIR%%/scripts/chip/st
+@dirrm %%DATADIR%%/scripts/chip/atmel/at91
+@dirrm %%DATADIR%%/scripts/chip/atmel
+@dirrm %%DATADIR%%/scripts/chip
+@dirrm %%DATADIR%%/scripts/board
+@dirrm %%DATADIR%%/scripts
+@dirrm %%DATADIR%%/contrib/libdcc
+@dirrm %%DATADIR%%/contrib
+@dirrm %%DATADIR%%
@dirrm lib/openocd/xscale
-@dirrm lib/openocd/tcl/cpu/arm
-@dirrm lib/openocd/tcl/cpu
-@dirrm lib/openocd/tcl/chip/st/stm32
-@dirrm lib/openocd/tcl/chip/st
-@dirrm lib/openocd/tcl/chip/atmel/at91
-@dirrm lib/openocd/tcl/chip/atmel
-@dirrm lib/openocd/tcl/chip
-@dirrm lib/openocd/tcl
-@dirrm lib/openocd/target
-@dirrm lib/openocd/interface
@dirrm lib/openocd/ecos
-@dirrm lib/openocd/board
@dirrm lib/openocd