aboutsummaryrefslogtreecommitdiffstats
path: root/devel
diff options
context:
space:
mode:
authorswills <swills@FreeBSD.org>2013-10-25 04:01:02 +0800
committerswills <swills@FreeBSD.org>2013-10-25 04:01:02 +0800
commit6dbae1599590b890890de03666e66943ef5c4e65 (patch)
tree2d3809df2413a41153095834ff67268be72e9c7e /devel
parentf78715519685028905b896b1c16534405c147aa4 (diff)
downloadfreebsd-ports-gnome-6dbae1599590b890890de03666e66943ef5c4e65.tar.gz
freebsd-ports-gnome-6dbae1599590b890890de03666e66943ef5c4e65.tar.zst
freebsd-ports-gnome-6dbae1599590b890890de03666e66943ef5c4e65.zip
Code coverage for Ruby 1.9 with a powerful configuration library and automatic
merging of coverage across test suites WWW: http://github.com/colszowka/simplecov PR: ports/182757 Submitted by: Loic Blot <loic.blot@unix-experience.fr>
Diffstat (limited to 'devel')
-rw-r--r--devel/Makefile1
-rw-r--r--devel/rubygem-simplecov/Makefile20
-rw-r--r--devel/rubygem-simplecov/distinfo2
-rw-r--r--devel/rubygem-simplecov/pkg-descr4
4 files changed, 27 insertions, 0 deletions
diff --git a/devel/Makefile b/devel/Makefile
index 74ee71f91dc9..6997c26985ec 100644
--- a/devel/Makefile
+++ b/devel/Makefile
@@ -4227,6 +4227,7 @@
SUBDIR += rubygem-shoulda-context
SUBDIR += rubygem-shoulda-matchers
SUBDIR += rubygem-simple_form
+ SUBDIR += rubygem-simplecov
SUBDIR += rubygem-slim
SUBDIR += rubygem-slop
SUBDIR += rubygem-soap4r
diff --git a/devel/rubygem-simplecov/Makefile b/devel/rubygem-simplecov/Makefile
new file mode 100644
index 000000000000..665322cb6946
--- /dev/null
+++ b/devel/rubygem-simplecov/Makefile
@@ -0,0 +1,20 @@
+# $FreeBSD$
+
+PORTNAME= simplecov
+PORTVERSION= 0.7.1
+CATEGORIES= devel rubygems
+MASTER_SITES= RG
+
+MAINTAINER= ruby@FreeBSD.org
+COMMENT= a powerful configuration library and automatic merging of coverage across test suites
+
+RUN_DEPENDS= rubygem-multi_json>=1.0:${PORTSDIR}/devel/rubygem-multi_json \
+ rubygem-simplecov-html>=0.7.1:${PORTSDIR}/textproc/rubygem-simplecov-html
+
+USE_RUBY= yes
+USE_RUBYGEMS= yes
+RUBYGEM_AUTOPLIST= yes
+
+NO_STAGE= yes
+
+.include <bsd.port.mk>
diff --git a/devel/rubygem-simplecov/distinfo b/devel/rubygem-simplecov/distinfo
new file mode 100644
index 000000000000..0c33f867fca0
--- /dev/null
+++ b/devel/rubygem-simplecov/distinfo
@@ -0,0 +1,2 @@
+SHA256 (rubygem/simplecov-0.7.1.gem) = f0b974cb466bfd9174e16a7f74bde1edc651548d6c221fd112fa07d9c56f1b25
+SIZE (rubygem/simplecov-0.7.1.gem) = 44032
diff --git a/devel/rubygem-simplecov/pkg-descr b/devel/rubygem-simplecov/pkg-descr
new file mode 100644
index 000000000000..725ba64157b2
--- /dev/null
+++ b/devel/rubygem-simplecov/pkg-descr
@@ -0,0 +1,4 @@
+Code coverage for Ruby 1.9 with a powerful configuration library and automatic
+merging of coverage across test suites
+
+WWW: http://github.com/colszowka/simplecov