aboutsummaryrefslogtreecommitdiffstats
path: root/devel
diff options
context:
space:
mode:
authorswills <swills@FreeBSD.org>2015-04-01 23:54:54 +0800
committerswills <swills@FreeBSD.org>2015-04-01 23:54:54 +0800
commit6e76e485128998975aeece13948102246de1b610 (patch)
tree68fd4581b4370c2ed1aa85e3e23b6561cf1f8b63 /devel
parentb765738355d38b579474dcc0a3865db1f8717cb8 (diff)
downloadfreebsd-ports-gnome-6e76e485128998975aeece13948102246de1b610.tar.gz
freebsd-ports-gnome-6e76e485128998975aeece13948102246de1b610.tar.zst
freebsd-ports-gnome-6e76e485128998975aeece13948102246de1b610.zip
devel/ruby-gems: fix with DOCS option disabled
PR: 198052
Diffstat (limited to 'devel')
-rw-r--r--devel/ruby-gems/Makefile12
-rw-r--r--devel/ruby-gems/pkg-plist2
2 files changed, 6 insertions, 8 deletions
diff --git a/devel/ruby-gems/Makefile b/devel/ruby-gems/Makefile
index a24e3d57562a..ecd2f3358820 100644
--- a/devel/ruby-gems/Makefile
+++ b/devel/ruby-gems/Makefile
@@ -49,16 +49,14 @@ OPTIONS_DEFINE= DOCS
.include <bsd.port.options.mk>
-.if ${PORT_OPTIONS:MDOCS}
-RUBY_SETUP_OPTIONS= --ri --rdoc --destdir=${STAGEDIR}
-GEM_ENV+= GEM_HOME=${STAGEDIR}${PREFIX}/${GEMS_VER_DIR}
-.else
-RUBY_SETUP_OPTIONS= --no-ri --no-rdoc --destdir=${STAGEDIR}
+RUBY_SETUP_OPTIONS= --destdir=${STAGEDIR}
+GEM_ENV= GEM_HOME=${STAGEDIR}${PREFIX}/${GEMS_VER_DIR}
+
+.if !${PORT_OPTIONS:MDOCS}
+RUBY_SETUP_OPTIONS+= --no-ri --no-rdoc
.endif
do-install:
- @${MKDIR} ${STAGEDIR}${PREFIX}/${GEMS_DOC_BASE_DIR}/
- @${TOUCH} ${STAGEDIR}${PREFIX}/${GEMS_DOC_BASE_DIR}/.keep_this
cd ${WRKSRC}; ${SETENV} ${GEM_ENV} ${RUBY} ${RUBY_SETUP} ${RUBY_SETUP_OPTIONS}
post-install:
diff --git a/devel/ruby-gems/pkg-plist b/devel/ruby-gems/pkg-plist
index 76d7c2115700..78d115727608 100644
--- a/devel/ruby-gems/pkg-plist
+++ b/devel/ruby-gems/pkg-plist
@@ -158,9 +158,9 @@ bin/gem%%RUBY_VER_SHORT%%
%%RUBY_SITELIBDIR%%/rubygems/version.rb
%%RUBY_SITELIBDIR%%/rubygems/version_option.rb
%%RUBY_SITELIBDIR%%/ubygems.rb
-lib/ruby/gems/%%RUBY_VER%%/doc/.keep_this
@dir lib/ruby/gems/%%RUBY_VER%%/build_info
@dir %%EXT_DIR%%
@dir %%CACHE_DIR%%
@dir %%GEMS_DIR%%
@dir %%SPEC_DIR%%
+@dir %%DOC_DIR%%