aboutsummaryrefslogtreecommitdiffstats
path: root/devel
diff options
context:
space:
mode:
authoralepulver <alepulver@FreeBSD.org>2006-08-10 04:14:32 +0800
committeralepulver <alepulver@FreeBSD.org>2006-08-10 04:14:32 +0800
commit734cc3c8c0dfd591660fddf7e2f7a653e4bb6f05 (patch)
tree2e367035edc29fd43f32d44090464b43a2afa494 /devel
parent6f5a08f6736016f0fabe128362b0c1227f5d87d4 (diff)
downloadfreebsd-ports-gnome-734cc3c8c0dfd591660fddf7e2f7a653e4bb6f05.tar.gz
freebsd-ports-gnome-734cc3c8c0dfd591660fddf7e2f7a653e4bb6f05.tar.zst
freebsd-ports-gnome-734cc3c8c0dfd591660fddf7e2f7a653e4bb6f05.zip
- Use 2 as the shared library major version.
- Install shared library as libXCurses.so.2, then symlink to libXCurses.so (not the other way around).
Diffstat (limited to 'devel')
-rw-r--r--devel/pdcurses-the/Makefile7
-rw-r--r--devel/pdcurses-the/pkg-plist2
-rw-r--r--devel/pdcurses/Makefile7
-rw-r--r--devel/pdcurses/pkg-plist2
4 files changed, 14 insertions, 4 deletions
diff --git a/devel/pdcurses-the/Makefile b/devel/pdcurses-the/Makefile
index 65b3e31099d4..fa03673b1095 100644
--- a/devel/pdcurses-the/Makefile
+++ b/devel/pdcurses-the/Makefile
@@ -42,7 +42,12 @@ LIB_DEPENDS+= Xaw3d.${XAWVER}:${PORTSDIR}/x11-toolkits/Xaw3d
CONFIGURE_ARGS+=--with-xaw3d
.endif
+post-patch:
+ @${REINPLACE_CMD} -e \
+ 's|$$(libdir)/$$(SHLPRE)$$(SHLFILE)$$(SHLPST)|&.2|' \
+ ${WRKSRC}/Makefile.in
+
post-install:
- @cd ${PREFIX}/lib && ${LN} -sf libXCurses.so libXCurses.so.8
+ @cd ${PREFIX}/lib && ${LN} -sf libXCurses.so.2 libXCurses.so
.include <bsd.port.post.mk>
diff --git a/devel/pdcurses-the/pkg-plist b/devel/pdcurses-the/pkg-plist
index 503f6d1fb00f..73056bde63d3 100644
--- a/devel/pdcurses-the/pkg-plist
+++ b/devel/pdcurses-the/pkg-plist
@@ -7,6 +7,6 @@ include/xcurses/term.h
include/xpanel.h
lib/libXCurses.a
lib/libXCurses.so
-lib/libXCurses.so.8
+lib/libXCurses.so.2
lib/libXpanel.a
@dirrm include/xcurses
diff --git a/devel/pdcurses/Makefile b/devel/pdcurses/Makefile
index 65b3e31099d4..fa03673b1095 100644
--- a/devel/pdcurses/Makefile
+++ b/devel/pdcurses/Makefile
@@ -42,7 +42,12 @@ LIB_DEPENDS+= Xaw3d.${XAWVER}:${PORTSDIR}/x11-toolkits/Xaw3d
CONFIGURE_ARGS+=--with-xaw3d
.endif
+post-patch:
+ @${REINPLACE_CMD} -e \
+ 's|$$(libdir)/$$(SHLPRE)$$(SHLFILE)$$(SHLPST)|&.2|' \
+ ${WRKSRC}/Makefile.in
+
post-install:
- @cd ${PREFIX}/lib && ${LN} -sf libXCurses.so libXCurses.so.8
+ @cd ${PREFIX}/lib && ${LN} -sf libXCurses.so.2 libXCurses.so
.include <bsd.port.post.mk>
diff --git a/devel/pdcurses/pkg-plist b/devel/pdcurses/pkg-plist
index 503f6d1fb00f..73056bde63d3 100644
--- a/devel/pdcurses/pkg-plist
+++ b/devel/pdcurses/pkg-plist
@@ -7,6 +7,6 @@ include/xcurses/term.h
include/xpanel.h
lib/libXCurses.a
lib/libXCurses.so
-lib/libXCurses.so.8
+lib/libXCurses.so.2
lib/libXpanel.a
@dirrm include/xcurses