aboutsummaryrefslogtreecommitdiffstats
path: root/devel
diff options
context:
space:
mode:
authorknu <knu@FreeBSD.org>2004-05-16 06:49:34 +0800
committerknu <knu@FreeBSD.org>2004-05-16 06:49:34 +0800
commit73bb14006cad6701900fbfcd5b8ab3fc22a7e93a (patch)
tree7ca3b5ff11e90141ff001e04ae1f8f705ffbbee8 /devel
parent8f6c08b6b97f8b8ae65f1d14584860ab30a91b8a (diff)
downloadfreebsd-ports-gnome-73bb14006cad6701900fbfcd5b8ab3fc22a7e93a.tar.gz
freebsd-ports-gnome-73bb14006cad6701900fbfcd5b8ab3fc22a7e93a.tar.zst
freebsd-ports-gnome-73bb14006cad6701900fbfcd5b8ab3fc22a7e93a.zip
Add p5-POE-Component-TSTP, a POE component to correctly handle Ctrl-Z
in your program.
Diffstat (limited to 'devel')
-rw-r--r--devel/Makefile1
-rw-r--r--devel/p5-POE-Component-TSTP/Makefile25
-rw-r--r--devel/p5-POE-Component-TSTP/distinfo2
-rw-r--r--devel/p5-POE-Component-TSTP/pkg-descr6
-rw-r--r--devel/p5-POE-Component-TSTP/pkg-plist3
5 files changed, 37 insertions, 0 deletions
diff --git a/devel/Makefile b/devel/Makefile
index 8d027871c102..6d186b048a11 100644
--- a/devel/Makefile
+++ b/devel/Makefile
@@ -845,6 +845,7 @@
SUBDIR += p5-POE-Component-Logger
SUBDIR += p5-POE-Component-Pcap
SUBDIR += p5-POE-Component-RSS
+ SUBDIR += p5-POE-Component-TSTP
SUBDIR += p5-POE-Exceptions
SUBDIR += p5-POE-Session-MultiDispatch
SUBDIR += p5-PPerl
diff --git a/devel/p5-POE-Component-TSTP/Makefile b/devel/p5-POE-Component-TSTP/Makefile
new file mode 100644
index 000000000000..45a5465ffba3
--- /dev/null
+++ b/devel/p5-POE-Component-TSTP/Makefile
@@ -0,0 +1,25 @@
+# New ports collection makefile for: POE-Component-TSTP
+# Date created: 16 May 2004
+# Whom: Akinori MUSHA aka knu <knu@idaemons.org>
+#
+# $FreeBSD$
+#
+
+PORTNAME= POE-Component-TSTP
+PORTVERSION= 0.02
+CATEGORIES= devel perl5
+MASTER_SITES= ${MASTER_SITE_PERL_CPAN}
+MASTER_SITE_SUBDIR= POE
+PKGNAMEPREFIX= p5-
+
+MAINTAINER= knu@FreeBSD.org
+COMMENT= POE component to correctly handle Ctrl-Z in your program
+
+BUILD_DEPENDS= ${SITE_PERL}/POE.pm:${PORTSDIR}/devel/p5-POE
+RUN_DEPENDS= ${BUILD_DEPENDS}
+
+PERL_CONFIGURE= yes
+
+MAN3= POE::Component::TSTP.3
+
+.include <bsd.port.mk>
diff --git a/devel/p5-POE-Component-TSTP/distinfo b/devel/p5-POE-Component-TSTP/distinfo
new file mode 100644
index 000000000000..06c2c77903c3
--- /dev/null
+++ b/devel/p5-POE-Component-TSTP/distinfo
@@ -0,0 +1,2 @@
+MD5 (POE-Component-TSTP-0.02.tar.gz) = 0ac0dafa63a99b3e305e073e30bb9f22
+SIZE (POE-Component-TSTP-0.02.tar.gz) = 1685
diff --git a/devel/p5-POE-Component-TSTP/pkg-descr b/devel/p5-POE-Component-TSTP/pkg-descr
new file mode 100644
index 000000000000..a612b8e0d7d4
--- /dev/null
+++ b/devel/p5-POE-Component-TSTP/pkg-descr
@@ -0,0 +1,6 @@
+POE::Component::TSTP
+--------------------
+
+A POE component to correctly handle Ctrl-Z in your program.
+
+WWW: http://search.cpan.org/dist/POE-Component-TSTP/
diff --git a/devel/p5-POE-Component-TSTP/pkg-plist b/devel/p5-POE-Component-TSTP/pkg-plist
new file mode 100644
index 000000000000..315ed8434f95
--- /dev/null
+++ b/devel/p5-POE-Component-TSTP/pkg-plist
@@ -0,0 +1,3 @@
+%%SITE_PERL%%/POE/Component/TSTP.pm
+@unexec rmdir %D/%%SITE_PERL%%/POE/Component 2>/dev/null || true
+@unexec rmdir %D/%%SITE_PERL%%/POE 2>/dev/null || true