aboutsummaryrefslogtreecommitdiffstats
path: root/devel
diff options
context:
space:
mode:
authorNicola Vitale <nivit@FreeBSD.org>2007-04-14 00:42:45 +0800
committerNicola Vitale <nivit@FreeBSD.org>2007-04-14 00:42:45 +0800
commit73fd17b8b1f5eab10cb0a69d99149e54a3920e35 (patch)
tree6a800d354729c8d0ae861d904e29c4e1b4a7081b /devel
parent6bde556226ae4fd2938e9d6cefc62ddcde149979 (diff)
downloadfreebsd-ports-gnome-73fd17b8b1f5eab10cb0a69d99149e54a3920e35.tar.gz
freebsd-ports-gnome-73fd17b8b1f5eab10cb0a69d99149e54a3920e35.tar.zst
freebsd-ports-gnome-73fd17b8b1f5eab10cb0a69d99149e54a3920e35.zip
Cog transforms files in a very simple way: it finds chunks of Python code
embedded in them, executes the Python code, and inserts its output back into the original file. The file can contain whatever text you like around the Python code. It will usually be source code. Author: Ned Batchelder WWW: http://www.nedbatchelder.com/code/cog/index.html PR: ports/111046 Submitted by: Alex Pesternikov <apesternikov at page2rss.com>
Diffstat (limited to 'devel')
-rw-r--r--devel/Makefile1
-rw-r--r--devel/py-cog/Makefile20
-rw-r--r--devel/py-cog/distinfo3
-rw-r--r--devel/py-cog/pkg-descr7
-rw-r--r--devel/py-cog/pkg-plist34
5 files changed, 65 insertions, 0 deletions
diff --git a/devel/Makefile b/devel/Makefile
index eab8016b238b..032baee63520 100644
--- a/devel/Makefile
+++ b/devel/Makefile
@@ -1786,6 +1786,7 @@
SUBDIR += py-ciphon
SUBDIR += py-cjson
SUBDIR += py-clientcookie
+ SUBDIR += py-cog
SUBDIR += py-configobj
SUBDIR += py-coro
SUBDIR += py-ctypes
diff --git a/devel/py-cog/Makefile b/devel/py-cog/Makefile
new file mode 100644
index 000000000000..c7414d5db111
--- /dev/null
+++ b/devel/py-cog/Makefile
@@ -0,0 +1,20 @@
+# New ports collection makefile for: cog
+# Date created: 30 March 2007
+# Whom: Alex Pesternikov <apesternikov@page2rss.com>
+#
+# $FreeBSD$
+#
+
+PORTNAME= cog
+PORTVERSION= 2.0
+CATEGORIES= devel python
+MASTER_SITES= http://www.nedbatchelder.com/code/cog/
+PKGNAMEPREFIX= ${PYTHON_PKGNAMEPREFIX}
+
+MAINTAINER= apesternikov@page2rss.com
+COMMENT= Code Generator for any language
+
+USE_PYTHON= yes
+USE_PYDISTUTILS= yes
+
+.include <bsd.port.mk>
diff --git a/devel/py-cog/distinfo b/devel/py-cog/distinfo
new file mode 100644
index 000000000000..2dba85176340
--- /dev/null
+++ b/devel/py-cog/distinfo
@@ -0,0 +1,3 @@
+MD5 (cog-2.0.tar.gz) = 3eb0d8d32f11f8094ce159af428ce80c
+SHA256 (cog-2.0.tar.gz) = fb92e1085b7bb9508b577e94767b7a726e07b957aa86df6bbdc70a8afd642a3c
+SIZE (cog-2.0.tar.gz) = 22168
diff --git a/devel/py-cog/pkg-descr b/devel/py-cog/pkg-descr
new file mode 100644
index 000000000000..9e03a46856d9
--- /dev/null
+++ b/devel/py-cog/pkg-descr
@@ -0,0 +1,7 @@
+Cog transforms files in a very simple way: it finds chunks of Python code
+embedded in them, executes the Python code, and inserts its output back into
+the original file. The file can contain whatever text you like around the
+Python code. It will usually be source code.
+
+Author: Ned Batchelder
+WWW: http://www.nedbatchelder.com/code/cog/index.html
diff --git a/devel/py-cog/pkg-plist b/devel/py-cog/pkg-plist
new file mode 100644
index 000000000000..70d90071e5a5
--- /dev/null
+++ b/devel/py-cog/pkg-plist
@@ -0,0 +1,34 @@
+bin/cog.py
+bin/test_cog.py
+%%PYTHON_SITELIBDIR%%/cogapp/cogapp.py
+%%PYTHON_SITELIBDIR%%/cogapp/makefiles.py
+%%PYTHON_SITELIBDIR%%/cogapp/test_cogapp.py
+%%PYTHON_SITELIBDIR%%/cogapp/test_makefiles.py
+%%PYTHON_SITELIBDIR%%/cogapp/test_whiteutils.py
+%%PYTHON_SITELIBDIR%%/cogapp/whiteutils.py
+%%PYTHON_SITELIBDIR%%/cogapp/__init__.py
+%%PYTHON_SITELIBDIR%%/cogapp/cogapp.pyc
+%%PYTHON_SITELIBDIR%%/cogapp/makefiles.pyc
+%%PYTHON_SITELIBDIR%%/cogapp/test_cogapp.pyc
+%%PYTHON_SITELIBDIR%%/cogapp/test_makefiles.pyc
+%%PYTHON_SITELIBDIR%%/cogapp/test_whiteutils.pyc
+%%PYTHON_SITELIBDIR%%/cogapp/whiteutils.pyc
+%%PYTHON_SITELIBDIR%%/cogapp/__init__.pyc
+%%PYTHON_SITELIBDIR%%/cogapp/cogapp.pyo
+%%PYTHON_SITELIBDIR%%/cogapp/makefiles.pyo
+%%PYTHON_SITELIBDIR%%/cogapp/test_cogapp.pyo
+%%PYTHON_SITELIBDIR%%/cogapp/test_makefiles.pyo
+%%PYTHON_SITELIBDIR%%/cogapp/test_whiteutils.pyo
+%%PYTHON_SITELIBDIR%%/cogapp/whiteutils.pyo
+%%PYTHON_SITELIBDIR%%/cogapp/__init__.pyo
+%%PYTHON_SITELIBDIR%%/handyxml/handyxml.py
+%%PYTHON_SITELIBDIR%%/handyxml/test_handyxml.py
+%%PYTHON_SITELIBDIR%%/handyxml/__init__.py
+%%PYTHON_SITELIBDIR%%/handyxml/handyxml.pyc
+%%PYTHON_SITELIBDIR%%/handyxml/test_handyxml.pyc
+%%PYTHON_SITELIBDIR%%/handyxml/__init__.pyc
+%%PYTHON_SITELIBDIR%%/handyxml/handyxml.pyo
+%%PYTHON_SITELIBDIR%%/handyxml/test_handyxml.pyo
+%%PYTHON_SITELIBDIR%%/handyxml/__init__.pyo
+@dirrm %%PYTHON_SITELIBDIR%%/cogapp
+@dirrm %%PYTHON_SITELIBDIR%%/handyxml