aboutsummaryrefslogtreecommitdiffstats
path: root/devel
diff options
context:
space:
mode:
authorwen <wen@FreeBSD.org>2010-01-30 10:36:25 +0800
committerwen <wen@FreeBSD.org>2010-01-30 10:36:25 +0800
commit744cefb2a22849b9d6ffff39ea4e07f9e38ba99b (patch)
treee863d18a6ade5ff3751ad970cd221d5239bd48f5 /devel
parent862f15f11d397d7425f8b2014364df461461fefa (diff)
downloadfreebsd-ports-gnome-744cefb2a22849b9d6ffff39ea4e07f9e38ba99b.tar.gz
freebsd-ports-gnome-744cefb2a22849b9d6ffff39ea4e07f9e38ba99b.tar.zst
freebsd-ports-gnome-744cefb2a22849b9d6ffff39ea4e07f9e38ba99b.zip
InlineX::CPP2XS is a perl module to create an XS file from an
Inline C++ file. WWW: http://search.cpan.org/dist/InlineX-CPP2XS/
Diffstat (limited to 'devel')
-rw-r--r--devel/Makefile1
-rw-r--r--devel/p5-InlineX-CPP2XS/Makefile26
-rw-r--r--devel/p5-InlineX-CPP2XS/distinfo3
-rw-r--r--devel/p5-InlineX-CPP2XS/pkg-descr4
-rw-r--r--devel/p5-InlineX-CPP2XS/pkg-plist6
5 files changed, 40 insertions, 0 deletions
diff --git a/devel/Makefile b/devel/Makefile
index 04cc77643ce2..78cbbc36cdfe 100644
--- a/devel/Makefile
+++ b/devel/Makefile
@@ -1646,6 +1646,7 @@
SUBDIR += p5-Inline-TT
SUBDIR += p5-Inline-Tcl
SUBDIR += p5-InlineX-C2XS
+ SUBDIR += p5-InlineX-CPP2XS
SUBDIR += p5-Ioctl
SUBDIR += p5-Iterator
SUBDIR += p5-Iterator-IO
diff --git a/devel/p5-InlineX-CPP2XS/Makefile b/devel/p5-InlineX-CPP2XS/Makefile
new file mode 100644
index 000000000000..33ed76e393b3
--- /dev/null
+++ b/devel/p5-InlineX-CPP2XS/Makefile
@@ -0,0 +1,26 @@
+# New ports collection makefile for: InlineX::CPP2XS
+# Date created: 30 Jan, 2010
+# Whom: Wen Heping <wen@FreeBSD.org>
+#
+# $FreeBSD$
+#
+
+PORTNAME= InlineX-CPP2XS
+PORTVERSION= 0.15
+CATEGORIES= devel perl5
+MASTER_SITES= CPAN
+MASTER_SITE_SUBDIR= ../../authors/id/S/SI/SISYPHUS/
+PKGNAMEPREFIX= p5-
+
+MAINTAINER= wen@FreeBSD.org
+COMMENT= Convert from Inline C++ code to XS
+
+BUILD_DEPENDS= ${SITE_PERL}/Inline/C.pm:${PORTSDIR}/devel/p5-Inline \
+ p5-Inline-CPP>=0.25:${PORTSDIR}/devel/p5-Inline-CPP
+RUN_DEPENDS= ${BUILD_DEPENDS}
+
+PERL_CONFIGURE= yes
+
+MAN3= InlineX::CPP2XS.3 InlineX::CPP2XS-Cookbook.3
+
+.include <bsd.port.mk>
diff --git a/devel/p5-InlineX-CPP2XS/distinfo b/devel/p5-InlineX-CPP2XS/distinfo
new file mode 100644
index 000000000000..e002c9edb709
--- /dev/null
+++ b/devel/p5-InlineX-CPP2XS/distinfo
@@ -0,0 +1,3 @@
+MD5 (InlineX-CPP2XS-0.15.tar.gz) = e61c834933902c70339e913fe7825131
+SHA256 (InlineX-CPP2XS-0.15.tar.gz) = 3fad28be3cbb8b85a6c188507c99977ffac4639943d6db9ef6f2a59cceeec631
+SIZE (InlineX-CPP2XS-0.15.tar.gz) = 19751
diff --git a/devel/p5-InlineX-CPP2XS/pkg-descr b/devel/p5-InlineX-CPP2XS/pkg-descr
new file mode 100644
index 000000000000..32313778bcc7
--- /dev/null
+++ b/devel/p5-InlineX-CPP2XS/pkg-descr
@@ -0,0 +1,4 @@
+InlineX::CPP2XS is a perl module to create an XS file from an
+Inline C++ file.
+
+WWW: http://search.cpan.org/dist/InlineX-CPP2XS/
diff --git a/devel/p5-InlineX-CPP2XS/pkg-plist b/devel/p5-InlineX-CPP2XS/pkg-plist
new file mode 100644
index 000000000000..663416fd2366
--- /dev/null
+++ b/devel/p5-InlineX-CPP2XS/pkg-plist
@@ -0,0 +1,6 @@
+%%SITE_PERL%%/InlineX/CPP2XS.pm
+%%SITE_PERL%%/InlineX/CPP2XS-Cookbook.pod
+%%SITE_PERL%%/%%PERL_ARCH%%/auto/InlineX/CPP2XS/.packlist
+@dirrm %%SITE_PERL%%/%%PERL_ARCH%%/auto/InlineX/CPP2XS
+@dirrmtry %%SITE_PERL%%/%%PERL_ARCH%%/auto/InlineX
+@dirrmtry %%SITE_PERL%%/InlineX