aboutsummaryrefslogtreecommitdiffstats
path: root/devel
diff options
context:
space:
mode:
authorrakuco <rakuco@FreeBSD.org>2017-10-09 03:57:25 +0800
committerrakuco <rakuco@FreeBSD.org>2017-10-09 03:57:25 +0800
commit7502d102f3b4083e8c64cf39cdb09c55697d420b (patch)
tree627f4b06eaaea808ff616c03aaa1a5e821840e57 /devel
parent1c618cd5d985b256cc992673fb03b60a31e7e055 (diff)
downloadfreebsd-ports-gnome-7502d102f3b4083e8c64cf39cdb09c55697d420b.tar.gz
freebsd-ports-gnome-7502d102f3b4083e8c64cf39cdb09c55697d420b.tar.zst
freebsd-ports-gnome-7502d102f3b4083e8c64cf39cdb09c55697d420b.zip
Add USES=compiler:c++11-lib.
It doesn't have an effect on platforms with clang and libc++ as the default compiler, but should likely help with the powerpc64 build error that was marked in the Makefile.
Diffstat (limited to 'devel')
-rw-r--r--devel/cpprestsdk/Makefile4
1 files changed, 1 insertions, 3 deletions
diff --git a/devel/cpprestsdk/Makefile b/devel/cpprestsdk/Makefile
index e87a68cb839e..38b01342dfe8 100644
--- a/devel/cpprestsdk/Makefile
+++ b/devel/cpprestsdk/Makefile
@@ -14,12 +14,10 @@ LICENSE_FILE= ${WRKSRC}/../license.txt
LIB_DEPENDS= libboost_system.so:devel/boost-libs
-BROKEN_powerpc64= fails to compile: cc1plus: unrecognized command line option "-std=c++11"
-
USE_GITHUB= yes
GH_ACCOUNT= Microsoft
-USES= cmake ssl
+USES= cmake compiler:c++11-lib ssl
USE_LDCONFIG= yes
WRKSRC_SUBDIR= Release