aboutsummaryrefslogtreecommitdiffstats
path: root/devel
diff options
context:
space:
mode:
authorsunpoet <sunpoet@FreeBSD.org>2018-11-12 02:19:41 +0800
committersunpoet <sunpoet@FreeBSD.org>2018-11-12 02:19:41 +0800
commit762223cfaca1c5352037fe3a71ea34c2777b9555 (patch)
treeaa7edfe26fc0d4a3c4d6fff6d31f5870839a55ed /devel
parent6c7c584f1671a2da52e2b16008c4b1eb91af0bd5 (diff)
downloadfreebsd-ports-gnome-762223cfaca1c5352037fe3a71ea34c2777b9555.tar.gz
freebsd-ports-gnome-762223cfaca1c5352037fe3a71ea34c2777b9555.tar.zst
freebsd-ports-gnome-762223cfaca1c5352037fe3a71ea34c2777b9555.zip
Fix *_DEPENDS
- Add NO_ARCH - Bump PORTREVISION for dependency and package change
Diffstat (limited to 'devel')
-rw-r--r--devel/py-unittest2/Makefile18
1 files changed, 9 insertions, 9 deletions
diff --git a/devel/py-unittest2/Makefile b/devel/py-unittest2/Makefile
index 12601b131c97..eded4b937cc3 100644
--- a/devel/py-unittest2/Makefile
+++ b/devel/py-unittest2/Makefile
@@ -2,6 +2,7 @@
PORTNAME= unittest2
PORTVERSION= 1.1.0
+PORTREVISION= 1
CATEGORIES= devel python
MASTER_SITES= CHEESESHOP
PKGNAMEPREFIX= ${PYTHON_PKGNAMEPREFIX}
@@ -11,18 +12,17 @@ COMMENT= New features in unittest backported to Python 2
LICENSE= BSD3CLAUSE
-BUILD_DEPENDS= ${PYTHON_PKGNAMEPREFIX}linecache2>0:devel/py-linecache2@${PY_FLAVOR} \
- ${PYTHON_PKGNAMEPREFIX}six>0:devel/py-six@${PY_FLAVOR} \
- ${PYTHON_PKGNAMEPREFIX}traceback2>0:devel/py-traceback2@${PY_FLAVOR}
-RUN_DEPENDS= ${PYTHON_PKGNAMEPREFIX}linecache2>0:devel/py-linecache2@${PY_FLAVOR} \
- ${PYTHON_PKGNAMEPREFIX}six>0:devel/py-six@${PY_FLAVOR} \
- ${PYTHON_PKGNAMEPREFIX}traceback2>0:devel/py-traceback2@${PY_FLAVOR}
+BUILD_DEPENDS= ${PYTHON_PKGNAMEPREFIX}six>=1.4:devel/py-six@${PY_FLAVOR} \
+ ${PYTHON_PKGNAMEPREFIX}traceback2>=0:devel/py-traceback2@${PY_FLAVOR}
+RUN_DEPENDS= ${PYTHON_PKGNAMEPREFIX}six>=1.4:devel/py-six@${PY_FLAVOR} \
+ ${PYTHON_PKGNAMEPREFIX}traceback2>=0:devel/py-traceback2@${PY_FLAVOR}
USES= python
-USE_PYTHON= autoplist distutils
+USE_PYTHON= autoplist concurrent distutils
+
+NO_ARCH= yes
post-patch:
- @${REINPLACE_CMD} -e "s|'argparse', ||" \
- ${WRKSRC}/setup.py
+ @${REINPLACE_CMD} -e "s|'argparse', ||" ${WRKSRC}/setup.py
.include <bsd.port.mk>