aboutsummaryrefslogtreecommitdiffstats
path: root/devel
diff options
context:
space:
mode:
authorthierry <thierry@FreeBSD.org>2005-02-22 02:05:04 +0800
committerthierry <thierry@FreeBSD.org>2005-02-22 02:05:04 +0800
commit770871c1eab230d29b148bc1ae9f369fa5fca2ef (patch)
tree1254a119aac3e078948772a9dc2a6af5ec7da32a /devel
parent2d86e6539303e270f7bf44c4202d769adeb5d9aa (diff)
downloadfreebsd-ports-gnome-770871c1eab230d29b148bc1ae9f369fa5fca2ef.tar.gz
freebsd-ports-gnome-770871c1eab230d29b148bc1ae9f369fa5fca2ef.tar.zst
freebsd-ports-gnome-770871c1eab230d29b148bc1ae9f369fa5fca2ef.zip
PR ports/77594 has been submitted to fix plist, but this case has
been fixed with the upgrade to 1.3.5. This fixes two other deinstallation problems: pear2 not found and several sub-directories (e.g. pear-HTML_Select_Common-1.1_3). Approved by: maintainer
Diffstat (limited to 'devel')
-rw-r--r--devel/pear-PEAR/Makefile.common2
-rw-r--r--devel/pear-PEAR/pkg-deinstall5
2 files changed, 5 insertions, 2 deletions
diff --git a/devel/pear-PEAR/Makefile.common b/devel/pear-PEAR/Makefile.common
index 12e6e1e21496..9271f7afa218 100644
--- a/devel/pear-PEAR/Makefile.common
+++ b/devel/pear-PEAR/Makefile.common
@@ -109,7 +109,7 @@ do-generate-plist:
for file in ${DOCS}; do echo "%%PORTDOCS%%${LDOCSDIR}/$${file}"; done; \
for file in ${EXAMPLES}; do echo "%%PORTDOCS%%${LEXAMPLESDIR}/$${file}"; done; \
echo "${LPKGREGDIR}/package.xml"; \
- for d in ${FILES}; do echo $${d}; done | ${DIRFILTER} | \
+ for d in ${FILES} ${FILES:H}; do echo $${d}; done | ${DIRFILTER} | \
while read dir; do echo "@dirrm ${LINSTDIR}/$${dir}"; done; \
for d in ${TESTS}; do echo $${d}; done | ${DIRFILTER} | \
while read dir; do echo "@dirrm ${LTESTSDIR}/$${dir}"; done; \
diff --git a/devel/pear-PEAR/pkg-deinstall b/devel/pear-PEAR/pkg-deinstall
index c0cbc6c195fc..94de0bfd249e 100644
--- a/devel/pear-PEAR/pkg-deinstall
+++ b/devel/pear-PEAR/pkg-deinstall
@@ -13,7 +13,10 @@ PACKAGE=$(echo $PKG_NAME | sed 's/pear-//')
PEAR=${PKG_PREFIX}/bin/pear
PEAR2=${PKG_PREFIX}/bin/pear2
-if [ ${PKG_NAME} = "pear-PEAR" ]; then
+if [ ${PACKAGE} = "PEAR" ] \
+|| [ ${PACKAGE} = "Archive_Tar" ] \
+|| [ ${PACKAGE} = "Console_Getopt" ] \
+|| [ ${PACKAGE} = "XML_RPC" ]; then
PEAR_INSTALLER=${PEAR}
else
PEAR_INSTALLER=${PEAR2}