aboutsummaryrefslogtreecommitdiffstats
path: root/devel
diff options
context:
space:
mode:
authorkwm <kwm@FreeBSD.org>2014-02-16 22:43:29 +0800
committerkwm <kwm@FreeBSD.org>2014-02-16 22:43:29 +0800
commit797812c3442a81cdbcdd0238f583377177c46f84 (patch)
treec183d3840f561dde24d17c232056250770dcf6d6 /devel
parent1639dec579b27c190ddc07ee6a9cf7633071a9c4 (diff)
downloadfreebsd-ports-gnome-797812c3442a81cdbcdd0238f583377177c46f84.tar.gz
freebsd-ports-gnome-797812c3442a81cdbcdd0238f583377177c46f84.tar.zst
freebsd-ports-gnome-797812c3442a81cdbcdd0238f583377177c46f84.zip
Update to 1.8.1. [1]
Use introspection USE_GNOME component to prevent /root/.cache from being generated [1,2] Use USES=libtool instead of ltverhack. Update LIB_DEPEND syntax [1]. Sync some small changes with MC devel repo. PR: ports/186782 [1] ports/185915 [2] Submitted by: olivierd@ [1] Dmitry Marakasov <amdmi3@amdmi3.ru> [2]
Diffstat (limited to 'devel')
-rw-r--r--devel/libpeas/Makefile30
-rw-r--r--devel/libpeas/distinfo4
-rw-r--r--devel/libpeas/pkg-plist40
3 files changed, 34 insertions, 40 deletions
diff --git a/devel/libpeas/Makefile b/devel/libpeas/Makefile
index 4d9acfb52bcb..f3da893e838d 100644
--- a/devel/libpeas/Makefile
+++ b/devel/libpeas/Makefile
@@ -1,9 +1,9 @@
# Created by: Koop Mast <kwm@FreeBSD.org>
# $FreeBSD$
-# $MCom: ports/trunk/devel/libpeas/Makefile 17268 2013-04-01 05:13:11Z marcus $
+# $MCom: ports/trunk/devel/libpeas/Makefile 19006 2014-02-16 10:03:26Z kwm $
PORTNAME= libpeas
-PORTVERSION= 1.6.1
+PORTVERSION= 1.8.1
CATEGORIES= devel gnome
MASTER_SITES= GNOME
DIST_SUBDIR= gnome3
@@ -11,35 +11,33 @@ DIST_SUBDIR= gnome3
MAINTAINER= kwm@FreeBSD.org
COMMENT= Next evolution of the Gedit plugins engine
-BUILD_DEPENDS= g-ir-scanner:${PORTSDIR}/devel/gobject-introspection \
- valac:${PORTSDIR}/lang/vala
+BUILD_DEPENDS= valac:${PORTSDIR}/lang/vala
USE_XZ= yes
-USE_PYTHON= yes
+USE_PYTHON= 2
USE_LDCONFIG= yes
-USE_AUTOTOOLS= libtool
-USES= pathfix gettext gmake pkgconfig
-USE_GNOME= glib20 gtk30 ltverhack
+USES= gettext gmake libtool pathfix pkgconfig
+USE_GNOME= gtk30 introspection:build
INSTALLS_ICONS= yes
GNU_CONFIGURE= yes
CPPFLAGS+= -I${LOCALBASE}/include
LDFLAGS+= -L${LOCALBASE}/lib
+INSTALL_TARGET= install-strip
CONFIGURE_ARGS+=--disable-glade-catalog
-OPTIONS_DEFINE= PYTHON JS
-OPTIONS_DEFAULT=PYTHON JS GJS
+OPTIONS_DEFINE= PYTHON
+OPTIONS_DEFAULT=PYTHON GJS
OPTIONS_MULTI= JS
OPTIONS_MULTI_JS=SEED GJS
JS_DESC=JavaScript plugin support
SEED_DESC= JavaScript support based on webkit-gtk3
GJS_DESC= JavaScript support based on spidermonkey
-NO_STAGE= yes
.include <bsd.port.options.mk>
.if ${PORT_OPTIONS:MSEED}
CONFIGURE_ARGS+=--enable-seed=yes
-LIB_DEPENDS= seed-gtk3:${PORTSDIR}/devel/seed3
+LIB_DEPENDS= libseed-gtk3.so:${PORTSDIR}/devel/seed3
PLIST_SUB+= SEED=""
.else
CONFIGURE_ARGS+=--enable-seed=no
@@ -47,24 +45,22 @@ PLIST_SUB+= SEED="@comment "
.endif
.if ${PORT_OPTIONS:MPYTHON}
-CONFIGURE_ARGS+=--enable-python
+CONFIGURE_ARGS+=--enable-python2 --disable-python3
USE_GNOME+= pygobject3
PLIST_SUB+= PYTHONS=""
.else
-CONFIGURE_ARGS+=--enable-python=no
+CONFIGURE_ARGS+=--disable-python2 --disable-python3
PLIST_SUB+= PYTHONS="@comment "
.endif
.if ${PORT_OPTIONS:MGJS}
CONFIGURE_ARGS+=--enable-gjs
BUILD_DEPENDS+= gjs>=1.32.0:${PORTSDIR}/lang/gjs
-LIB_DEPENDS+= gjs:${PORTSDIR}/lang/gjs
+LIB_DEPENDS+= libgjs.so:${PORTSDIR}/lang/gjs
PLIST_SUB+= GJS=""
.else
CONFIGURE_ARGS+=--enable-gjs=no
PLIST_SUB+= GJS="@comment "
.endif
-PLIST_SUB+= VALA="@comment "
-
.include <bsd.port.mk>
diff --git a/devel/libpeas/distinfo b/devel/libpeas/distinfo
index 7b07f46faa6a..334d35bc69c4 100644
--- a/devel/libpeas/distinfo
+++ b/devel/libpeas/distinfo
@@ -1,2 +1,2 @@
-SHA256 (gnome3/libpeas-1.6.1.tar.xz) = 7f133f44101594e0f96a0e5fe69c5893cde500f3edf916f680467dfd74de5c39
-SIZE (gnome3/libpeas-1.6.1.tar.xz) = 523800
+SHA256 (gnome3/libpeas-1.8.1.tar.xz) = ff0e7cd1f0da5dc1289efdd4662a06188f8f0fb088eac67abe05ffa66ba7751d
+SIZE (gnome3/libpeas-1.8.1.tar.xz) = 530948
diff --git a/devel/libpeas/pkg-plist b/devel/libpeas/pkg-plist
index ce93eee9e58a..82b46029f9fc 100644
--- a/devel/libpeas/pkg-plist
+++ b/devel/libpeas/pkg-plist
@@ -13,43 +13,30 @@ include/libpeas-1.0/libpeas-gtk/peas-gtk-plugin-manager.h
include/libpeas-1.0/libpeas-gtk/peas-gtk.h
lib/girepository-1.0/Peas-1.0.typelib
lib/girepository-1.0/PeasGtk-1.0.typelib
-lib/libpeas-1.0.a
lib/libpeas-1.0.la
lib/libpeas-1.0.so
lib/libpeas-1.0.so.0
-%%GJS%%lib/libpeas-1.0/loaders/libgjsloader.a
+lib/libpeas-1.0.so.0.801.0
%%GJS%%lib/libpeas-1.0/loaders/libgjsloader.la
%%GJS%%lib/libpeas-1.0/loaders/libgjsloader.so
-%%PYTHONS%%lib/libpeas-1.0/loaders/libpythonloader.a
%%PYTHONS%%lib/libpeas-1.0/loaders/libpythonloader.la
%%PYTHONS%%lib/libpeas-1.0/loaders/libpythonloader.so
-%%SEED%%lib/libpeas-1.0/loaders/libseedloader.a
%%SEED%%lib/libpeas-1.0/loaders/libseedloader.la
%%SEED%%lib/libpeas-1.0/loaders/libseedloader.so
-lib/libpeas-gtk-1.0.a
lib/libpeas-gtk-1.0.la
lib/libpeas-gtk-1.0.so
lib/libpeas-gtk-1.0.so.0
+lib/libpeas-gtk-1.0.so.0.801.0
%%GJS%%lib/peas-demo/plugins/gjshello/gjshello.js
%%GJS%%lib/peas-demo/plugins/gjshello/gjshello.plugin
lib/peas-demo/plugins/helloworld/helloworld.plugin
-lib/peas-demo/plugins/helloworld/libhelloworld.a
lib/peas-demo/plugins/helloworld/libhelloworld.la
lib/peas-demo/plugins/helloworld/libhelloworld.so
-%%PYTHONS%%lib/peas-demo/plugins/pythonhello/pythonhello.plugin
-%%PYTHONS%%lib/peas-demo/plugins/pythonhello/pythonhello.py
-%%PYTHONS%%lib/peas-demo/plugins/pythonhello/pythonhello.pyc
-%%PYTHONS%%lib/peas-demo/plugins/pythonhello/pythonhello.pyo
-lib/peas-demo/plugins/secondtime/libsecondtime.a
lib/peas-demo/plugins/secondtime/libsecondtime.la
lib/peas-demo/plugins/secondtime/libsecondtime.so
lib/peas-demo/plugins/secondtime/secondtime.plugin
%%SEED%%lib/peas-demo/plugins/seedhello/seedhello.js
%%SEED%%lib/peas-demo/plugins/seedhello/seedhello.plugin
-%%VALA%%lib/peas-demo/plugins/valahello/libvalahello.a
-%%VALA%%lib/peas-demo/plugins/valahello/libvalahello.la
-%%VALA%%lib/peas-demo/plugins/valahello/libvalahello.so
-%%VALA%%lib/peas-demo/plugins/valahello/valahello.plugin
libdata/pkgconfig/libpeas-1.0.pc
libdata/pkgconfig/libpeas-gtk-1.0.pc
share/gir-1.0/Peas-1.0.gir
@@ -83,6 +70,7 @@ share/icons/hicolor/16x16/actions/libpeas-plugin.png
share/icons/hicolor/22x22/actions/libpeas-plugin.png
share/icons/hicolor/32x32/actions/libpeas-plugin.png
share/icons/hicolor/scalable/actions/libpeas-plugin.svg
+share/locale/an/LC_MESSAGES/libpeas.mo
share/locale/ar/LC_MESSAGES/libpeas.mo
share/locale/as/LC_MESSAGES/libpeas.mo
share/locale/ast/LC_MESSAGES/libpeas.mo
@@ -103,6 +91,7 @@ share/locale/eu/LC_MESSAGES/libpeas.mo
share/locale/fa/LC_MESSAGES/libpeas.mo
share/locale/fi/LC_MESSAGES/libpeas.mo
share/locale/fr/LC_MESSAGES/libpeas.mo
+share/locale/fur/LC_MESSAGES/libpeas.mo
share/locale/gl/LC_MESSAGES/libpeas.mo
share/locale/gu/LC_MESSAGES/libpeas.mo
share/locale/he/LC_MESSAGES/libpeas.mo
@@ -114,26 +103,29 @@ share/locale/ja/LC_MESSAGES/libpeas.mo
share/locale/kn/LC_MESSAGES/libpeas.mo
share/locale/ko/LC_MESSAGES/libpeas.mo
share/locale/lt/LC_MESSAGES/libpeas.mo
-share/locale/mr/LC_MESSAGES/libpeas.mo
-share/locale/te/LC_MESSAGES/libpeas.mo
-share/locale/th/LC_MESSAGES/libpeas.mo
-share/locale/tr/LC_MESSAGES/libpeas.mo
share/locale/lv/LC_MESSAGES/libpeas.mo
share/locale/ml/LC_MESSAGES/libpeas.mo
+share/locale/mr/LC_MESSAGES/libpeas.mo
share/locale/nb/LC_MESSAGES/libpeas.mo
share/locale/nds/LC_MESSAGES/libpeas.mo
share/locale/nl/LC_MESSAGES/libpeas.mo
+share/locale/or/LC_MESSAGES/libpeas.mo
share/locale/pa/LC_MESSAGES/libpeas.mo
share/locale/pl/LC_MESSAGES/libpeas.mo
share/locale/pt/LC_MESSAGES/libpeas.mo
share/locale/pt_BR/LC_MESSAGES/libpeas.mo
share/locale/ro/LC_MESSAGES/libpeas.mo
share/locale/ru/LC_MESSAGES/libpeas.mo
+share/locale/sk/LC_MESSAGES/libpeas.mo
share/locale/sl/LC_MESSAGES/libpeas.mo
share/locale/sr/LC_MESSAGES/libpeas.mo
share/locale/sr@latin/LC_MESSAGES/libpeas.mo
share/locale/sv/LC_MESSAGES/libpeas.mo
share/locale/ta/LC_MESSAGES/libpeas.mo
+share/locale/te/LC_MESSAGES/libpeas.mo
+share/locale/tg/LC_MESSAGES/libpeas.mo
+share/locale/th/LC_MESSAGES/libpeas.mo
+share/locale/tr/LC_MESSAGES/libpeas.mo
share/locale/ug/LC_MESSAGES/libpeas.mo
share/locale/uk/LC_MESSAGES/libpeas.mo
share/locale/vi/LC_MESSAGES/libpeas.mo
@@ -150,17 +142,23 @@ share/locale/zh_TW/LC_MESSAGES/libpeas.mo
@dirrmtry share/locale/sr@latin
@dirrmtry share/locale/nds/LC_MESSAGES
@dirrmtry share/locale/nds
+@dirrmtry share/locale/mr/LC_MESSAGES
+@dirrmtry share/locale/mr
+@dirrmtry share/locale/fur/LC_MESSAGES
+@dirrmtry share/locale/fur
@dirrmtry share/locale/ca@valencia/LC_MESSAGES
@dirrmtry share/locale/ca@valencia
+@dirrmtry share/locale/bn_IN/LC_MESSAGES
+@dirrmtry share/locale/bn_IN
@dirrmtry share/locale/ast/LC_MESSAGES
@dirrmtry share/locale/ast
@dirrmtry share/locale/as/LC_MESSAGES
@dirrmtry share/locale/as
+@dirrmtry share/locale/an/LC_MESSAGES
+@dirrmtry share/locale/an
@dirrm share/gtk-doc/html/libpeas
-%%VALA%%@dirrm lib/peas-demo/plugins/valahello
%%SEED%%@dirrm lib/peas-demo/plugins/seedhello
@dirrm lib/peas-demo/plugins/secondtime
-%%PYTHONS%%@dirrm lib/peas-demo/plugins/pythonhello
%%GJS%%@dirrm lib/peas-demo/plugins/gjshello
@dirrm lib/peas-demo/plugins/helloworld
@dirrm lib/peas-demo/plugins