aboutsummaryrefslogtreecommitdiffstats
path: root/devel
diff options
context:
space:
mode:
authorlev <lev@FreeBSD.org>2008-07-22 20:04:37 +0800
committerlev <lev@FreeBSD.org>2008-07-22 20:04:37 +0800
commit7cb8f7bedf1e76d14dd36ab6289f7841a11a72e0 (patch)
tree3ce727171ef2181c2343b3064ae602ddc4ee6c46 /devel
parent6ac2b47fe567d6904eef91eaa0710bc4656b8ba1 (diff)
downloadfreebsd-ports-gnome-7cb8f7bedf1e76d14dd36ab6289f7841a11a72e0.tar.gz
freebsd-ports-gnome-7cb8f7bedf1e76d14dd36ab6289f7841a11a72e0.tar.zst
freebsd-ports-gnome-7cb8f7bedf1e76d14dd36ab6289f7841a11a72e0.zip
Fix subversion's bindings building ob build cluster, when subversion everything, but
bindings are installed from packages.
Diffstat (limited to 'devel')
-rw-r--r--devel/p5-subversion/Makefile2
-rw-r--r--devel/py-subversion/Makefile2
-rw-r--r--devel/ruby-subversion/Makefile2
-rw-r--r--devel/subversion/Makefile.common6
-rw-r--r--devel/subversion16/Makefile.common6
5 files changed, 6 insertions, 12 deletions
diff --git a/devel/p5-subversion/Makefile b/devel/p5-subversion/Makefile
index 594925df2e70..a4fdf5f0008b 100644
--- a/devel/p5-subversion/Makefile
+++ b/devel/p5-subversion/Makefile
@@ -13,8 +13,6 @@ COMMENT= Perl bindings for Version control system
MASTERDIR= ${.CURDIR}/../../devel/subversion
PKGDIR= ${.CURDIR}
-BROKEN= conflicting dependencies
-
USE_PERL5= 5.8.0+
MAN3PREFIX= ${PREFIX}/lib/perl5/${PERL_VERSION}
diff --git a/devel/py-subversion/Makefile b/devel/py-subversion/Makefile
index fa9145561175..897c4069f411 100644
--- a/devel/py-subversion/Makefile
+++ b/devel/py-subversion/Makefile
@@ -10,8 +10,6 @@ PKGNAMEPREFIX= py-
MAINTAINER= lev@FreeBSD.org
COMMENT= Python bindings for version control system
-BROKEN= depends on apr-db42-1.3.2 and apr-1.3.2 which conflict with each other
-
MASTERDIR= ${.CURDIR}/../../devel/subversion
PKGDIR= ${.CURDIR}
diff --git a/devel/ruby-subversion/Makefile b/devel/ruby-subversion/Makefile
index 3f936fe5e4a2..ed0703a1854f 100644
--- a/devel/ruby-subversion/Makefile
+++ b/devel/ruby-subversion/Makefile
@@ -10,8 +10,6 @@ PKGNAMEPREFIX= ruby-
MAINTAINER= lev@FreeBSD.org
COMMENT= Ruby bindings for version control system
-BROKEN= depends on apr-db42-1.3.2 and apr-1.3.2 which conflict with each other
-
MASTERDIR= ${.CURDIR}/../../devel/subversion
PKGDIR= ${.CURDIR}
diff --git a/devel/subversion/Makefile.common b/devel/subversion/Makefile.common
index 85d74367cd1c..8903a1f92cbf 100644
--- a/devel/subversion/Makefile.common
+++ b/devel/subversion/Makefile.common
@@ -6,7 +6,7 @@
PORTNAME= subversion
PORTVERSION= 1.5.0
-PORTREVISION?= 3
+PORTREVISION?= 4
CATEGORIES+= devel
MASTER_SITES= http://subversion.tigris.org/downloads/:main \
http://svnbook.red-bean.com/en/1.4/:book
@@ -90,7 +90,7 @@ APR_CONFIG= apr-config
APU_CONFIG= apu-config
.endif
APR_PORT= ${APACHE_PORT}
-.if defined(WITH_BDB)
+.if !defined(WITHOUT_BDB)
DEPENDS_ARGS+= WITH_BERKELEYDB=db4
OPT_NAME= WITH_BERKELEYDB=(db4|db41|db42)
.endif
@@ -98,7 +98,7 @@ OPT_NAME= WITH_BERKELEYDB=(db4|db41|db42)
APR_APU_DIR= ${LOCALBASE}/bin
APR_CONFIG= apr-1-config
APU_CONFIG= apu-1-config
-.if defined(WITH_BDB)
+.if !defined(WITHOUT_BDB)
LIB_DEPENDS+= apr-1.3:${PORTSDIR}/devel/apr-svn
APR_PORT= devel/apr-svn
OPT_NAME= APR_UTIL_WITH_BERKELEY_DB=yes
diff --git a/devel/subversion16/Makefile.common b/devel/subversion16/Makefile.common
index 85d74367cd1c..8903a1f92cbf 100644
--- a/devel/subversion16/Makefile.common
+++ b/devel/subversion16/Makefile.common
@@ -6,7 +6,7 @@
PORTNAME= subversion
PORTVERSION= 1.5.0
-PORTREVISION?= 3
+PORTREVISION?= 4
CATEGORIES+= devel
MASTER_SITES= http://subversion.tigris.org/downloads/:main \
http://svnbook.red-bean.com/en/1.4/:book
@@ -90,7 +90,7 @@ APR_CONFIG= apr-config
APU_CONFIG= apu-config
.endif
APR_PORT= ${APACHE_PORT}
-.if defined(WITH_BDB)
+.if !defined(WITHOUT_BDB)
DEPENDS_ARGS+= WITH_BERKELEYDB=db4
OPT_NAME= WITH_BERKELEYDB=(db4|db41|db42)
.endif
@@ -98,7 +98,7 @@ OPT_NAME= WITH_BERKELEYDB=(db4|db41|db42)
APR_APU_DIR= ${LOCALBASE}/bin
APR_CONFIG= apr-1-config
APU_CONFIG= apu-1-config
-.if defined(WITH_BDB)
+.if !defined(WITHOUT_BDB)
LIB_DEPENDS+= apr-1.3:${PORTSDIR}/devel/apr-svn
APR_PORT= devel/apr-svn
OPT_NAME= APR_UTIL_WITH_BERKELEY_DB=yes