aboutsummaryrefslogtreecommitdiffstats
path: root/devel
diff options
context:
space:
mode:
authorpi <pi@FreeBSD.org>2015-05-01 22:48:49 +0800
committerpi <pi@FreeBSD.org>2015-05-01 22:48:49 +0800
commit7e64b23d644df312f7ee04e4c47894b707c41a21 (patch)
tree5510c64869af641f025e7d9a4e9a7eb0a3fa1483 /devel
parent20d587b0227e89c4827d3342078c995272a9e014 (diff)
downloadfreebsd-ports-gnome-7e64b23d644df312f7ee04e4c47894b707c41a21.tar.gz
freebsd-ports-gnome-7e64b23d644df312f7ee04e4c47894b707c41a21.tar.zst
freebsd-ports-gnome-7e64b23d644df312f7ee04e4c47894b707c41a21.zip
New port: devel/ocaml-ppx-tools
Tools for authors of syntactic tools (such as ppx rewriters). This package is licensed by LexiFi under the terms of the MIT license. WWW: https://github.com/alainfrisch/ppx_tools PR: 195777 Submitted by: <Michael Grünewald> (michipili@gmail.com)
Diffstat (limited to 'devel')
-rw-r--r--devel/Makefile1
-rw-r--r--devel/ocaml-ppx-tools/Makefile26
-rw-r--r--devel/ocaml-ppx-tools/distinfo2
-rw-r--r--devel/ocaml-ppx-tools/pkg-descr5
-rw-r--r--devel/ocaml-ppx-tools/pkg-plist13
5 files changed, 47 insertions, 0 deletions
diff --git a/devel/Makefile b/devel/Makefile
index bc012bbf3baf..fa5ce33a91db 100644
--- a/devel/Makefile
+++ b/devel/Makefile
@@ -1401,6 +1401,7 @@
SUBDIR += ocaml-ounit
SUBDIR += ocaml-pcre
SUBDIR += ocaml-pomap
+ SUBDIR += ocaml-ppx-tools
SUBDIR += ocaml-react
SUBDIR += ocaml-res
SUBDIR += ocaml-sdl
diff --git a/devel/ocaml-ppx-tools/Makefile b/devel/ocaml-ppx-tools/Makefile
new file mode 100644
index 000000000000..784cdd872d66
--- /dev/null
+++ b/devel/ocaml-ppx-tools/Makefile
@@ -0,0 +1,26 @@
+# Created by: Michael Grünewald <michipili@gmail.com>
+# $FreeBSD$
+
+PORTNAME= ppx-tools
+PORTVERSION= 0.99.2
+CATEGORIES= devel
+MASTER_SITES= https://github.com/alainfrisch/${PORTNAME:C/-/_/}/archive/
+PKGNAMEPREFIX= ocaml-
+DISTNAME= ${PORTNAME:C/-/_/}_${PORTVERSION}
+DIST_SUBDIR= ${PKGNAMEPREFIX}${PORTNAME}
+
+MAINTAINER= michipili@gmail.com
+COMMENT= Tools for authors of ppx rewriters
+
+LICENSE= MIT
+
+USES= gmake
+USE_OCAML= yes
+USE_OCAML_FINDLIB=yes
+MAKE_JOBS_UNSAFE=yes
+WRKSRC= ${WRKDIR}/${PORTNAME:C/-/_/}-${PORTNAME:C/-/_/}_${PORTVERSION}
+
+post-stage:
+ ${STRIP_CMD} ${STAGEDIR}${PREFIX}/lib/ocaml/site-lib/ppx_tools/ppx_tools.cmxs
+
+.include <bsd.port.mk>
diff --git a/devel/ocaml-ppx-tools/distinfo b/devel/ocaml-ppx-tools/distinfo
new file mode 100644
index 000000000000..7a629b5dfc79
--- /dev/null
+++ b/devel/ocaml-ppx-tools/distinfo
@@ -0,0 +1,2 @@
+SHA256 (ocaml-ppx-tools/ppx_tools_0.99.2.tar.gz) = 98128022ea0574d769a263eb9b73be06200eec4bac9adb8dc44df289a77c4dec
+SIZE (ocaml-ppx-tools/ppx_tools_0.99.2.tar.gz) = 15877
diff --git a/devel/ocaml-ppx-tools/pkg-descr b/devel/ocaml-ppx-tools/pkg-descr
new file mode 100644
index 000000000000..be2ad9f81634
--- /dev/null
+++ b/devel/ocaml-ppx-tools/pkg-descr
@@ -0,0 +1,5 @@
+Tools for authors of syntactic tools (such as ppx rewriters).
+
+This package is licensed by LexiFi under the terms of the MIT license.
+
+WWW: https://github.com/alainfrisch/ppx_tools
diff --git a/devel/ocaml-ppx-tools/pkg-plist b/devel/ocaml-ppx-tools/pkg-plist
new file mode 100644
index 000000000000..8797310bc2dd
--- /dev/null
+++ b/devel/ocaml-ppx-tools/pkg-plist
@@ -0,0 +1,13 @@
+%%OCAML_SITELIBDIR%%/ppx_tools/META
+%%OCAML_SITELIBDIR%%/ppx_tools/ast_convenience.cmi
+%%OCAML_SITELIBDIR%%/ppx_tools/ast_convenience.cmx
+%%OCAML_SITELIBDIR%%/ppx_tools/ast_mapper_class.cmi
+%%OCAML_SITELIBDIR%%/ppx_tools/ast_mapper_class.cmx
+%%OCAML_SITELIBDIR%%/ppx_tools/dumpast
+%%OCAML_SITELIBDIR%%/ppx_tools/genlifter
+%%OCAML_SITELIBDIR%%/ppx_tools/ppx_metaquot
+%%OCAML_SITELIBDIR%%/ppx_tools/ppx_tools.a
+%%OCAML_SITELIBDIR%%/ppx_tools/ppx_tools.cma
+%%OCAML_SITELIBDIR%%/ppx_tools/ppx_tools.cmxa
+%%OCAML_SITELIBDIR%%/ppx_tools/ppx_tools.cmxs
+%%OCAML_SITELIBDIR%%/ppx_tools/rewriter