aboutsummaryrefslogtreecommitdiffstats
path: root/devel
diff options
context:
space:
mode:
authorahze <ahze@FreeBSD.org>2006-11-20 07:25:49 +0800
committerahze <ahze@FreeBSD.org>2006-11-20 07:25:49 +0800
commit7fb3e42c6ecd7a2863b45ae02269e68dc59bc2bb (patch)
treeffa4a47b4b097f4b620ea726f4c2540aee2400f7 /devel
parent6b72990fe5b60b09a8eaaec52e571aa7a9ec3a09 (diff)
downloadfreebsd-ports-gnome-7fb3e42c6ecd7a2863b45ae02269e68dc59bc2bb.tar.gz
freebsd-ports-gnome-7fb3e42c6ecd7a2863b45ae02269e68dc59bc2bb.tar.zst
freebsd-ports-gnome-7fb3e42c6ecd7a2863b45ae02269e68dc59bc2bb.zip
Fix depends on gcc34 on 5.x unless WITH_3DNOW_GCC40 is defined then it
will depend on gcc40+ Reported by: pav
Diffstat (limited to 'devel')
-rw-r--r--devel/liboil/Makefile12
1 files changed, 9 insertions, 3 deletions
diff --git a/devel/liboil/Makefile b/devel/liboil/Makefile
index bd4d14f02931..ed1f61f98b80 100644
--- a/devel/liboil/Makefile
+++ b/devel/liboil/Makefile
@@ -24,13 +24,19 @@ CFLAGS+= -O2
.include <bsd.port.pre.mk>
-.if ${OSVERSION} < 600000 && ${OSVERSION} > 500000
-USE_GCC= 3.4+
-RUN_DEPENDS+= ${CC}:${PORTSDIR}/lang/${CC}
+.if ${OSVERSION} < 600000 && ${OSVERSION} > 500000 && !defined(WITH_3DNOW_GCC40)
+BUILD_DEPENDS+= gcc34:${PORTSDIR}/lang/gcc34
+RUN_DEPENDS+= gcc34:${PORTSDIR}/lang/gcc34
+CC:= gcc34
+CXX:= g++34
.endif
.if defined(WITH_3DNOW_GCC40)
USE_GCC= 4.0+
+.if ${OSVERSION} < 600000 && ${OSVERSION} > 500000
+# yeah yeah, I know other stuff will be added that shouldn't...
+RUN_DEPENDS+= ${BUILD_DEPENDS}
+.endif
.endif
pre-everything::