aboutsummaryrefslogtreecommitdiffstats
path: root/devel
diff options
context:
space:
mode:
authorseanc <seanc@FreeBSD.org>2003-11-16 06:20:01 +0800
committerseanc <seanc@FreeBSD.org>2003-11-16 06:20:01 +0800
commit81534020134a60dce4b280283817550a5942259a (patch)
treed6e4a310588f52aa577aa571a17389ddc2ea456e /devel
parentcd386c7a1015e653336d6293d1d52bd7112f42c1 (diff)
downloadfreebsd-ports-gnome-81534020134a60dce4b280283817550a5942259a.tar.gz
freebsd-ports-gnome-81534020134a60dce4b280283817550a5942259a.tar.zst
freebsd-ports-gnome-81534020134a60dce4b280283817550a5942259a.zip
When installing bison, create a symlink from bin/bison to bin/bison1875
that way ports that require bison1875 (ie: PostgreSQL 7.4+) can properly detect this dependency. Given both bison's have the appropriate CONFLICTS sections, this should be a big enough hint to users to move from bison < 1.875 to something more recent. Bump port revision. Pointy hat to: bison(1) authors for grammar incompatibilities
Diffstat (limited to 'devel')
-rw-r--r--devel/bison-devel/Makefile5
-rw-r--r--devel/bison-devel/pkg-plist1
-rw-r--r--devel/bison1875/Makefile5
-rw-r--r--devel/bison1875/pkg-plist1
-rw-r--r--devel/bison2/Makefile5
-rw-r--r--devel/bison2/pkg-plist1
-rw-r--r--devel/bison20/Makefile5
-rw-r--r--devel/bison20/pkg-plist1
8 files changed, 20 insertions, 4 deletions
diff --git a/devel/bison-devel/Makefile b/devel/bison-devel/Makefile
index 0c6856608bf7..0c56476b12a2 100644
--- a/devel/bison-devel/Makefile
+++ b/devel/bison-devel/Makefile
@@ -7,7 +7,7 @@
PORTNAME= bison
PORTVERSION= 1.875
-PORTREVISION= 1
+PORTREVISION= 2
CATEGORIES= devel
MASTER_SITES= ${MASTER_SITE_GNU}
MASTER_SITE_SUBDIR= ${PORTNAME}
@@ -37,4 +37,7 @@ MAN1= bison.1
post-extract:
@${RM} -f ${WRKSRC}/doc/bison.info*
+post-install:
+ ${LN} -sf ${LOCALBASE}/bin/bison ${LOCALBASE}/bin/bison1875
+
.include <bsd.port.mk>
diff --git a/devel/bison-devel/pkg-plist b/devel/bison-devel/pkg-plist
index 040e1d6550ae..edad32f1329c 100644
--- a/devel/bison-devel/pkg-plist
+++ b/devel/bison-devel/pkg-plist
@@ -1,5 +1,6 @@
@comment $FreeBSD$
bin/bison
+bin/bison1875
bin/yacc
@unexec install-info --delete %D/info/bison.info %D/info/dir
info/bison.info
diff --git a/devel/bison1875/Makefile b/devel/bison1875/Makefile
index 0c6856608bf7..0c56476b12a2 100644
--- a/devel/bison1875/Makefile
+++ b/devel/bison1875/Makefile
@@ -7,7 +7,7 @@
PORTNAME= bison
PORTVERSION= 1.875
-PORTREVISION= 1
+PORTREVISION= 2
CATEGORIES= devel
MASTER_SITES= ${MASTER_SITE_GNU}
MASTER_SITE_SUBDIR= ${PORTNAME}
@@ -37,4 +37,7 @@ MAN1= bison.1
post-extract:
@${RM} -f ${WRKSRC}/doc/bison.info*
+post-install:
+ ${LN} -sf ${LOCALBASE}/bin/bison ${LOCALBASE}/bin/bison1875
+
.include <bsd.port.mk>
diff --git a/devel/bison1875/pkg-plist b/devel/bison1875/pkg-plist
index 040e1d6550ae..edad32f1329c 100644
--- a/devel/bison1875/pkg-plist
+++ b/devel/bison1875/pkg-plist
@@ -1,5 +1,6 @@
@comment $FreeBSD$
bin/bison
+bin/bison1875
bin/yacc
@unexec install-info --delete %D/info/bison.info %D/info/dir
info/bison.info
diff --git a/devel/bison2/Makefile b/devel/bison2/Makefile
index 0c6856608bf7..0c56476b12a2 100644
--- a/devel/bison2/Makefile
+++ b/devel/bison2/Makefile
@@ -7,7 +7,7 @@
PORTNAME= bison
PORTVERSION= 1.875
-PORTREVISION= 1
+PORTREVISION= 2
CATEGORIES= devel
MASTER_SITES= ${MASTER_SITE_GNU}
MASTER_SITE_SUBDIR= ${PORTNAME}
@@ -37,4 +37,7 @@ MAN1= bison.1
post-extract:
@${RM} -f ${WRKSRC}/doc/bison.info*
+post-install:
+ ${LN} -sf ${LOCALBASE}/bin/bison ${LOCALBASE}/bin/bison1875
+
.include <bsd.port.mk>
diff --git a/devel/bison2/pkg-plist b/devel/bison2/pkg-plist
index 040e1d6550ae..edad32f1329c 100644
--- a/devel/bison2/pkg-plist
+++ b/devel/bison2/pkg-plist
@@ -1,5 +1,6 @@
@comment $FreeBSD$
bin/bison
+bin/bison1875
bin/yacc
@unexec install-info --delete %D/info/bison.info %D/info/dir
info/bison.info
diff --git a/devel/bison20/Makefile b/devel/bison20/Makefile
index 0c6856608bf7..0c56476b12a2 100644
--- a/devel/bison20/Makefile
+++ b/devel/bison20/Makefile
@@ -7,7 +7,7 @@
PORTNAME= bison
PORTVERSION= 1.875
-PORTREVISION= 1
+PORTREVISION= 2
CATEGORIES= devel
MASTER_SITES= ${MASTER_SITE_GNU}
MASTER_SITE_SUBDIR= ${PORTNAME}
@@ -37,4 +37,7 @@ MAN1= bison.1
post-extract:
@${RM} -f ${WRKSRC}/doc/bison.info*
+post-install:
+ ${LN} -sf ${LOCALBASE}/bin/bison ${LOCALBASE}/bin/bison1875
+
.include <bsd.port.mk>
diff --git a/devel/bison20/pkg-plist b/devel/bison20/pkg-plist
index 040e1d6550ae..edad32f1329c 100644
--- a/devel/bison20/pkg-plist
+++ b/devel/bison20/pkg-plist
@@ -1,5 +1,6 @@
@comment $FreeBSD$
bin/bison
+bin/bison1875
bin/yacc
@unexec install-info --delete %D/info/bison.info %D/info/dir
info/bison.info