aboutsummaryrefslogtreecommitdiffstats
path: root/devel
diff options
context:
space:
mode:
authorkmoore <kmoore@FreeBSD.org>2009-05-28 00:19:33 +0800
committerkmoore <kmoore@FreeBSD.org>2009-05-28 00:19:33 +0800
commit81d89b37e116eef1fe475829576d285e4557eeae (patch)
treee58654c3bc71af58a11e98bc49bc1fa32e2b1033 /devel
parentb5de871a3df5290589674677a4eb1495604668f3 (diff)
downloadfreebsd-ports-gnome-81d89b37e116eef1fe475829576d285e4557eeae.tar.gz
freebsd-ports-gnome-81d89b37e116eef1fe475829576d285e4557eeae.tar.zst
freebsd-ports-gnome-81d89b37e116eef1fe475829576d285e4557eeae.zip
Updated devel/cmake to respect LOCALBASE when set to locations other than /usr/local
- Not bumping PORTREV since this only effects users running on a non-standard LOCALBASE Approved by: miwi (mentor)
Diffstat (limited to 'devel')
-rw-r--r--devel/cmake/Makefile8
1 files changed, 8 insertions, 0 deletions
diff --git a/devel/cmake/Makefile b/devel/cmake/Makefile
index e5d9625dc9fb..0cde16628865 100644
--- a/devel/cmake/Makefile
+++ b/devel/cmake/Makefile
@@ -37,8 +37,16 @@ MAN1= ccmake.1 \
ctest.1
post-patch:
+ @${GREP} -rl '/usr/local' ${WRKSRC}/Modules ${WRKSRC}/Tests | \
+ ${XARGS} ${REINPLACE_CMD} -e 's,/usr/local,${LOCALBASE},g'
@${GREP} -rl '/usr/X11R6' ${WRKSRC}/Modules ${WRKSRC}/Tests | \
${XARGS} ${REINPLACE_CMD} -e 's,/usr/X11R6,${LOCALBASE},g'
+ @${REINPLACE_CMD} -e 's,/usr/local,${LOCALBASE},g' \
+ ${WRKSRC}/Source/cmLocalGenerator.cxx
+ @${REINPLACE_CMD} -e 's,/usr/local,${LOCALBASE},g' \
+ ${WRKSRC}/Source/CPack/cmCPackGenerator.cxx
+ @${REINPLACE_CMD} -e 's,/usr/local,${LOCALBASE},g' \
+ ${WRKSRC}/bootstrap
@${REINPLACE_CMD} -e 's,/opt/kde4,${LOCALBASE}/kde4,g' \
${WRKSRC}/Modules/FindKDE4.cmake