aboutsummaryrefslogtreecommitdiffstats
path: root/devel
diff options
context:
space:
mode:
authormat <mat@FreeBSD.org>2016-11-03 21:37:45 +0800
committermat <mat@FreeBSD.org>2016-11-03 21:37:45 +0800
commit8352508a5099d4e2b067aa94e77e086e5337942b (patch)
treefd3453ba501bafa808978d08e28bc7f00c6e13f1 /devel
parentae0fa176f5b1a86e475935dc7af84b322420b794 (diff)
downloadfreebsd-ports-gnome-8352508a5099d4e2b067aa94e77e086e5337942b.tar.gz
freebsd-ports-gnome-8352508a5099d4e2b067aa94e77e086e5337942b.tar.zst
freebsd-ports-gnome-8352508a5099d4e2b067aa94e77e086e5337942b.zip
Mark broken with Perl 5.24+ on 9.x.
cc -c -DHAS_FPSETMASK -DHAS_FLOATINGPOINT_H -fno-strict-aliasing -pipe -fstack-protector -I/usr/local/include -D_FORTIFY_SOURCE=2 -O2 -pipe -fstack-protector -fno-strict-aliasing -DVERSION=\"0.11\" -DXS_VERSION=\"0.11\" -DPIC -fPIC "-I/usr/local/lib/perl5/5.24/mach/CORE" byterun.c In file included from byterun.c:33: byterun.h:39: error: redefinition of typedef 'I64' /usr/local/lib/perl5/5.24/mach/CORE/handy.h:178: error: previous declaration of 'I64' was here byterun.h:40: error: redefinition of typedef 'U64' /usr/local/lib/perl5/5.24/mach/CORE/handy.h:179: error: previous declaration of 'U64' was here byterun.c: In function 'byterun': byterun.c:389: warning: comparison is always false due to limited range of data type byterun.c:1436: warning: comparison is always false due to limited range of data type *** [byterun.o] Error code 1 PR: 213810 Sponsored by: Absolight
Diffstat (limited to 'devel')
-rw-r--r--devel/p5-B-C/Makefile4
1 files changed, 4 insertions, 0 deletions
diff --git a/devel/p5-B-C/Makefile b/devel/p5-B-C/Makefile
index 4a3a19465ac4..01c2fe0172bb 100644
--- a/devel/p5-B-C/Makefile
+++ b/devel/p5-B-C/Makefile
@@ -32,6 +32,10 @@ PLIST_SUB+= PERL_ARCH=${PERL_ARCH}
EXTRA_PATCHES= ${FILESDIR}/extra-patch-ByteLoader_bytecode.h
.endif
+.if ${PERL_LEVEL} >= 502400 && ${OSVERSION} < 1000054
+BROKEN= Does not build
+.endif
+
post-patch:
${REINPLACE_CMD} -e "s|PERL_INC|PERL_INC_STAGE|g" ${WRKSRC}/Makefile.PL
${MKDIR} ${PERL_INC_STAGE}