aboutsummaryrefslogtreecommitdiffstats
path: root/devel
diff options
context:
space:
mode:
authorsem <sem@FreeBSD.org>2004-08-21 18:59:35 +0800
committersem <sem@FreeBSD.org>2004-08-21 18:59:35 +0800
commit83bcfa9215d34c0f88aa8f7d71b420c28424493f (patch)
treef54852b212154cee191079104d24b06b59ed0eae /devel
parent6270666234ea07df4199447e477d7461a1765ea1 (diff)
downloadfreebsd-ports-gnome-83bcfa9215d34c0f88aa8f7d71b420c28424493f.tar.gz
freebsd-ports-gnome-83bcfa9215d34c0f88aa8f7d71b420c28424493f.tar.zst
freebsd-ports-gnome-83bcfa9215d34c0f88aa8f7d71b420c28424493f.zip
The Parse::Lex.pm module for perl5 is an object-oriented generator of
lexical analyzers. PR: ports/62936 Submitted by: Jim Pirzyk <pirzyk@uiuc.edu>
Diffstat (limited to 'devel')
-rw-r--r--devel/Makefile1
-rw-r--r--devel/p5-ParseLex/Makefile26
-rw-r--r--devel/p5-ParseLex/distinfo1
-rw-r--r--devel/p5-ParseLex/files/patch-lib-Parse-Template.pm17
-rw-r--r--devel/p5-ParseLex/files/patch-t-test4.t8
-rw-r--r--devel/p5-ParseLex/pkg-descr7
-rw-r--r--devel/p5-ParseLex/pkg-plist13
7 files changed, 73 insertions, 0 deletions
diff --git a/devel/Makefile b/devel/Makefile
index ec22e83ce1f6..3282e5119399 100644
--- a/devel/Makefile
+++ b/devel/Makefile
@@ -907,6 +907,7 @@
SUBDIR += p5-Parse-PerlConfig
SUBDIR += p5-Parse-RecDescent
SUBDIR += p5-Parse-Yapp
+ SUBDIR += p5-ParseLex
SUBDIR += p5-PatchReader
SUBDIR += p5-Path-Class
SUBDIR += p5-Penguin
diff --git a/devel/p5-ParseLex/Makefile b/devel/p5-ParseLex/Makefile
new file mode 100644
index 000000000000..e60eaeb65ea2
--- /dev/null
+++ b/devel/p5-ParseLex/Makefile
@@ -0,0 +1,26 @@
+# New ports collection makefile for: p5-ParseLex
+# Date created: 16 February 2004
+# Whom: Jim Pirzyk <pirzyk@uiuc.edu>
+#
+# $FreeBSD$
+#
+
+PORTNAME= ParseLex
+PORTVERSION= 2.15
+CATEGORIES= devel perl5
+MASTER_SITES= ${MASTER_SITE_PERL_CPAN}
+MASTER_SITE_SUBDIR= Parse
+PKGNAMEPREFIX= p5-
+
+MAINTAINER= pirzyk@freebsd.org
+COMMENT= Object-oriented generator of lexical analyzers
+
+PERL_CONFIGURE= yes
+
+MAN3PREFIX= ${PREFIX}/lib/perl5/${PERL_VERSION}
+MAN3= Parse::Lex.3 Parse::Token.3 Parse::YYLex.3 Parse::LexEvent.3 Parse::CLex.3 Parse::Template.3
+
+post-patch:
+ @${RM} ${WRKSRC}/lib/Parse/*.orig
+
+.include <bsd.port.mk>
diff --git a/devel/p5-ParseLex/distinfo b/devel/p5-ParseLex/distinfo
new file mode 100644
index 000000000000..8b87f8c33e70
--- /dev/null
+++ b/devel/p5-ParseLex/distinfo
@@ -0,0 +1 @@
+MD5 (ParseLex-2.15.tar.gz) = aeb0bb36454485d28214aad0907d5c92
diff --git a/devel/p5-ParseLex/files/patch-lib-Parse-Template.pm b/devel/p5-ParseLex/files/patch-lib-Parse-Template.pm
new file mode 100644
index 000000000000..4fa68fea4bc1
--- /dev/null
+++ b/devel/p5-ParseLex/files/patch-lib-Parse-Template.pm
@@ -0,0 +1,17 @@
+--- lib/Parse/Template.pm.orig Thu Sep 23 12:16:28 1999
++++ lib/Parse/Template.pm Fri Aug 20 16:03:23 2004
+@@ -1,4 +1,4 @@
+-use strict
++use strict;
+ require 5.004;
+ package Parse::Template;
+ $Parse::Template::VERSION = '0.32';
+@@ -132,7 +132,7 @@
+ }
+ # evaluated expressions are not always available in (caller(1))[6];
+ if (defined($1) and $1 ne '') {
+- $expr = $1; # what is the template expression?
++ my $expr = $1; # what is the template expression?
+ { package DB; # what is the part name?
+ @DB::caller = caller(2); # why is this needed? /ee?
+ @DB::caller = caller(1);
diff --git a/devel/p5-ParseLex/files/patch-t-test4.t b/devel/p5-ParseLex/files/patch-t-test4.t
new file mode 100644
index 000000000000..8bf0be513cef
--- /dev/null
+++ b/devel/p5-ParseLex/files/patch-t-test4.t
@@ -0,0 +1,8 @@
+--- t/test4.t.orig Fri Aug 20 16:06:52 2004
++++ t/test4.t Fri Aug 20 16:07:08 2004
+@@ -54,4 +54,4 @@
+ [main::lexer|Parse::CLex] Token read (NEWLINE, \n):
+
+ [main::lexer|Parse::CLex] Token read (ERROR, .*): this is an invalid string with a "" in it"
+-can't analyze: "this is an invalid string with a "" in it"" at examples/ctokenizer.pl line 17, <DATA> chunk 4.
++can't analyze: "this is an invalid string with a "" in it"" at examples/ctokenizer.pl line 17, <DATA> line 4.
diff --git a/devel/p5-ParseLex/pkg-descr b/devel/p5-ParseLex/pkg-descr
new file mode 100644
index 000000000000..a69b65e337a3
--- /dev/null
+++ b/devel/p5-ParseLex/pkg-descr
@@ -0,0 +1,7 @@
+The Parse::Lex.pm module for perl5 is an object-oriented generator of
+lexical analyzers.
+
+This distribution includes Parse::YYLex (writed by Vladimir Alexiev)
+a lexer generator that you can use with yacc parsers.
+
+WWW: http://search.cpan.org/~pverd
diff --git a/devel/p5-ParseLex/pkg-plist b/devel/p5-ParseLex/pkg-plist
new file mode 100644
index 000000000000..de2402fd546a
--- /dev/null
+++ b/devel/p5-ParseLex/pkg-plist
@@ -0,0 +1,13 @@
+%%SITE_PERL%%/Parse/Lex.pm
+%%SITE_PERL%%/Parse/ALex.pm
+%%SITE_PERL%%/Parse/LexEvent.pm
+%%SITE_PERL%%/Parse/YYLex.pm
+%%SITE_PERL%%/Parse/Template.pm
+%%SITE_PERL%%/Parse/CLex.pm
+%%SITE_PERL%%/Parse/Trace.pm
+%%SITE_PERL%%/Parse/Token.pm
+%%SITE_PERL%%/Parse/Token-t.pm
+%%SITE_PERL%%/%%PERL_ARCH%%/auto/Parse/Lex/.packlist
+@unexec rmdir %D/%%SITE_PERL%%/%%PERL_ARCH%%/auto/Parse/Lex 2>/dev/null || true
+@unexec rmdir %D/%%SITE_PERL%%/%%PERL_ARCH%%/auto/Parse 2>/dev/null || true
+@unexec rmdir %D/%%SITE_PERL%%/Parse 2>/dev/null || true