aboutsummaryrefslogtreecommitdiffstats
path: root/devel
diff options
context:
space:
mode:
authorrakuco <rakuco@FreeBSD.org>2017-10-08 02:32:18 +0800
committerrakuco <rakuco@FreeBSD.org>2017-10-08 02:32:18 +0800
commit847bd4ca8f523f3cd985327e2fde17136755f743 (patch)
treed70bb7cdb8473a0d47071f509428baab30c5e3a6 /devel
parent9c361bf1de59cbca008c0dbabe8ce34aa134d643 (diff)
downloadfreebsd-ports-gnome-847bd4ca8f523f3cd985327e2fde17136755f743.tar.gz
freebsd-ports-gnome-847bd4ca8f523f3cd985327e2fde17136755f743.tar.zst
freebsd-ports-gnome-847bd4ca8f523f3cd985327e2fde17136755f743.zip
Switch to an out-of-source CMake build.
It does not have any bad side-effects, and out-of-source builds are recommended by CMake. In this case, it also avoids ninja warnings that become errors with Ninja 1.8: ninja: warning: multiple rules generate locales/leatherman.pot. builds involving this target will not be correct; continuing anyway [-w dupbuild=warn] ninja: warning: multiple rules generate locale/locales/leatherman_locale.pot. builds involving this target will not be correct; continuing anyway [-w dupbuild=warn] ninja: warning: multiple rules generate logging/locales/leatherman_logging.pot. builds involving this target will not be correct; continuing anyway [-w dupbuild=warn] PR: 222770
Diffstat (limited to 'devel')
-rw-r--r--devel/leatherman/Makefile2
1 files changed, 1 insertions, 1 deletions
diff --git a/devel/leatherman/Makefile b/devel/leatherman/Makefile
index 335f6ed0f4f3..a729f077ed69 100644
--- a/devel/leatherman/Makefile
+++ b/devel/leatherman/Makefile
@@ -19,7 +19,7 @@ BROKEN_powerpc64= fails to compile: cc1plus: error: unrecognized command line op
USE_GITHUB= yes
GH_ACCOUNT= puppetlabs
-USES= cmake gettext
+USES= cmake:outsource gettext
USE_RUBY= yes
CMAKE_ARGS= -DLEATHERMAN_SHARED:BOOL=ON
USE_LDCONFIG= yes