aboutsummaryrefslogtreecommitdiffstats
path: root/devel
diff options
context:
space:
mode:
authorthierry <thierry@FreeBSD.org>2004-05-31 03:33:12 +0800
committerthierry <thierry@FreeBSD.org>2004-05-31 03:33:12 +0800
commit8491bd15fd7a5ff7a629100beea93cce50ed9ee8 (patch)
tree2b57d950cf2ac06afe318b0f86283c28fb129c07 /devel
parent490061a2c8230f42eec9d3ef8da48b77196c74e9 (diff)
downloadfreebsd-ports-gnome-8491bd15fd7a5ff7a629100beea93cce50ed9ee8.tar.gz
freebsd-ports-gnome-8491bd15fd7a5ff7a629100beea93cce50ed9ee8.tar.zst
freebsd-ports-gnome-8491bd15fd7a5ff7a629100beea93cce50ed9ee8.zip
- several ports require SDL with GL enabled => set GL by default;
- bump PORTREVISION; - remove the unused option X11; - fix COMMENT (1.2.7 is the stable version); - do some cleaning.
Diffstat (limited to 'devel')
-rw-r--r--devel/sdl12/Makefile20
-rw-r--r--devel/sdl12/pkg-plist2
2 files changed, 10 insertions, 12 deletions
diff --git a/devel/sdl12/Makefile b/devel/sdl12/Makefile
index a76e5539d642..bb5772bca4a9 100644
--- a/devel/sdl12/Makefile
+++ b/devel/sdl12/Makefile
@@ -7,14 +7,14 @@
PORTNAME= sdl
PORTVERSION= 1.2.7
-PORTREVISION= 1
+PORTREVISION= 2
PORTEPOCH= 1
CATEGORIES= devel
MASTER_SITES= http://www.libsdl.org/release/
DISTNAME= SDL-${PORTVERSION}
MAINTAINER= ports@FreeBSD.org
-COMMENT= Cross-platform multi-media development API (developm. vers.)
+COMMENT= Cross-platform multi-media development API
LIB_DEPENDS= aa.1:${PORTSDIR}/graphics/aalib
BUILD_DEPENDS= nasm:${PORTSDIR}/devel/nasm
@@ -27,19 +27,20 @@ CONFIGURE_ENV= NASM="${LOCALBASE}/bin/nasm" \
PTHREAD_CFLAGS="${PTHREAD_CFLAGS}" \
PTHREAD_LIBS="${PTHREAD_LIBS}" \
LDFLAGS="${LDFLAGS}"
-CONFIGURE_ARGS= --enable-video-aalib \
- --target=
+CONFIGURE_ARGS= --enable-video-aalib
+CONFIGURE_TARGET= --build=${MACHINE_ARCH}-portbld-freebsd${OSREL}
CFLAGS+= ${PTHREAD_CFLAGS} -I${LOCALBASE}/include
LDFLAGS+= -L${LOCALBASE}/lib
+USE_XLIB= yes
+
.if !defined(NOPORTDOCS)
PORTDOCS= *
.endif
OPTIONS= NAS "Include support for the Network Audio System" Off \
- X11 "Include support for X11" On \
- GL "Include support for OpenGL" Off
+ GL "Include support for OpenGL" On
.include <bsd.port.pre.mk>
@@ -48,7 +49,7 @@ CONFIGURE_ARGS+=--enable-video-vgl
DISPLAY_MSG= ${CAT} ${PKGMESSAGE}
.else
CONFIGURE_ARGS+=--disable-video-vgl
-PKGMESSAGE= /I/hate/ports/Mk/bsd.port.mk
+PKGMESSAGE= none
DISPLAY_MSG= ${DO_NADA}
.endif
@@ -58,10 +59,7 @@ LIB_DEPENDS+= audio.2:${PORTSDIR}/audio/nas
CONFIGURE_ARGS+=--disable-nas
.endif
-.if defined(WITH_X11)
-USE_XLIB= yes
-.endif
-.if !defined(WITH_GL)
+.if defined(WITHOUT_GL)
CONFIGURE_ARGS+=--disable-video-opengl
.else
USE_GL= yes
diff --git a/devel/sdl12/pkg-plist b/devel/sdl12/pkg-plist
index 5cb052b5e40e..d561035aff90 100644
--- a/devel/sdl12/pkg-plist
+++ b/devel/sdl12/pkg-plist
@@ -84,4 +84,4 @@ share/aclocal/sdl11.m4
%%EXAMPLESDIR%%/threadwin.c
%%EXAMPLESDIR%%/torturethread.c
@dirrm %%EXAMPLESDIR%%
-@dirrm include/SDL11
+@unexec rmdir %D/include/SDL11 2>/dev/null || true