aboutsummaryrefslogtreecommitdiffstats
path: root/devel
diff options
context:
space:
mode:
authorale <ale@FreeBSD.org>2016-10-31 17:27:23 +0800
committerale <ale@FreeBSD.org>2016-10-31 17:27:23 +0800
commit87932755f32076cd38444c6c9c7fd4554329c835 (patch)
tree7a35f3cd985476391c1bdbca7c6b2735e63a51ef /devel
parent45c6b1041fef0e9f34a1e89b72e3335bb7e76f54 (diff)
downloadfreebsd-ports-gnome-87932755f32076cd38444c6c9c7fd4554329c835.tar.gz
freebsd-ports-gnome-87932755f32076cd38444c6c9c7fd4554329c835.tar.zst
freebsd-ports-gnome-87932755f32076cd38444c6c9c7fd4554329c835.zip
Update to 0.13.13 release.
PR: 213913 Submitted by: jhyphenkeck@gmail.com
Diffstat (limited to 'devel')
-rw-r--r--devel/sbt/Makefile9
-rw-r--r--devel/sbt/distinfo5
-rw-r--r--devel/sbt/files/patch-bin_sbt12
-rw-r--r--devel/sbt/files/patch-bin_sbt-launch-lib.bash6
4 files changed, 15 insertions, 17 deletions
diff --git a/devel/sbt/Makefile b/devel/sbt/Makefile
index 854064639b99..c0d13ac86b19 100644
--- a/devel/sbt/Makefile
+++ b/devel/sbt/Makefile
@@ -2,7 +2,7 @@
# $FreeBSD$
PORTNAME= sbt
-PORTVERSION= 0.13.11
+PORTVERSION= 0.13.13
CATEGORIES= devel java
MASTER_SITES= http://dl.bintray.com/sbt/native-packages/sbt/${PORTVERSION}/
@@ -17,8 +17,9 @@ ADVANCED_DESC= Install advanced bash shell-script
USES= tar:tgz
NO_BUILD= yes
+NO_ARCH= yes
USE_JAVA= yes
-WRKSRC= ${WRKDIR}/${PORTNAME}
+WRKSRC= ${WRKDIR}/${PORTNAME}-launcher-packaging-${PORTVERSION}
PLIST_FILES= bin/sbt \
%%DATADIR%%/sbt-launch.jar
@@ -34,10 +35,6 @@ PLIST_FILES+= %%DATADIR%%/sbt \
SUB_FILES= sbt.sh
.endif
-post-patch:
- @${REINPLACE_CMD} "s|%%PREFIX%%|${PREFIX}|g" \
- ${WRKSRC}/bin/sbt
-
do-install:
${MKDIR} ${STAGEDIR}${DATADIR}
${INSTALL_DATA} ${WRKSRC}/bin/sbt-launch.jar ${STAGEDIR}${DATADIR}
diff --git a/devel/sbt/distinfo b/devel/sbt/distinfo
index 6fad34c4e21a..f971a0f0f512 100644
--- a/devel/sbt/distinfo
+++ b/devel/sbt/distinfo
@@ -1,2 +1,3 @@
-SHA256 (sbt-0.13.11.tgz) = a36a6fbf6dd70afd93fb8db16c40e8ac00798fdddfa0b4c678786dc15617afa6
-SIZE (sbt-0.13.11.tgz) = 1049516
+TIMESTAMP = 1477900389
+SHA256 (sbt-0.13.13.tgz) = 40d03d21a260c5a6a43f8349298f41c9d047f97972057d9d915afd8945faf979
+SIZE (sbt-0.13.13.tgz) = 1049906
diff --git a/devel/sbt/files/patch-bin_sbt b/devel/sbt/files/patch-bin_sbt
index eacecfefbbd3..a89c35c970d9 100644
--- a/devel/sbt/files/patch-bin_sbt
+++ b/devel/sbt/files/patch-bin_sbt
@@ -1,6 +1,6 @@
---- bin/sbt.orig 2013-08-28 10:14:39.000000000 +0200
-+++ bin/sbt 2013-08-28 10:16:02.000000000 +0200
-@@ -63,7 +63,7 @@
+--- bin/sbt.orig 2016-10-28 17:46:00 UTC
++++ bin/sbt
+@@ -62,7 +62,7 @@ cygwinpath() {
declare -r noshare_opts="-Dsbt.global.base=project/.sbtboot -Dsbt.boot.directory=project/.boot -Dsbt.ivy.home=project/.ivy"
declare -r sbt_opts_file=".sbtopts"
@@ -9,10 +9,10 @@
declare -r win_sbt_opts_file="${sbt_home}/conf/sbtconfig.txt"
usage() {
-@@ -98,7 +98,7 @@
+@@ -99,7 +99,7 @@ Usage: $script_name [options]
SBT_OPTS environment variable, if unset uses "$default_sbt_opts"
- .sbtopts if this file exists in the current directory, it is
- prepended to the runner args
+ .sbtopts if this file exists in the current directory, its contents
+ are prepended to the runner args
- /etc/sbt/sbtopts if this file exists, it is prepended to the runner args
+ ${sbt_home}/etc/sbtopts if this file exists, it is prepended to the runner args
-Dkey=val pass -Dkey=val directly to the java runtime
diff --git a/devel/sbt/files/patch-bin_sbt-launch-lib.bash b/devel/sbt/files/patch-bin_sbt-launch-lib.bash
index fc90ed82b447..0493e7ae53df 100644
--- a/devel/sbt/files/patch-bin_sbt-launch-lib.bash
+++ b/devel/sbt/files/patch-bin_sbt-launch-lib.bash
@@ -1,6 +1,6 @@
---- bin/sbt-launch-lib.bash.orig 2013-08-28 10:14:44.000000000 +0200
-+++ bin/sbt-launch-lib.bash 2013-08-28 10:20:01.000000000 +0200
-@@ -31,7 +31,7 @@
+--- bin/sbt-launch-lib.bash.orig 2016-10-28 17:46:00 UTC
++++ bin/sbt-launch-lib.bash
+@@ -26,7 +26,7 @@ dlog () {
}
jar_file () {