aboutsummaryrefslogtreecommitdiffstats
path: root/devel
diff options
context:
space:
mode:
authorpav <pav@FreeBSD.org>2005-09-04 20:33:50 +0800
committerpav <pav@FreeBSD.org>2005-09-04 20:33:50 +0800
commit8cb7ff21c13e60352efd387c3202735bfeebbb27 (patch)
tree24f6c2c104adc29b39aa97630396442957e549c8 /devel
parentbeff558d3f17a4fbc1eec3de59ab1847d58b6b67 (diff)
downloadfreebsd-ports-gnome-8cb7ff21c13e60352efd387c3202735bfeebbb27.tar.gz
freebsd-ports-gnome-8cb7ff21c13e60352efd387c3202735bfeebbb27.tar.zst
freebsd-ports-gnome-8cb7ff21c13e60352efd387c3202735bfeebbb27.zip
- Unbreak on FreeBSD 5 and newer
PR: ports/85034 Submitted by: Vasil Dimov <vd@datamax.bg> Approved by: maintainer timeout (18 days)
Diffstat (limited to 'devel')
-rw-r--r--devel/swigruby/Makefile4
-rw-r--r--devel/swigruby/files/patch-ruby.cxx25
2 files changed, 21 insertions, 8 deletions
diff --git a/devel/swigruby/Makefile b/devel/swigruby/Makefile
index 07706b985f92..c068721ddcd5 100644
--- a/devel/swigruby/Makefile
+++ b/devel/swigruby/Makefile
@@ -27,10 +27,6 @@ DOCS_JA= README.ja
.include <bsd.port.pre.mk>
-.if ${OSVERSION} >= 501000
-BROKEN= "Does not compile"
-.endif
-
do-configure:
@cd ${WRKSRC}; \
${SETENV} ${CONFIGURE_ENV} ${RUBY} configure.rb --with-swig=swig1.1
diff --git a/devel/swigruby/files/patch-ruby.cxx b/devel/swigruby/files/patch-ruby.cxx
index 93e75bfbec58..367078e70a74 100644
--- a/devel/swigruby/files/patch-ruby.cxx
+++ b/devel/swigruby/files/patch-ruby.cxx
@@ -1,12 +1,29 @@
---- ruby.cxx.orig Thu May 25 01:18:29 2000
-+++ ruby.cxx Fri Nov 8 03:05:43 2002
-@@ -840,3 +840,3 @@
+--- ruby.cxx.orig Wed May 24 19:18:29 2000
++++ ruby.cxx Wed Aug 17 11:08:17 2005
+@@ -24,7 +24,7 @@
+
+ static char *extconf_rb = "\
+ require 'mkmf'\n\
+-
++\
+ #%ext%_dir = with_config('%ext%-dir')\n\
+ #%ext%_include_dir = %ext%_dir + '/include' if %ext%_dir\n\
+ #%ext%_include_dir = with_config('%ext%-include-dir', %ext%_include_dir)\n\
+@@ -838,7 +838,7 @@
+ // target = a string containing the target value
+ // f = a wrapper function object (optional)
// ---------------------------------------------------------------------
-char *RUBY::ruby_typemap_lookup(char *op, DataType *type, char *pname, char *source, char *target, WrapperFunction *f = 0) {
+char *RUBY::ruby_typemap_lookup(char *op, DataType *type, char *pname, char *source, char *target, WrapperFunction *f) {
static String s;
-@@ -903,3 +903,3 @@
+ char *tm;
+ String target_replace = target;
+@@ -901,7 +901,7 @@
+ // value = C value (as a string)
+ // raw = value is raw string (not quoted) ?
// ---------------------------------------------------------------------
-char *RUBY::to_VALUE(DataType *type, char *value, int raw = 0) {
+char *RUBY::to_VALUE(DataType *type, char *value, int raw) {
static String str;
+
+ str = "";