aboutsummaryrefslogtreecommitdiffstats
path: root/devel
diff options
context:
space:
mode:
authoramdmi3 <amdmi3@FreeBSD.org>2009-07-15 21:47:51 +0800
committeramdmi3 <amdmi3@FreeBSD.org>2009-07-15 21:47:51 +0800
commit8ceee93d95685f0c18eb020a38555a63bfb34d67 (patch)
tree16cec96d95a6dead3ad14e7d3650914065d9f1be /devel
parent95f3b494f005f6743cb9a86042c850797d1d2b2d (diff)
downloadfreebsd-ports-gnome-8ceee93d95685f0c18eb020a38555a63bfb34d67.tar.gz
freebsd-ports-gnome-8ceee93d95685f0c18eb020a38555a63bfb34d67.tar.zst
freebsd-ports-gnome-8ceee93d95685f0c18eb020a38555a63bfb34d67.zip
This module does the same thing as msgfmt from GNU gettext-tools,
except this is pure Perl. WWW: http://search.cpan.org/dist/Locale-Msgfmt/ PR: 136699 Submitted by: Cezary Morga <cm@therek.net>
Diffstat (limited to 'devel')
-rw-r--r--devel/Makefile1
-rw-r--r--devel/p5-Locale-Msgfmt/Makefile25
-rw-r--r--devel/p5-Locale-Msgfmt/distinfo3
-rw-r--r--devel/p5-Locale-Msgfmt/pkg-descr4
-rw-r--r--devel/p5-Locale-Msgfmt/pkg-plist13
5 files changed, 46 insertions, 0 deletions
diff --git a/devel/Makefile b/devel/Makefile
index 8c5b85bf3c82..9ed0dbf2aad2 100644
--- a/devel/Makefile
+++ b/devel/Makefile
@@ -1540,6 +1540,7 @@
SUBDIR += p5-Locale-Maketext-Gettext
SUBDIR += p5-Locale-Maketext-Lexicon
SUBDIR += p5-Locale-Maketext-Simple
+ SUBDIR += p5-Locale-Msgfmt
SUBDIR += p5-Locale-PGetText
SUBDIR += p5-Locale-PO
SUBDIR += p5-Locale-gettext
diff --git a/devel/p5-Locale-Msgfmt/Makefile b/devel/p5-Locale-Msgfmt/Makefile
new file mode 100644
index 000000000000..f056cafbb910
--- /dev/null
+++ b/devel/p5-Locale-Msgfmt/Makefile
@@ -0,0 +1,25 @@
+# New ports collection makefile for: p5-Locale-Msgfmt
+# Date created: July 12th 2009
+# Whom: Cezary Morga <cm@therek.net>
+#
+# $FreeBSD$
+#
+
+PORTNAME= Locale-Msgfmt
+PORTVERSION= 0.14
+CATEGORIES= devel perl5
+MASTER_SITES= CPAN
+PKGNAMEPREFIX= p5-
+
+MAINTAINER= cm@therek.net
+COMMENT= Compile .po files to .mo files
+
+PERL_CONFIGURE= yes
+
+MAN1= msgfmt.pl.1
+MAN3= Locale::Msgfmt::Utils.3 \
+ Locale::Msgfmt::mo.3 \
+ Locale::Msgfmt::po.3 \
+ Locale::Msgfmt.3
+
+.include <bsd.port.mk>
diff --git a/devel/p5-Locale-Msgfmt/distinfo b/devel/p5-Locale-Msgfmt/distinfo
new file mode 100644
index 000000000000..d81b47d129d6
--- /dev/null
+++ b/devel/p5-Locale-Msgfmt/distinfo
@@ -0,0 +1,3 @@
+MD5 (Locale-Msgfmt-0.14.tar.gz) = 2fd04fc47a8cff9e2c565d79a1b42599
+SHA256 (Locale-Msgfmt-0.14.tar.gz) = 534992881fc2be558050291e458093b6ba782f7f46bb1bd6b0000780d4dfc7d8
+SIZE (Locale-Msgfmt-0.14.tar.gz) = 30765
diff --git a/devel/p5-Locale-Msgfmt/pkg-descr b/devel/p5-Locale-Msgfmt/pkg-descr
new file mode 100644
index 000000000000..18d98eda2d2b
--- /dev/null
+++ b/devel/p5-Locale-Msgfmt/pkg-descr
@@ -0,0 +1,4 @@
+This module does the same thing as msgfmt from GNU gettext-tools,
+except this is pure Perl.
+
+WWW: http://search.cpan.org/dist/Locale-Msgfmt/
diff --git a/devel/p5-Locale-Msgfmt/pkg-plist b/devel/p5-Locale-Msgfmt/pkg-plist
new file mode 100644
index 000000000000..057c204dbc53
--- /dev/null
+++ b/devel/p5-Locale-Msgfmt/pkg-plist
@@ -0,0 +1,13 @@
+bin/msgfmt.pl
+%%SITE_PERL%%/Locale/Msgfmt/po.pm
+%%SITE_PERL%%/Locale/Msgfmt/Utils.pm
+%%SITE_PERL%%/Locale/Msgfmt/mo.pm
+%%SITE_PERL%%/Locale/Msgfmt.pm
+%%SITE_PERL%%/Module/Install/Msgfmt.pm
+%%SITE_PERL%%/%%PERL_ARCH%%/auto/Locale/Msgfmt/.packlist
+@dirrmtry %%SITE_PERL%%/%%PERL_ARCH%%/auto/Locale/Msgfmt
+@dirrmtry %%SITE_PERL%%/%%PERL_ARCH%%/auto/Locale
+@dirrmtry %%SITE_PERL%%/Locale/Msgfmt
+@dirrmtry %%SITE_PERL%%/Locale
+@dirrmtry %%SITE_PERL%%/Module/Install
+@dirrmtry %%SITE_PERL%%/Module