aboutsummaryrefslogtreecommitdiffstats
path: root/devel
diff options
context:
space:
mode:
authorbmah <bmah@FreeBSD.org>2003-06-28 05:03:40 +0800
committerbmah <bmah@FreeBSD.org>2003-06-28 05:03:40 +0800
commit8e89ee97af79075b5ebf52d1b982a5fdb39cd884 (patch)
treed9cd2e4e0b966e55b622731ec634ac971d1ac4e3 /devel
parent31038b40aef816c0121509f6d308761ac8fa807f (diff)
downloadfreebsd-ports-gnome-8e89ee97af79075b5ebf52d1b982a5fdb39cd884.tar.gz
freebsd-ports-gnome-8e89ee97af79075b5ebf52d1b982a5fdb39cd884.tar.zst
freebsd-ports-gnome-8e89ee97af79075b5ebf52d1b982a5fdb39cd884.zip
Link the subversion binaries against the Apache 2.X installed
version of APR if WITH_APACHE2_APR is defined. This is also implied by WITH_MOD_DAV_SVN. I noticed some problems in testing WITH_APACHE2_APR in that the subversion binaries would somehow be linked by the runtime linker against APR from the devel/apr port if the latter was installed. Mention this potential problem at portbuild time, although this should be handled better than it is. PORTREVISION bump. Based on part of the patch from the PR mentioned below. PR: 53190 Submitted by: Chia-liang Kao <clkao@alcatraz.elixus.org>
Diffstat (limited to 'devel')
-rw-r--r--devel/subversion-devel/Makefile41
-rw-r--r--devel/subversion-freebsd/Makefile41
-rw-r--r--devel/subversion/Makefile41
-rw-r--r--devel/subversion16/Makefile41
4 files changed, 124 insertions, 40 deletions
diff --git a/devel/subversion-devel/Makefile b/devel/subversion-devel/Makefile
index c6440acf1e31..3a73dfc110d2 100644
--- a/devel/subversion-devel/Makefile
+++ b/devel/subversion-devel/Makefile
@@ -6,6 +6,7 @@
PORTNAME= subversion
PORTVERSION= 0.24.2
+PORTREVISION= 1
CATEGORIES= devel
MASTER_SITES= http://subversion.tigris.org/files/documents/15/4807/
MASTER_SITES+= ${MASTER_SITE_LOCAL}
@@ -16,8 +17,7 @@ COMMENT= Version control system
LIB_DEPENDS= db4:${PORTSDIR}/databases/db4 \
neon.23:${PORTSDIR}/www/neon \
- expat.4:${PORTSDIR}/textproc/expat2 \
- apr-0.9:${PORTSDIR}/devel/apr
+ expat.4:${PORTSDIR}/textproc/expat2
INSTALLS_SHLIB= yes
@@ -28,17 +28,15 @@ CONFIGURE_TARGET= --build=${MACHINE_ARCH}-portbld-freebsd${OSREL}
CONFIGURE_ARGS= --with-ssl \
--with-neon=${LOCALBASE} \
--with-berkeley-db=${LOCALBASE}/include/db4:${LOCALBASE}/lib \
- --with-apr=${LOCALBASE} \
- --with-apr-util=${LOCALBASE} \
--with-swig=no
MAN1= svn.1 svnadmin.1
MANCOMPRESSED= no
-.if defined(WITH_MOD_DAV_SVN)
APXS=${LOCALBASE}/sbin/apxs
-BUILD_DEPENDS+= ${APXS}:${PORTSDIR}/www/apache2
-RUN_DEPENDS+= ${APXS}:${PORTSDIR}/www/apache2
+
+.if defined(WITH_MOD_DAV_SVN)
+WITH_APACHE2_APR= yes
CONFIGURE_ARGS+= \
--with-apxs=${APXS}
PLIST_SUB+= MOD_DAV_SVN=""
@@ -47,13 +45,36 @@ PLIST_SUB+= MOD_DAV_SVN="@comment "
PKGDEINSTALL= NONEXISTENT
.endif
+.if defined(WITH_APACHE2_APR)
+APACHE2_PORT?= ${PORTSDIR}/www/apache2
+BUILD_DEPENDS+= ${APXS}:${APACHE2_PORT}
+RUN_DEPENDS+= ${APXS}:${APACHE2_PORT}
+CONFIGURE_ARGS+=--with-apr=${LOCALBASE}/lib/apache2/apr-config \
+ --with-apr-util=${LOCALBASE}/lib/apache2/apu-config
+.else
+LIB_DEPENDS+= apr-0.9:${PORTSDIR}/devel/apr
+CONFIGURE_ARGS+=--with-apr=${LOCALBASE} \
+ --with-apr-util=${LOCALBASE}
+.endif
+
pre-extract:
-.if !defined(WITH_MOD_DAV_SVN)
- @${ECHO_MSG}
+.if defined(WITH_MOD_DAV_SVN)
+ @${ECHO_MSG} "mod_dav_svn module for Apache 2.X enabled."
+.else
@${ECHO_MSG} "You can enable the mod_dav_svn module for Apache 2.X"
- @${ECHO_MSG} "by defining WITH_MOD_DAV_SVN."
+ @${ECHO_MSG} "by defining WITH_MOD_DAV_SVN. This option implies
+ @${ECHO_MSG} "the WITH_APACHE2_APR option."
+.endif
@${ECHO_MSG}
+.if defined(WITH_APACHE2_APR)
+ @${ECHO_MSG} "Using APR from www/apache2. If you have the devel/apr"
+ @${ECHO_MSG} "port/package installed, you may need to remove it."
+else
+ @${ECHO_MSG} "You can link subversion against the APR built with"
+ @${ECHO_MSG} "the www/apache2 port, rather than the devel/apr port,"
+ @${ECHO_MSG} "by defining WITH_APACHE2_APR."
.endif
+ @${ECHO_MSG}
post-extract:
@${REINPLACE_CMD} 's/ldb/ldb4/g' ${WRKSRC}/configure
diff --git a/devel/subversion-freebsd/Makefile b/devel/subversion-freebsd/Makefile
index c6440acf1e31..3a73dfc110d2 100644
--- a/devel/subversion-freebsd/Makefile
+++ b/devel/subversion-freebsd/Makefile
@@ -6,6 +6,7 @@
PORTNAME= subversion
PORTVERSION= 0.24.2
+PORTREVISION= 1
CATEGORIES= devel
MASTER_SITES= http://subversion.tigris.org/files/documents/15/4807/
MASTER_SITES+= ${MASTER_SITE_LOCAL}
@@ -16,8 +17,7 @@ COMMENT= Version control system
LIB_DEPENDS= db4:${PORTSDIR}/databases/db4 \
neon.23:${PORTSDIR}/www/neon \
- expat.4:${PORTSDIR}/textproc/expat2 \
- apr-0.9:${PORTSDIR}/devel/apr
+ expat.4:${PORTSDIR}/textproc/expat2
INSTALLS_SHLIB= yes
@@ -28,17 +28,15 @@ CONFIGURE_TARGET= --build=${MACHINE_ARCH}-portbld-freebsd${OSREL}
CONFIGURE_ARGS= --with-ssl \
--with-neon=${LOCALBASE} \
--with-berkeley-db=${LOCALBASE}/include/db4:${LOCALBASE}/lib \
- --with-apr=${LOCALBASE} \
- --with-apr-util=${LOCALBASE} \
--with-swig=no
MAN1= svn.1 svnadmin.1
MANCOMPRESSED= no
-.if defined(WITH_MOD_DAV_SVN)
APXS=${LOCALBASE}/sbin/apxs
-BUILD_DEPENDS+= ${APXS}:${PORTSDIR}/www/apache2
-RUN_DEPENDS+= ${APXS}:${PORTSDIR}/www/apache2
+
+.if defined(WITH_MOD_DAV_SVN)
+WITH_APACHE2_APR= yes
CONFIGURE_ARGS+= \
--with-apxs=${APXS}
PLIST_SUB+= MOD_DAV_SVN=""
@@ -47,13 +45,36 @@ PLIST_SUB+= MOD_DAV_SVN="@comment "
PKGDEINSTALL= NONEXISTENT
.endif
+.if defined(WITH_APACHE2_APR)
+APACHE2_PORT?= ${PORTSDIR}/www/apache2
+BUILD_DEPENDS+= ${APXS}:${APACHE2_PORT}
+RUN_DEPENDS+= ${APXS}:${APACHE2_PORT}
+CONFIGURE_ARGS+=--with-apr=${LOCALBASE}/lib/apache2/apr-config \
+ --with-apr-util=${LOCALBASE}/lib/apache2/apu-config
+.else
+LIB_DEPENDS+= apr-0.9:${PORTSDIR}/devel/apr
+CONFIGURE_ARGS+=--with-apr=${LOCALBASE} \
+ --with-apr-util=${LOCALBASE}
+.endif
+
pre-extract:
-.if !defined(WITH_MOD_DAV_SVN)
- @${ECHO_MSG}
+.if defined(WITH_MOD_DAV_SVN)
+ @${ECHO_MSG} "mod_dav_svn module for Apache 2.X enabled."
+.else
@${ECHO_MSG} "You can enable the mod_dav_svn module for Apache 2.X"
- @${ECHO_MSG} "by defining WITH_MOD_DAV_SVN."
+ @${ECHO_MSG} "by defining WITH_MOD_DAV_SVN. This option implies
+ @${ECHO_MSG} "the WITH_APACHE2_APR option."
+.endif
@${ECHO_MSG}
+.if defined(WITH_APACHE2_APR)
+ @${ECHO_MSG} "Using APR from www/apache2. If you have the devel/apr"
+ @${ECHO_MSG} "port/package installed, you may need to remove it."
+else
+ @${ECHO_MSG} "You can link subversion against the APR built with"
+ @${ECHO_MSG} "the www/apache2 port, rather than the devel/apr port,"
+ @${ECHO_MSG} "by defining WITH_APACHE2_APR."
.endif
+ @${ECHO_MSG}
post-extract:
@${REINPLACE_CMD} 's/ldb/ldb4/g' ${WRKSRC}/configure
diff --git a/devel/subversion/Makefile b/devel/subversion/Makefile
index c6440acf1e31..3a73dfc110d2 100644
--- a/devel/subversion/Makefile
+++ b/devel/subversion/Makefile
@@ -6,6 +6,7 @@
PORTNAME= subversion
PORTVERSION= 0.24.2
+PORTREVISION= 1
CATEGORIES= devel
MASTER_SITES= http://subversion.tigris.org/files/documents/15/4807/
MASTER_SITES+= ${MASTER_SITE_LOCAL}
@@ -16,8 +17,7 @@ COMMENT= Version control system
LIB_DEPENDS= db4:${PORTSDIR}/databases/db4 \
neon.23:${PORTSDIR}/www/neon \
- expat.4:${PORTSDIR}/textproc/expat2 \
- apr-0.9:${PORTSDIR}/devel/apr
+ expat.4:${PORTSDIR}/textproc/expat2
INSTALLS_SHLIB= yes
@@ -28,17 +28,15 @@ CONFIGURE_TARGET= --build=${MACHINE_ARCH}-portbld-freebsd${OSREL}
CONFIGURE_ARGS= --with-ssl \
--with-neon=${LOCALBASE} \
--with-berkeley-db=${LOCALBASE}/include/db4:${LOCALBASE}/lib \
- --with-apr=${LOCALBASE} \
- --with-apr-util=${LOCALBASE} \
--with-swig=no
MAN1= svn.1 svnadmin.1
MANCOMPRESSED= no
-.if defined(WITH_MOD_DAV_SVN)
APXS=${LOCALBASE}/sbin/apxs
-BUILD_DEPENDS+= ${APXS}:${PORTSDIR}/www/apache2
-RUN_DEPENDS+= ${APXS}:${PORTSDIR}/www/apache2
+
+.if defined(WITH_MOD_DAV_SVN)
+WITH_APACHE2_APR= yes
CONFIGURE_ARGS+= \
--with-apxs=${APXS}
PLIST_SUB+= MOD_DAV_SVN=""
@@ -47,13 +45,36 @@ PLIST_SUB+= MOD_DAV_SVN="@comment "
PKGDEINSTALL= NONEXISTENT
.endif
+.if defined(WITH_APACHE2_APR)
+APACHE2_PORT?= ${PORTSDIR}/www/apache2
+BUILD_DEPENDS+= ${APXS}:${APACHE2_PORT}
+RUN_DEPENDS+= ${APXS}:${APACHE2_PORT}
+CONFIGURE_ARGS+=--with-apr=${LOCALBASE}/lib/apache2/apr-config \
+ --with-apr-util=${LOCALBASE}/lib/apache2/apu-config
+.else
+LIB_DEPENDS+= apr-0.9:${PORTSDIR}/devel/apr
+CONFIGURE_ARGS+=--with-apr=${LOCALBASE} \
+ --with-apr-util=${LOCALBASE}
+.endif
+
pre-extract:
-.if !defined(WITH_MOD_DAV_SVN)
- @${ECHO_MSG}
+.if defined(WITH_MOD_DAV_SVN)
+ @${ECHO_MSG} "mod_dav_svn module for Apache 2.X enabled."
+.else
@${ECHO_MSG} "You can enable the mod_dav_svn module for Apache 2.X"
- @${ECHO_MSG} "by defining WITH_MOD_DAV_SVN."
+ @${ECHO_MSG} "by defining WITH_MOD_DAV_SVN. This option implies
+ @${ECHO_MSG} "the WITH_APACHE2_APR option."
+.endif
@${ECHO_MSG}
+.if defined(WITH_APACHE2_APR)
+ @${ECHO_MSG} "Using APR from www/apache2. If you have the devel/apr"
+ @${ECHO_MSG} "port/package installed, you may need to remove it."
+else
+ @${ECHO_MSG} "You can link subversion against the APR built with"
+ @${ECHO_MSG} "the www/apache2 port, rather than the devel/apr port,"
+ @${ECHO_MSG} "by defining WITH_APACHE2_APR."
.endif
+ @${ECHO_MSG}
post-extract:
@${REINPLACE_CMD} 's/ldb/ldb4/g' ${WRKSRC}/configure
diff --git a/devel/subversion16/Makefile b/devel/subversion16/Makefile
index c6440acf1e31..3a73dfc110d2 100644
--- a/devel/subversion16/Makefile
+++ b/devel/subversion16/Makefile
@@ -6,6 +6,7 @@
PORTNAME= subversion
PORTVERSION= 0.24.2
+PORTREVISION= 1
CATEGORIES= devel
MASTER_SITES= http://subversion.tigris.org/files/documents/15/4807/
MASTER_SITES+= ${MASTER_SITE_LOCAL}
@@ -16,8 +17,7 @@ COMMENT= Version control system
LIB_DEPENDS= db4:${PORTSDIR}/databases/db4 \
neon.23:${PORTSDIR}/www/neon \
- expat.4:${PORTSDIR}/textproc/expat2 \
- apr-0.9:${PORTSDIR}/devel/apr
+ expat.4:${PORTSDIR}/textproc/expat2
INSTALLS_SHLIB= yes
@@ -28,17 +28,15 @@ CONFIGURE_TARGET= --build=${MACHINE_ARCH}-portbld-freebsd${OSREL}
CONFIGURE_ARGS= --with-ssl \
--with-neon=${LOCALBASE} \
--with-berkeley-db=${LOCALBASE}/include/db4:${LOCALBASE}/lib \
- --with-apr=${LOCALBASE} \
- --with-apr-util=${LOCALBASE} \
--with-swig=no
MAN1= svn.1 svnadmin.1
MANCOMPRESSED= no
-.if defined(WITH_MOD_DAV_SVN)
APXS=${LOCALBASE}/sbin/apxs
-BUILD_DEPENDS+= ${APXS}:${PORTSDIR}/www/apache2
-RUN_DEPENDS+= ${APXS}:${PORTSDIR}/www/apache2
+
+.if defined(WITH_MOD_DAV_SVN)
+WITH_APACHE2_APR= yes
CONFIGURE_ARGS+= \
--with-apxs=${APXS}
PLIST_SUB+= MOD_DAV_SVN=""
@@ -47,13 +45,36 @@ PLIST_SUB+= MOD_DAV_SVN="@comment "
PKGDEINSTALL= NONEXISTENT
.endif
+.if defined(WITH_APACHE2_APR)
+APACHE2_PORT?= ${PORTSDIR}/www/apache2
+BUILD_DEPENDS+= ${APXS}:${APACHE2_PORT}
+RUN_DEPENDS+= ${APXS}:${APACHE2_PORT}
+CONFIGURE_ARGS+=--with-apr=${LOCALBASE}/lib/apache2/apr-config \
+ --with-apr-util=${LOCALBASE}/lib/apache2/apu-config
+.else
+LIB_DEPENDS+= apr-0.9:${PORTSDIR}/devel/apr
+CONFIGURE_ARGS+=--with-apr=${LOCALBASE} \
+ --with-apr-util=${LOCALBASE}
+.endif
+
pre-extract:
-.if !defined(WITH_MOD_DAV_SVN)
- @${ECHO_MSG}
+.if defined(WITH_MOD_DAV_SVN)
+ @${ECHO_MSG} "mod_dav_svn module for Apache 2.X enabled."
+.else
@${ECHO_MSG} "You can enable the mod_dav_svn module for Apache 2.X"
- @${ECHO_MSG} "by defining WITH_MOD_DAV_SVN."
+ @${ECHO_MSG} "by defining WITH_MOD_DAV_SVN. This option implies
+ @${ECHO_MSG} "the WITH_APACHE2_APR option."
+.endif
@${ECHO_MSG}
+.if defined(WITH_APACHE2_APR)
+ @${ECHO_MSG} "Using APR from www/apache2. If you have the devel/apr"
+ @${ECHO_MSG} "port/package installed, you may need to remove it."
+else
+ @${ECHO_MSG} "You can link subversion against the APR built with"
+ @${ECHO_MSG} "the www/apache2 port, rather than the devel/apr port,"
+ @${ECHO_MSG} "by defining WITH_APACHE2_APR."
.endif
+ @${ECHO_MSG}
post-extract:
@${REINPLACE_CMD} 's/ldb/ldb4/g' ${WRKSRC}/configure