aboutsummaryrefslogtreecommitdiffstats
path: root/devel
diff options
context:
space:
mode:
authorAlexey Dokuchaev <danfe@FreeBSD.org>2014-09-07 22:15:05 +0800
committerAlexey Dokuchaev <danfe@FreeBSD.org>2014-09-07 22:15:05 +0800
commit9075d2d477ac6b51dd9217f3a47e3a12252e6521 (patch)
treefea3f8e89ac6c1a1410a69750e109c41473f0343 /devel
parentfc099a9581cddedd58d14c07ce64cdebfb466cdb (diff)
downloadfreebsd-ports-gnome-9075d2d477ac6b51dd9217f3a47e3a12252e6521.tar.gz
freebsd-ports-gnome-9075d2d477ac6b51dd9217f3a47e3a12252e6521.tar.zst
freebsd-ports-gnome-9075d2d477ac6b51dd9217f3a47e3a12252e6521.zip
Stagify the port properly: previously, binaries would embed ${STAGEDIR}
references in them.
Diffstat (limited to 'devel')
-rw-r--r--devel/plan9port/Makefile4
1 files changed, 3 insertions, 1 deletions
diff --git a/devel/plan9port/Makefile b/devel/plan9port/Makefile
index 9ad157bd2eb2..0bcf42e9bb08 100644
--- a/devel/plan9port/Makefile
+++ b/devel/plan9port/Makefile
@@ -3,6 +3,7 @@
PORTNAME= plan9port
PORTVERSION= 20140306
+PORTREVISION= 1
CATEGORIES= devel plan9
MASTER_SITES= http://swtch.com/${PORTNAME}/
@@ -43,6 +44,7 @@ post-patch:
> ${WRKSRC}/src/cmd/9term/${OPSYS}.c
@${REINPLACE_CMD} -e 's|, swizz(void)|&, swizz8(void)|' \
${WRKSRC}/src/cmd/xd.c
+ @${REINPLACE_CMD} -e '/^cd $$PLAN9/d' ${WRKSRC}/lib/moveplan9.sh
do-build:
cd ${WRKSRC} && CC9="${CC}" ./INSTALL
@@ -63,7 +65,7 @@ do-install:
${CP} -a ${WRKSRC} ${STAGEDIR}${PREFIX}
post-install:
- cd ${STAGEDIR}${PLAN9} && ${SETENV} PLAN9=${STAGEDIR}${PLAN9} \
+ cd ${STAGEDIR}${PLAN9} && ${SETENV} PLAN9=${PLAN9} \
PATH=${PATH}:${STAGEDIR}${PLAN9}/bin \
${SH} lib/moveplan9.sh ${WRKSRC}
${CHMOD} 01777 ${STAGEDIR}${PLAN9}/news