aboutsummaryrefslogtreecommitdiffstats
path: root/devel
diff options
context:
space:
mode:
authormiwi <miwi@FreeBSD.org>2007-10-10 21:39:45 +0800
committermiwi <miwi@FreeBSD.org>2007-10-10 21:39:45 +0800
commit90f244df62462fb416cdb3c37e6c7a0967e74d8f (patch)
treeb3dd9949d5c9029569b2fccda78c7d35a3d3474a /devel
parent42758becae4e8e1b3b7cde55666976780cb0443a (diff)
downloadfreebsd-ports-gnome-90f244df62462fb416cdb3c37e6c7a0967e74d8f.tar.gz
freebsd-ports-gnome-90f244df62462fb416cdb3c37e6c7a0967e74d8f.tar.zst
freebsd-ports-gnome-90f244df62462fb416cdb3c37e6c7a0967e74d8f.zip
Perl Console is a light program that lets you evaluate Perl code
interactively. It uses Readline for grabing input and provides completion with all the namespaces loaded during your session. This is pretty useful for Perl developers that write modules. You can load a module in your session and test a function exported by the module. Readline is used to grab user input and provides then all the facilities your are used to : completion, key bindings, ... WWW: http://www.sukria.net/perlconsole.html PR: ports/117056 Submitted by: Philippe Audeoud <jadawin at tuxaco.net>
Diffstat (limited to 'devel')
-rw-r--r--devel/Makefile1
-rw-r--r--devel/perlconsole/Makefile52
-rw-r--r--devel/perlconsole/distinfo3
-rw-r--r--devel/perlconsole/pkg-descr12
4 files changed, 68 insertions, 0 deletions
diff --git a/devel/Makefile b/devel/Makefile
index 2ab761bca747..92f74678a1bd 100644
--- a/devel/Makefile
+++ b/devel/Makefile
@@ -1794,6 +1794,7 @@
SUBDIR += pedisassem
SUBDIR += perforce
SUBDIR += performance
+ SUBDIR += perlconsole
SUBDIR += perltidy
SUBDIR += pharmacy
SUBDIR += php-dbg
diff --git a/devel/perlconsole/Makefile b/devel/perlconsole/Makefile
new file mode 100644
index 000000000000..7fdb81262de9
--- /dev/null
+++ b/devel/perlconsole/Makefile
@@ -0,0 +1,52 @@
+# New ports collection makefile for: perlconsole
+# Date created: 9 October 2007
+# Whom: Philippe Audeoud <jadawin@tuxaco.net>
+#
+# $FreeBSD$
+#
+
+PORTNAME= perlconsole
+PORTVERSION= 0.3
+CATEGORIES= devel
+MASTER_SITES= http://www.sukria.net/
+
+MAINTAINER= jadawin@tuxaco.net
+COMMENT= A light program that lets you evaluate Perl code interactively
+
+RUN_DEPENDS= ${BASEP}/Getopt/Long.pm:${PORTSDIR}/devel/p5-Getopt-Long \
+ ${BASEP}/${PERL_ARCH}/Term/ReadLine/Gnu.pm:${PORTSDIR}/devel/p5-ReadLine-Gnu \
+ ${BASEP}/Module/Refresh.pm:${PORTSDIR}/devel/p5-Module-Refresh \
+ ${BASEP}/Lexical/Persistence.pm:${PORTSDIR}/devel/p5-Lexical-Persistence
+
+BASEP= ${SITE_PERL}
+
+USE_PERL5= yes
+PERL_CONFIGURE= 5.8.0+
+
+PORTDOCS= README \
+ AUTHORS \
+ CHANGES
+
+PLIST_FILES= bin/perlconsole \
+ lib/perl5/${PERL_VER}/PerlConsole/Commands.pm \
+ lib/perl5/${PERL_VER}/PerlConsole/Console.pm \
+ lib/perl5/${PERL_VER}/PerlConsole/Preferences.pm \
+ lib/perl5/${PERL_VER}/PerlConsole.pm
+
+PLIST_DIRS= lib/perl5/${PERL_VER}/PerlConsole
+
+do-install:
+.if !defined(NOPORTDOCS)
+ ${MKDIR} ${DOCSDIR}
+.for i in README AUTHORS CHANGES
+ ${INSTALL_DATA} ${WRKSRC}/${i} ${DOCSDIR}
+.endfor
+.endif
+ ${MKDIR} ${PREFIX}/lib/perl5/${PERL_VER}/PerlConsole/
+ ${CP} -R ${WRKSRC}/lib/PerlConsole/ \
+ ${PREFIX}/lib/perl5/${PERL_VER}/PerlConsole/
+ ${CP} ${WRKSRC}/lib/PerlConsole.pm \
+ ${PREFIX}/lib/perl5/${PERL_VER}/PerlConsole.pm
+ ${INSTALL_SCRIPT} ${WRKSRC}/${PORTNAME} ${PREFIX}/bin/
+
+.include <bsd.port.mk>
diff --git a/devel/perlconsole/distinfo b/devel/perlconsole/distinfo
new file mode 100644
index 000000000000..0362f3ebbfad
--- /dev/null
+++ b/devel/perlconsole/distinfo
@@ -0,0 +1,3 @@
+MD5 (perlconsole-0.3.tar.gz) = 6ffecc40da21aa331ec1023446acc067
+SHA256 (perlconsole-0.3.tar.gz) = 66a3973652d0cd59e662edc17da4376ea8a7754e76b3dc346d49f87d9417e991
+SIZE (perlconsole-0.3.tar.gz) = 15580
diff --git a/devel/perlconsole/pkg-descr b/devel/perlconsole/pkg-descr
new file mode 100644
index 000000000000..d5fba7d3b2fd
--- /dev/null
+++ b/devel/perlconsole/pkg-descr
@@ -0,0 +1,12 @@
+Perl Console is a light program that lets you evaluate Perl code
+interactively. It uses Readline for grabing input and provides
+completion with all the namespaces loaded during your session.
+
+This is pretty useful for Perl developers that write modules. You can
+load a module in your session and test a function exported by the
+module.
+
+Readline is used to grab user input and provides then all the facilities
+your are used to : completion, key bindings, ...
+
+WWW: http://www.sukria.net/perlconsole.html