aboutsummaryrefslogtreecommitdiffstats
path: root/devel
diff options
context:
space:
mode:
authorgerald <gerald@FreeBSD.org>2013-08-18 00:27:24 +0800
committergerald <gerald@FreeBSD.org>2013-08-18 00:27:24 +0800
commit92621d361d009a9f1c5fbfe137cf9e878dbe34cf (patch)
treec1657d06d35b5f160b90b16620933ca757495766 /devel
parent9e9651b8c9f8d3ec1375dfb2e0d48a491ad6c121 (diff)
downloadfreebsd-ports-gnome-92621d361d009a9f1c5fbfe137cf9e878dbe34cf.tar.gz
freebsd-ports-gnome-92621d361d009a9f1c5fbfe137cf9e878dbe34cf.tar.zst
freebsd-ports-gnome-92621d361d009a9f1c5fbfe137cf9e878dbe34cf.zip
Replace USE_GCC=4.6+ and USE_GCC=4.4+ by USE_GCC=yes.
Right now this is a noop in the former case and a noop in the latter case unless lang/gcc44 has been installed explicitly. This puts a bit more emphasis on standardizing on a canonical version "current" GCC and makes it easier to update that canonical version by changing the default in Mk/bsd.gcc.mk and updating the lang/gcc port. That is, USE_GCC=yes means "use a decent/modern version of GCC" without having to worry about details. Approved by: portmgr (bdrewery)
Diffstat (limited to 'devel')
-rw-r--r--devel/astyle/Makefile2
-rw-r--r--devel/clanlib/Makefile2
-rw-r--r--devel/cocaine-core/Makefile2
-rw-r--r--devel/covtool/Makefile2
-rw-r--r--devel/freeocl/Makefile2
-rw-r--r--devel/kdevelop-pg-qt/Makefile2
-rw-r--r--devel/libYGP/Makefile2
-rw-r--r--devel/libclaw/Makefile2
-rw-r--r--devel/msgpack/Makefile2
-rw-r--r--devel/nemiver/Makefile2
-rw-r--r--devel/p5-perlkde/Makefile2
-rw-r--r--devel/pure-stldict/Makefile3
-rw-r--r--devel/raknet/Makefile2
13 files changed, 13 insertions, 14 deletions
diff --git a/devel/astyle/Makefile b/devel/astyle/Makefile
index 2e3211672c6f..58aed754df9b 100644
--- a/devel/astyle/Makefile
+++ b/devel/astyle/Makefile
@@ -15,7 +15,7 @@ CFLAGS+= -W -Wall -fno-rtti -fno-exceptions
LDFLAGS+= -s
MAKE_ARGS+= CFLAGS="${CFLAGS}"
USE_GMAKE= yes
-USE_GCC= 4.4+
+USE_GCC= yes
WRKSRC= ${WRKDIR}/astyle/build/gcc
diff --git a/devel/clanlib/Makefile b/devel/clanlib/Makefile
index 6592c0bcf2ea..d94b0a973266 100644
--- a/devel/clanlib/Makefile
+++ b/devel/clanlib/Makefile
@@ -24,7 +24,7 @@ LIB_DEPENDS= jpeg:${PORTSDIR}/graphics/jpeg \
pcre:${PORTSDIR}/devel/pcre
USE_GMAKE= yes
-USE_GCC= 4.6+
+USE_GCC= yes
USE_XORG= x11
USES= pathfix pkgconfig
USE_LDCONFIG= yes
diff --git a/devel/cocaine-core/Makefile b/devel/cocaine-core/Makefile
index 2eb4d0133f4a..7ee7118b9f6e 100644
--- a/devel/cocaine-core/Makefile
+++ b/devel/cocaine-core/Makefile
@@ -20,7 +20,7 @@ LIB_DEPENDS= boost_iostreams:${PORTSDIR}/devel/boost-libs \
zmq:${PORTSDIR}/devel/zmq
USES= cmake
-USE_GCC= 4.6+
+USE_GCC= yes
USE_LDCONFIG= yes
USE_GITHUB= yes
GH_ACCOUNT= zloidemon
diff --git a/devel/covtool/Makefile b/devel/covtool/Makefile
index b6765c307976..70ca334923f1 100644
--- a/devel/covtool/Makefile
+++ b/devel/covtool/Makefile
@@ -11,7 +11,7 @@ COMMENT= C++ test coverage analyzer
WRKSRC= ${WRKDIR}
USE_ZIP= yes
-USE_GCC= 4.6+
+USE_GCC= yes
USE_GMAKE= yes
MAKEFILE= makefile
diff --git a/devel/freeocl/Makefile b/devel/freeocl/Makefile
index ace9d545efab..ce544fbdbf03 100644
--- a/devel/freeocl/Makefile
+++ b/devel/freeocl/Makefile
@@ -17,7 +17,7 @@ LICENSE= LGPL3
WRKSRC= ${WRKDIR}/FreeOCL-${PORTVERSION}-Source
-USE_GCC= 4.6+
+USE_GCC= yes
USES= cmake
USE_LDCONFIG= yes
CMAKE_BUILD_TYPE=Release
diff --git a/devel/kdevelop-pg-qt/Makefile b/devel/kdevelop-pg-qt/Makefile
index f0093fcb7431..ce1e0a8a1105 100644
--- a/devel/kdevelop-pg-qt/Makefile
+++ b/devel/kdevelop-pg-qt/Makefile
@@ -16,7 +16,7 @@ COMMENT= Parser-generator from KDevplatform
BUILD_DEPENDS= ${LOCALBASE}/bin/flex:${PORTSDIR}/textproc/flex
-USE_GCC= 4.6+
+USE_GCC= yes
USE_BZIP2= yes
USES= bison cmake:outsource
USE_KDE4= automoc4 kdehier kdelibs kdeprefix
diff --git a/devel/libYGP/Makefile b/devel/libYGP/Makefile
index fcbceeae0beb..8b691c3a1798 100644
--- a/devel/libYGP/Makefile
+++ b/devel/libYGP/Makefile
@@ -15,7 +15,7 @@ LIB_DEPENDS= gmp.10:${PORTSDIR}/math/gmp \
boost_filesystem:${PORTSDIR}/devel/boost-libs
USE_BZIP2= yes
-USE_GCC= 4.6+
+USE_GCC= yes
GNU_CONFIGURE= yes
USES= pathfix pkgconfig gettext
USE_LDCONFIG= yes
diff --git a/devel/libclaw/Makefile b/devel/libclaw/Makefile
index e0ae701dbdfc..542d341db3fc 100644
--- a/devel/libclaw/Makefile
+++ b/devel/libclaw/Makefile
@@ -16,7 +16,7 @@ BUILD_DEPENDS= ${LOCALBASE}/include/boost/bind.hpp:${PORTSDIR}/devel/boost-libs
USES= cmake gettext
CMAKE_ARGS= -DCLAW_CMAKE_MODULES_INSTALL_PATH="${DATADIR}/cmake"
USE_LDCONFIG= yes
-USE_GCC= 4.6+
+USE_GCC= yes
post-patch:
@${REINPLACE_CMD} -e '/subdirs/ s|doc||' ${WRKSRC}/CMakeLists.txt
diff --git a/devel/msgpack/Makefile b/devel/msgpack/Makefile
index 350b552097d3..81c4df5757fd 100644
--- a/devel/msgpack/Makefile
+++ b/devel/msgpack/Makefile
@@ -20,7 +20,7 @@ USE_LDCONFIG= yes
.if ${ARCH} == "sparc64"
# required for __sync _* atomic operations on sparc
-USE_GCC= 4.4+
+USE_GCC= yes
.else
USE_GCC= 4.2+
.endif
diff --git a/devel/nemiver/Makefile b/devel/nemiver/Makefile
index f6a285e45248..bebe3be4d683 100644
--- a/devel/nemiver/Makefile
+++ b/devel/nemiver/Makefile
@@ -28,7 +28,7 @@ CONFIGURE_TARGET=--build=${MACHINE_ARCH}-portbld-freebsd${OSREL}
CONFIGURE_ENV= ac_cv_path_GDB_PROG=${LOCALBASE}/bin/gdb
USE_GMAKE= yes
USE_GNOME= gnomeprefix gnomehack intltool gnomedocutils gconf2 vte
-USE_GCC= 4.4+
+USE_GCC= yes
USE_LDCONFIG= yes
USES= gettext
INSTALLS_OMF= yes
diff --git a/devel/p5-perlkde/Makefile b/devel/p5-perlkde/Makefile
index d1edb4e48fde..b762ab4b58ef 100644
--- a/devel/p5-perlkde/Makefile
+++ b/devel/p5-perlkde/Makefile
@@ -14,7 +14,7 @@ COMMENT= Perl bindings for KDE
USE_XZ= yes
USE_PERL5= yes
# Build fails with system gcc
-USE_GCC= 4.6+
+USE_GCC= yes
USE_KDE4= kdehier kdeprefix perlqt smokekde automoc4
USE_QT4= network opengl sql svg xml \
qmake_build moc_build uic_build rcc_build
diff --git a/devel/pure-stldict/Makefile b/devel/pure-stldict/Makefile
index 432793b55613..2b2ec2f5b628 100644
--- a/devel/pure-stldict/Makefile
+++ b/devel/pure-stldict/Makefile
@@ -10,8 +10,7 @@ COMMENT= Pure interface to C++ STL map/unordered_map
USE_PURE= yes
-USE_GCC= 4.6+
-CXX= g++${GCC_DEFAULT_V}
+USE_GCC= yes
CXXFLAGS+= -std=c++0x -DHAVE_STD_IS_PERMUTATION
.include "${.CURDIR}/../../lang/pure/bsd.pure.mk"
diff --git a/devel/raknet/Makefile b/devel/raknet/Makefile
index 65b0e6e87e2e..8a8dfb9b0060 100644
--- a/devel/raknet/Makefile
+++ b/devel/raknet/Makefile
@@ -28,7 +28,7 @@ USE_LDCONFIG= yes
USE_DOS2UNIX= yes
DOS2UNIX_REGEX= .*\.(cpp|h|txt)
-USE_GCC= 4.6+
+USE_GCC= yes
USE_GMAKE= yes
USES= cmake